Cannot join the domain with Windows 2008 Server

Discussion in 'Windows 7 Networking' started by jtnktz, Mar 8, 2010.

  1. jtnktz

    jtnktz New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    I am trying to connect Windows 7 to the domain of a Windows 2008 Server. We have ~20 other Windows XP clients able to join and connect to the domain.
    I get this error message when trying to join the domain:

    An attempt to resolve the dns name of a domain controller in the domain being joined has failed.

    I have the TCP/IP set to obtain the IP automatically and the DNS as static with the correct DNS IP.

    I can ping the server using both it's IP and host name.
    DNS functions propperly when the host name is typed into the URL bar.

    Any ideas?
     
  2. jtnktz

    jtnktz New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    It also says that I have limited connection but I think that is because the network that all these computers are connected to is not connected to the web.
     
    #2 jtnktz, Mar 8, 2010
    Last edited: Mar 8, 2010
  3. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Try ipconfig /flushdns
    and then ipconfig /registerdns
    Also right click computer, choose properties, click the link to "Change Settings" by the computer name, domain and workgroup settings area, then click the change button, and then the more button and add your mydomain.whatever in the primary DNS suffix of this computer box.
     
  4. jtnktz

    jtnktz New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Alright I will do that next time I go into class. I forgot to mention but we tried this on 2 machinces with Windows 7 and got the same response. We have other computers running XP and can join the domain, log onto the domain with ease.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Check the ipconfig /all information on the problem machines and make sure that the only DNS resolver listed is the domain DNS server.
    Check the DNS info on the server (forward and reverse lookup zones) for information regarding the problem machines, edit or delete any bad entries.
    Check AD for pre-existing machine accounts for the problem machines, remove and try rejoining from the individual machines rather than creating accounts in advance.
     
  6. Sliver

    Sliver New Member

    Joined:
    Sep 11, 2009
    Messages:
    46
    Likes Received:
    2
    Also, make sure the time is not off by a lot on the windows 7 boxes. If it is off by more than 10 or so minutes, it may not join the domain. If the time looks right, verify the time zones, just to make sure that they are the same... (they may both say 4:30pm, but if they are in different time zones, then the time is off).
     
  7. jtnktz

    jtnktz New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Did the ipconfig /flushdns /registerdns but its still not working.
    When I did the bolded part I get the same error.
     
  8. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Not sure, what could be going on here. Could you post a screen shot of an ipconfig /all from the Win7 machine and from the server. Also check member Sliver's post above, double check dates, time, time zones, etc.
    Is the AD Domain Controller, the server that is hosting DNS as well as doing the DHCP provisioning for the network?
     
  9. nugget

    nugget New Member

    Joined:
    Jan 29, 2010
    Messages:
    4
    Likes Received:
    0
    What version of Windows 7 do you have?
     
  10. jtnktz

    jtnktz New Member

    Joined:
    Mar 8, 2010
    Messages:
    10
    Likes Received:
    0
    Alright, I set the time correctly and still nothing.

    Although I have reason to believe that DNS is only partially functioning. Reason for this is because nslookup does not work but you can typer server1 into the URL bar and come up with the homepage and/or you can ping server1.

    I removed than added the DNS role and still nothing... Remember this is part of a High School Class so we are all still learning (Studying for CompTIA Network+).

    Keep in mind this is an intranet so no outside internet connection!!!
     
  11. Sliver

    Sliver New Member

    Joined:
    Sep 11, 2009
    Messages:
    46
    Likes Received:
    2
    When you go under Network and Sharing Center, does your network show up as Home, Work or Public? You want to make sure it is set to Work (Home would work too, but stick to work). You could shutoff the firewall completely, if you haven't already.

    Also, check to make sure none of the items under your Network Adapter settings are unchecked. You need to have Client for Microsoft Networks enabled, which is by default, but worth asking.

    I am sure there is something simple missing, and I think you are right to be looking at DNS, since it is so tightly integrated into Active Directory. When you re-installed DNS on the Windows 2008 server, you did make sure it was AD Integrated, correct? NSLOOKUP should work.. when you first go into it, just type:

    server {ip address of DNS server} and hit enter

    then do your machine name lookup, or lookup of the domain controller... etc.

    Other than that, good luck!!
     
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Check the DNS server for host records, make sure you machine name and ip address is included in the forward lookup zone. As well as a ptr record in reverse lookup.
    Is the DNS server is also excluded from an internet connection?
    Open the host file on your machine and at the bottom add the ip address and FQDN of the DNS server without any # sign. Something like
    192.168.nnn.nnn ServerName.YourDomain.Local (or whatever) Hosts file is found here C:\Windows\System32\drivers\etc\hosts
    Make sure that the DNS server is pointing to itself for DNS resolution.
    Then on you Win7 machine from a command prompt type
    ipconfig /flushdns and then
    ipconfig /registerdns
    What is the Network and Sharing Center saying about your network connection?
    What are you using in class for a default gateway?
     

Share This Page

Loading...