Cannot override "permission required" to copy/paste DLL file (user account set to "never notify me")

Discussion in 'Windows 7 Help and Support' started by InjunJoe, May 6, 2010.

  1. InjunJoe

    InjunJoe New Member

    Joined:
    Oct 30, 2009
    Messages:
    16
    Likes Received:
    0
    Hello,

    For days now, I've been looking to solve an issue I'm having regarding the permission settings. It's driving me bonkers ! For whatever reason I simply cannot move a specific dll file, I then get the following message : "you require permissions from Everyone to make changes to this file" ==> it says "make changes" although all I want to do is copy and paste the dll file elsewhere...

    So far, I've tried running the takeownership program, I've ran Registry Booster (who knows?), of course my user account settings are on "never notify me" AND YET I just can't copy/paste this dll file.

    I've got all the latest Win7 (64-bit) updates, AVG 9 AV+firewall (which I even turned off), I'm running an AMD Phenom II x4 3.00 Ghz, 4,00 GB RAM...and that's about it I guess.

    I've googled this issue to death but haven't found any practical solutions. Can anyone please help?
     
  2. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    Go to the folder you want highlight it go to properties select security go to edit then add and enter the name everyone form there you can give everyone the permissions desired
    hope this helps
     
  3. InjunJoe

    InjunJoe New Member

    Joined:
    Oct 30, 2009
    Messages:
    16
    Likes Received:
    0
    I'd like to do that, the thing is though, when I right click=>properties=>there's only 3 tabs: General|Sharing|Customize => no Security tab :confused:
     
  4. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    Can you get a security tb by doing it for the C drive itself
     
  5. InjunJoe

    InjunJoe New Member

    Joined:
    Oct 30, 2009
    Messages:
    16
    Likes Received:
    0
    Yes :)

    If it matters, the dll file I would like to copy/paste is actually from a mounted image (iso file).
     
  6. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    I do not know if it matters or not but try pasting it on your desktop. If it does not paste there it maybe because it is an ISO problem
     
  7. InjunJoe

    InjunJoe New Member

    Joined:
    Oct 30, 2009
    Messages:
    16
    Likes Received:
    0
    This is precisely what I've been trying to do and the reason I created this thread hence I cannot copy/Paste the dll file to desktop.

    I also encounter this problem with certain other dll files but NOT from iso files...

    It's getting to a point where it's ridiculous that I can't decide what I'd like to do with my own computer although the user account is on "never notify" and yet win 7 STILL interferes when not asked to, I'd like it to stop ! I'd like to claim back full control.

    So what am I supposed to do ? This is SO irritating.
     
  8. InjunJoe

    InjunJoe New Member

    Joined:
    Oct 30, 2009
    Messages:
    16
    Likes Received:
    0
    Ok, I just downloaded the dll file (so it isn't from an ISO).

    It's still the exact same problem...says need permission for administrator (me!) => I checked security is on FULL CONTROL and it still keeps annoying me !

    I mean WTF am I supposed to do, I'm going nuts over here.
     
  9. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    Were you looking for the Security Tab under the DLL file? If so that is not what you change it is not there look for it under the folder the file is in see example of Image also note un-check the read only if checked as shown in example image
    [​IMG]
    The security tab I was speaking about is for the folder the file is in.
     
  10. InjunJoe

    InjunJoe New Member

    Joined:
    Oct 30, 2009
    Messages:
    16
    Likes Received:
    0
    Yes I did click on the folder containing the dll file. But it's still the same story : need permission from myself (basically).
    I also unchecked read-only to no avail.
    It says "name of the account" needs to give permission eventhough that account effectively has full control !!
     
  11. Super Sarge

    Super Sarge New Member

    Joined:
    Jun 4, 2009
    Messages:
    1,737
    Likes Received:
    64
    I hope someone can help you, I know you said you tried taking ownership of the file which one the one from the ISO? or the one in the folder you want to paste it to? if it is the ISO one you cannot most likely do thsat but if it is the one in that you want to replace try it again. The only other thing I can say is create an another USER with Administrative permissions and try everything you have tried under the new account you created.

    If none of these work it will be beyond my limited expertise.
     
  12. XxXDaRkXxX

    XxXDaRkXxX New Member

    Joined:
    Jun 6, 2010
    Messages:
    2
    Likes Received:
    0
    well :) try copying it in safe mode worked for me
     
  13. Sam Perry

    Sam Perry New Member

    Joined:
    Aug 20, 2010
    Messages:
    2
    Likes Received:
    0
    Ive got an idea. so you say the .dll is in an iso then im presuming you are using power iso or equivalent. try to extract the dll from the iso directly into the place you want it and that should work. good luck.
     
  14. Scott Kiely

    Scott Kiely New Member

    Joined:
    Aug 1, 2011
    Messages:
    2
    Likes Received:
    0
    Hi.

    Not sure if this thread is [Solved], but I found out the solution.
    Turn off your anti-virus and it should work, your A-V is blocking the .dll and won't let it onto the system.

    Regards.
     
  15. Jjara

    Jjara New Member

    Joined:
    Nov 19, 2011
    Messages:
    2
    Likes Received:
    0
    Done it! What i did was extracting the whole iso to a folder in the desktop, then i went to microsoft security essentials, configs and added the .dll extension to the exceptions, ta ta! it worked like a charm, no permission from anyone, seems like the antivirus found something it didnt like in the file... anyway, I hope that helps, oh and you can still remove the .dll from the exceptions after you paste the file in the folder
     
  16. BijouxKitty

    BijouxKitty New Member

    Joined:
    Aug 30, 2013
    Messages:
    2
    Likes Received:
    0
    How did you added the .dll extension to the exceptions?
     
  17. BijouxKitty

    BijouxKitty New Member

    Joined:
    Aug 30, 2013
    Messages:
    2
    Likes Received:
    0
    Solved it :)
     
  18. Dageek

    Dageek New Member

    Joined:
    Oct 19, 2013
    Messages:
    1
    Likes Received:
    0
    There's an easier way to do it to be honest, you just download WinRAR Archiver, and right click on the .ISO file and click on "open with" and you use WinRAR Archiver, it opens the file and therefrom it overwrites any of the requirements for the files within, and remember to turn off your MSE in any way, else it just deletes the file. Hope you can use this even though you've already solved the problem :)
     
  19. Flavius Ibanescu

    Flavius Ibanescu New Member

    Joined:
    Dec 26, 2013
    Messages:
    1
    Likes Received:
    0
    It's easy, if you open with WinRar, which is possible for an .iso, then extract .dll files where you want.
     
  20. Myles Hamilton

    Myles Hamilton New Member

    Joined:
    Jan 9, 2014
    Messages:
    1
    Likes Received:
    0
    Hay guys, i've been reading what you have put and its got me farther than i was before but when i go to right click the .ISO file there's no "open with" option. Any ideas?
     

Share This Page

Loading...