Cannot run Installshield wizard.

#1
I have been trying to install an incredibly important program called NovaNet which I use for my classes. If I can't install this, then I can't do my classwork and get my credit. The program is certified to run on XP and Vista, so I figured that if it can run on Vista then it can run on 7.

It uses Installshield, and after trying to find a solution, I discovered that other people were having problems with Installshield wizards. I get the following message when trying to run it:

This installation package could not be opened. Contact the application vendor to verify that this is a valid Windows Installation package.
I hit OK and it closes out. I've tried running it as administrator (even though it should automatically do so since my user is the administrator) and I've tried running it in compatibility mode (XP SP2 and SP3, Vista SP1), but it turns up the same message regardless, and this is what leads me to believe it has something to do with Windows Installer.


So is there any work-around for this? This situation is making me regret upgrading to Windows 7. I would really like to not have to go back to XP since I also had to order a new sound card since my current one is so old that there's no support for it any longer and Windows 7 doesn't even detect it. I had to spend 30 bucks (including tax and shipping) on one so I'd like to not make that a waste either.
 


Last edited:

reghakr

Essential Member
#2
Try run as administrator when double-clicking on the executable file.
 


#3
Yes I have tried all of that already. Compatibility mode does nothing either.
 


#4
I'll go try that right now. Thanks.
 


#5
That sounds quite helpful.

Edit: Well I got it up and running nice and easy. However, the installer still doesn't work. :(
 


Last edited:
This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.