Cannot write to Samba Share

Discussion in 'Windows 7 Networking' started by Han, Jan 12, 2011.

  1. Han

    Han New Member

    Joined:
    Jan 12, 2011
    Messages:
    6
    Likes Received:
    0
    I set up a Linux machine I want to use as a fileserver. I set up Samba I can see a folder I share that is on the same hard drive as the operating system (Ubuntu), from my Windows 7 machine, but I cannot write to it. I set read/right privledges in the Samba GUI.

    I want to eventually be able to share another hard drive that I have on the machine, but W7 will not even let me look at files on that.

    Any suggestions?

    Thank You

    Chris
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You may have to make adjustments to NTLMv2 settings.
    Launch the local security policy management console by typing secpol.msc into the search box and hitting enter.
    Scroll as needed and change
    Network security: LAN Manger authentication level from Send NTLMv2 response only to
    Send LM & NTLM - use NTLMv2 session security if negotiated.
    See attachment.
    You may also have to alter the Minimum session security for clients and servers but hold off until adjusting the first setting and rebooting
     
    #2 Trouble, Jan 12, 2011
    Last edited: Jan 12, 2011
  3. Han

    Han New Member

    Joined:
    Jan 12, 2011
    Messages:
    6
    Likes Received:
    0
    No luck, what should I change the minimum security settings too?
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Experiment. First drop them to no minimum by unchecking both option boxes. Reboot.
    If that resolves the issue, go back and try the 128 box and see if that works.
     
  5. kd833

    kd833 New Member

    Joined:
    Sep 16, 2014
    Messages:
    5
    Likes Received:
    0
    Not able to share/read/write "from" Windows "to" Linux. It's a Samba problem.
    - check firewall, user/samba account, file/driectory permissions, smb conf file, selinux
    Not able to share/read/write "from" Linux "to" Windows. It's a Windows problem.
    - check sharing options, local security policies, firewall
    You'll have to experiment as others have said and report back with the specific settings you've made and any error messages you are receiving on "both" platforms to narrow it down.

    http://answers.microsoft.com/en-us/windows/forum/windows_7-networking/i-want-to-prevent-the-use-of-the-loginpassword/e6a0138f-d6e0-4111-8d14-a5d3539f701c
     

Share This Page

Loading...