Canon SD1000 driver

Discussion in 'Windows 7 Help and Support' started by MacSkip, Feb 23, 2012.

  1. MacSkip

    MacSkip Well-Known Member

    Feb 23, 2012
    Likes Received:
    Until a week or so ago, my Canon PowerShot SD1000 camera worked just fine. I bought a new Gateway DX4860 desktop last December and was importing pictures from my camera using Picasa 3 with no problem -- did it several times. (I connect with a USB cord.)

    Then about a week ago I could not get my computer to "see" the SD1000 -- absolutely nothing. A friend thinks that the driver is corrupted, but I can't seem to delete any driver for my SD1000 camera. My wife has a SD600 and that connects to my new desktop OK. I even tried putting the memory chip from my SD1000 into her SD600 and that works OK, but her chip in my camera does nothing and the SD1000 camera is still not recognized. :(

    Another friend suggested connecting my SD1000 and then looking at DeviceMgr -> PortableDevices, but my Canon camera doesn't show up there. When it's connected, it isn't recognized in the Start -> Device and Printers window (but the SD600, when connected, does show up there). :confused:

    If you have any clues about what's happening and how I can return to having my SD1000 recognized, I'll be most appreciative. :D
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Oct 16, 2009
    Likes Received:
    We have had several folks talking about problems with their USB devices in the last week or two. Since Update Tuesday was done recently, hopefully some change in it isn't involved.

    Her camera does work on your computer?

    Have you tried changing the USB port? It is suppose to cause it to load a driver for the new port.

    Any chance the USB cable is bad? Do you have another device that can read your flash card, like a printer?

    I don't know if it matters, but the camera is charged or plugged in? Any batteries need replacing, maybe a small one that keeps the memory alive?

Share This Page