Can't access local computer using Remote Desktop - Username or Password Incorrect

:(:( I have been trying to log on remotely from a Windows 7 Professional machine into my personal machine that is also running Windows 7 Professional on the same network. Following is some setup points.
1) My personal/host computer is assigned a static IP address
2) I can ping my personal computer from the other computer successfully
3) I have set up to allow remote logon/access.
4) I have made sure the firewall is allowing remote logon and other remote access passthroughs that are required
5) I have set up my administrator user account with a password
6) Checked the name of my computer using ipconfig
7) Reset my user password (for fun) and can logon to my machine locally without any problem

I have checked, double checked, triple tested everything and I know that this should work because I have set up another machine on the network with identical setup parameters and it works just fine (different user and password, etc.).

When I go to the other machine on our network that has Windows 7 Premium installed and access the Remote Desktop Client, I type in the which is my static IP address and the name of my computer and it asks me for a password. The correct name of my computer obviously shows (I told it that previously) and when I press enter it appears to find my personal machine because it throws up the special bar at the top of the screen showing the and then it gives me the response "The username or password is incorrect".

Not sure how I can have the wrong username and password when I logon to the machine daily with it without any problem. Any help would be greatly appreciated, and thanks in advance.

Try This..

Instead of using the other computer's network I.D. to remote to it. Try connecting to the other computer while it is logged off, using it's I.P. address. Just the I.P address of the computer you are trying to connect to. Make sure you are using the same credentials that would log you on to that computer if you were sitting at it. Also, make sure port 3389 is open in your windows firewall for your private network only. You do this by creating a new rule for inbound connections on the remote computer's firewall.

  • Open Windows Firewall by clicking the Start button, clicking Control Panel, clicking Security, and then clicking Windows Firewall.
  • Click Allow a program through Windows Firewall. If you are prompted for an administrator password or confirmation, type the password or provide confirmation.
  • Click Add port.
  • In the Name box, type a name that will help you remember what the port is used for.
  • In the Port number box, type the port number.
  • Click UDP, Remote Desktop is UDP
  • To change scope for the port, click Change scope, and then click the option that you want to use. ("Scope" refers to the set of computers that can use this port opening.)

Windows Password Key 8.0

Windows Password Key 8.0 is considered as the best tool to reset local administrator and user passwords on any Windows system. It creates a password recovery CD/DVD, USB Flash Drive for home, business and enterprise with an extremely competitive price. And most of all, it's the most popular and safe solution for removing your Windows password until now。
You can google to find your best:

Have you seen this information on networking with Windows 7 Professional? It includes the Domain Join function as well as HomeGroup. Go to to see more.

I had sort of the same problem. In my case, in Windows installation I mistyped my name, switching two letters. When I first log-in, I realized my mistake and went to Control Panel - Users Accounts to rename it. After three weeks I decided to use Remote Desktop, and forgeting about that situation, I spent 3 days struggling with this error, and so I finally realized, just typed the wrong name and everything turned out fine. If this is your case, you can check it out in "C:\users" folder and see how your username will be recognized by Remote Desktop. Hope it helps.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.