Can't Boot from CD-ROM in AHCI mode

Discussion in 'Windows 7 Software' started by Seventy Nine, Feb 9, 2011.

  1. Seventy Nine

    Seventy Nine Well-Known Member

    Joined:
    Sep 28, 2010
    Messages:
    37
    Likes Received:
    6
    I'm trying to do a startup repair of Windows 7 x64 on an SSD but can't boot from the CD-ROM while in AHCI mode. I have set CD-ROM at the top of the boot order in BIOS but this is just ignored and the computer boots from the SSD with the knackered version of W7x64.

    I read somewhere that when in AHCI mode, the BIOS boot order may include "CD-ROM" but it's not the real device anymore. I tried looking for the CD-ROM by its manufacturer name in the list under Hard Drives but it's not there either.

    So just how do I go about booting from the CD-ROM in AHCI mode? No problems booting if I set the BIOS back to IDE mode, install Windows 7 and then do the registry hack to install the AHCI drivers, but I'd like to be able to boot from the CD-ROM in AHCI mode.

    P.S. I have a Gigabyte GA-MA78GM-US2H motherboard and am using the latest BIOS version (F9D)
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Boot device priority usually works flawlessly. DVD-ROM must be 1st boot device.
    If no luck still, see if your motherboard has a key to select the boot device on start after POST. (F4 in my case).
     
  3. Seventy Nine

    Seventy Nine Well-Known Member

    Joined:
    Sep 28, 2010
    Messages:
    37
    Likes Received:
    6
    The "First Boot Device" and "Hard Disk Boot Priority" did work flawlessly with the "OnChip SATA Type" set to IDE. The problem was when I set the "OnChip SATA Type" to AHCI.

    Having gone a little further down the Integrated Peripherals page in BIOS I found a separate "OnChip SATA Port4/5" setting which could be IDE or SATA. I'd mistakenly set this to SATA when I set the "OnChip SATA Type" to AHCI. The Boot Priority only works properly if the CD-ROM is plugged in to the SATA2_4 connector and the "OnChip SATA Port4/5" is set to "Native IDE"

    I'd actually tried setting it to IDE at some stage but I mixed up the SATA cables (all yellow) and still had a HDD plugged in to the SATA2_4 connector on the motherboard. Apart from me taking more care in tracing back which cable was connected to which device, it would have helped if the manual had had mentioned that the IDE setting was needed to boot from an optical drive.

    Anyway, problem solved and to answer my question - Yes you can boot from CD-ROM in AHCI mode - all you have to do is take a little care with the BIOS settings.
     

Share This Page

Loading...