Can't Change Desktop Background after the "Windows Repair Virus"

#1
Windows 7 Home Premium 64 bit

So I had the "Windows Repair" virus. I succesfully removed it with MalwareBites and Ad Aware and everything seems to be working fine, with exception to my desktop background. It's pitch black.

When I try to change it through personalize ->desktop backgrounds nothing happens, I can only change my background to some collor, for example from all black to all white etc.

When I open My Themes folder, it's totally empty.

When I try opening a picture and pushing "set as background image" it says : "the image can't be set as background. Internal error occured".

Also, I don't know if it's relevant, but the virus hid some files, like my documents and internet explorer shortcut and so on. I used unhider.exe to unhide them. Also scanned my computer a couple of more times and there's no trace of adware or viruses anymore. However, I also noticed Windows Repair file can't be located, and I don't have the windows disk ( It's a Toshiba Satellite, which doesn't come with a windows cd). So frustrating...

So thanks for the help, cheers.
 


zvit

Honorable Member
#2
A few things to try:

1. Go to Control Panel \ Appearance \ Personalization. Click "Show hidden files and folders". It's right next to folder options, then check the box for "show hidden files, folder, and drives". Click Ok. Now, navigate to C:\Users\[YOUR_USERNAME]\ AppData\ Roaming\ Microsoft\ Windows\ Themes. If there's a wallpaper(s), delete it. If there's an .ini file, open it with Notepad and erase the contents. Reboot.

2. To get more technical and manual: Desktop Background - Specify and Prevent Change - Windows 7 Forums
Desktop Background - Allow or Prevent Changing - Windows 7 Forums

3. It might be a corrupt user account. If none of the above helped we can create a new admin account. (Form Microsoft).

4. If Windows isn't activated this might cause it.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#3
It seems I had something like that once and believe I chose another type of background in the Personalize window. If you are using Aero backgrounds, you might try changing it back to Basic or High Contrast. If already using this one, change it back to Aero.

It can be a little confusing since all the choices are not shown directly in the window.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
You might also check the Ease of Access settings in Control Panel.
 


#5
I had the same issue and zvit's solution worked for me.

A few things to try:

1. Go to Control Panel \ Appearance \ Personalization. Click "Show hidden files and folders". It's right next to folder options, then check the box for "show hidden files, folder, and drives". Click Ok. Now, navigate to C:\Users\[YOUR_USERNAME]\ AppData\ Roaming\ Microsoft\ Windows\ Themes. If there's a wallpaper(s), delete it. If there's an .ini file, open it with Notepad and erase the contents. Reboot.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top