Cant change language

Discussion in 'Windows 7 Help and Support' started by oren, Jul 25, 2010.

  1. oren

    oren New Member

    Joined:
    Jul 25, 2010
    Messages:
    8
    Likes Received:
    0
    Well sometimes I have really weird problem Sometimes I cant change the keyboard language I have Hebrew and English in my keyboard and sometimes Its get stuck on hebrew or english , When I press Alt+Shift it normally change the language but sometimes it get stuck on 1 language and I need to restart the app (windows office , google chrome ex..) to get the language to change ,and this happend to me in the first time I installed windows 7 and after I upgraded my PC I made a fresh install and the same problem came again.

    It happens in allot of programs, And I cant figure out what causing this



    I made a video so you can see whats going on. Please help.

    (windows 7 ultimate)

    Code:
    
    http://www.youtube.com/watch?v=qG2WxbeHmE4
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I wish I could help but I do not have any experience with changing languages. Have you run this type of operation is other OSes and did they work as you feel they should?

    Do the ALT keys work differently depending on whether you use the right or left ones?

    Have you been able to see anything in common with what you are doing when the lockups occur?

    Have you checked the event viewer to see if any errors or warnings are showing up concerning the situation?

    How much memory do you have and are you running a 32 or 64 bit version of Win 7?

    Have you checked for a newer keyboard driver?
     
    Trouble and (deleted member) like this.
  3. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    cybercore and (deleted member) like this.
  4. oren

    oren New Member

    Joined:
    Jul 25, 2010
    Messages:
    8
    Likes Received:
    0
    @Saltgrass
    I dont think its the keyboard.
    Because as you can see in the video the language bar does change.. but it just does not write..
    I have 32bit and 2gb memory crosir
    @zvit now doing as you suggested will report back.
     
    #4 oren, Jul 31, 2010
    Last edited: Jul 31, 2010
  5. oren

    oren New Member

    Joined:
    Jul 25, 2010
    Messages:
    8
    Likes Received:
    0
    @zvit
    What you suggested is for windows xp.. Not for windows 7 ..

    Anyone what can I do now?
     
  6. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Let's see if your settings are correct.
    Go to the keyboard settings (right-click language bar > Settings > Advanced Key Settings > Change key sequence. There are actually two settings: "Switch input language" and "Switch keyboard layout". Set "Switch input language" to Left Alt+Shft and set "Switch keyboard layout" to Ctrl + Shft.

    Also , try to create a new account and see if the problem is there. You can copy language settings from account to account here: (Scroll down to posts at bottom of page).
    http://www.sevenforums.com/general-discussion/11334-language-bar-welcome-screen.html

    Also, Is this a legal copy of Windows 7 with a valid product key number? If not, that could be a cause for the language bug.
     
    #6 zvit, Jul 31, 2010
    Last edited: Jul 31, 2010
  7. oren

    oren New Member

    Joined:
    Jul 25, 2010
    Messages:
    8
    Likes Received:
    0
    @zivt
    My setting are correct...
     
  8. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    As Zvit said, it's a known bug. I believe this problem is related to the general input method in windows os. If your language input doesn't switch in an application, click on the line where you need to type (even if the keyboard focus is already there), and press the key sequence again.
     

Share This Page

Loading...