Can't connect to integrated router - Quite advanced issue [SOLVED]


I noticed that you had earlier reset the IP stack, I assume with
netsh int ip reset
Did you at that time also reset the Winsock Catalog with
netsh winsock reset
restart computer
If not give it a try it's not going to hurt and may just break something loose.

I did not try it, I tried it then after you suggested it.
Restarted the computer directly after. This had no affect in my eyes in regards to connecting to the modem at my end of the house with an ethernet cable. The connection still says it has no IPv4 or IPv6 connectivity under the local area connection status window. Wireless adapter still stays disabled and wont enable even after saying it does enable... Just as it did before. Which is weird, obviously something in regards to the device driver or hardware has gone wrong.

Also double check the properties of the problem NIC, type
into the run dialog box (win logo key + r) and hit enter
right click the problem NIC and choose properties
In the "This connection uses the following items: box
Make sure there are no entries pertaining to old security suites or random services that are no longer used.


AVG free virus protection was forcefully removed and un-installed via the software provided by the vendor. I'm surprised that there was a network entry regarding AVG security in there, I unchecked it then thought, I may as well just un-install it as anything regarding it would've been removed. Nothing seemed to of change, however, the wireless adapter was then able to be enabled on it's own accord it did this but under this connection said it was not connected to anything and still couldn't find any wireless access points but I restarted the computer to see if it finished the fix and it did! I was able to connect to the modem via ethernet and the Wireless adapter could also pick up networks and connect again!

Thanks for the help and insight on the possible problem which turned out to be correct!
Much appreciated Trouble!

Thanks to the rest of you for helping me out too! Much appreciated also!

Additionally in device manager
on the tool bar click "View" and then "Show hidden devices"
Take a look for, again, any random entries relating to old products no longer needed and left over from previous products.

I continued to go through with the rest of your advice and there was nothing of difference here that needed to be removed also, aside the extra microsoft 6 to 4 adapter in network connections that I accidentally installed twice through out this discussion thread.

Once again, thank you everyone for the help!


Noob Whisperer
You're very welcome. I'm glad you were able to resolve your issue and thanks very much for posting back and letting us know your status.
We've seen this often enough before with remnants of previous security suites leaving bits here and there which result in some of the most peculiar behavior with respect to network connections.


Well-Known Member
Is the ethernet connection integrated on the MB ? On this build a box computer, did you get a driver disk with the MB ? Did you install the MB Drivers ? Does your network adapter show up in Device Manager ? What is the make & model of your MB ?