Can't connect to PC from laptop on home network

Discussion in 'Windows 7 Networking' started by webking, Jun 5, 2011.

  1. webking

    webking New Member

    Joined:
    Jun 5, 2011
    Messages:
    8
    Likes Received:
    0
    hello
    i've got a new laptop, running win7 home premium 64bit
    at the PC i have win7 ultimate 32bit

    i've set the workgroup to be the same on both computers
    when i try to enter any of the computers (from the laptop to the PC or vice versa),
    i get the username / password screen
    there are no passwords on any of the users logged in to the windows and each system has only one user.

    if i remember correctly, if both are on same workgroup, nothing else should be done in order to see shared folders.

    do i miss anything?

    would appreciate any help :)
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First thing to check is date and time. Make sure both are sync'd (internet time) and they are both using the correct regional settings as applies to time zones.
    Second open network and sharing center and from the left column choose "Change advanced sharing settings" and then toggle off "Password protected sharing" under the "Home and Work" section.
    Third remove any and all third party firewalls (like Comodo and or ZoneAlarm, etc.,) and Internet Security Suites (Like Norton/Symantec, McAfee, AVG, etc.,) uninstall from control panel programs and features applet and follow up with the vendor specific proprietary removal tool, some of which can be found here. If yours is not listed google it. Consider replacing with the built in Windows 7 Firewall and Microsoft Security Essentials.
    Finally are you using the same username on both computers and when prompted are you using both the machine name followed by a backslash and then the username in the top box of the credentials prompt like.....
    TheWinSevenMachineYouAreAttemptingToAccess\ValidUserNameOnThatComputer
    Generally speaking Windows (since XP service pack 3) has not done particularly well with blank passwords and from a security standpoint as a matter of best practices all shares should generally be protected with a strong password so you may save yourself some time and headaches in the long run if you added passwords to the user accounts and made sure that whatever they are, they are present and valid on both computers to support authentication. Just some thoughts.
    Welcome to the forums and thank you for joining our community.
    Best Wishes and keep us posted.
    Regards
    Randy
     
  3. webking

    webking New Member

    Joined:
    Jun 5, 2011
    Messages:
    8
    Likes Received:
    0
    hi

    after toggling off "Password protected sharing" the laptop can now see the PC
    i have access to almost all folders, yet some folders are unavailable.. (all drives are set to "share")

    still, from the PC i can't access the laptop drive, can access only the /users/public folder...

    i've disabled all firewalls and security suits (removed microsoft essentials also)

    any idea about that?
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You may need to examine the properties of the individual folders that you are reporting are still "unavailable"
    Right click the folder and choose properties.
    Inspect the Sharing and Security tabs to determine who has access to what.
    You may need to explicitly add a particular user or group to make access possible as well as make sure you cascade permission down to include subfolders and files.
     
  5. webking

    webking New Member

    Joined:
    Jun 5, 2011
    Messages:
    8
    Likes Received:
    0
    i've checked all these folders, and i think i've found the problem:
    i can't enter c: drive at all. i've checked and it's permissions are set to allow read to everyone.
    also, i can't read any of the folders that are set as those windows uses for Documents, Music, Pictures and Videos
    (the default folders of win7 , after i've set it to my own destinations).

    is there any way to overcome this?
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    First you need to understand that there are two types of permissions that affect your ability to access files and folders across a network and they are cumulative, in other words they are for lack of a better word, combined, and the most restrictive is applied.
    Share Permissions (Sharing Tab in folder and or file properties)
    NTFS Security Permissions (Security Tab in folder and or file properties)
    These apply to both users and user groups so if you have a user (JohnSmith) and JohnSmith has been granted explicit permissions to write to folder xyz, but, JohnSmith is also a member of the security group "Users" and the security group "Users" only has read permissions to folder xyz, then JohnSmith will only have read permissions to folder xyz. Likewise multi-group membership can conflict with the same consequences, so if JohnSmith is a member of multiple groups you will need to consider the permissions granted to all groups he is a member of as well.
    Second the C drive is not a default share (excepting it's hidden default value of C$) so unless you have explicitly shared your entire C drive (not generally considered a good practice) and given it another name something like C_Drive, then you are not likely to be able to browse it across the network like as if you were setting at the console.
    The other folders that you are referring to (libraries), are located in
    C:\Users\YourUserName\ My Whatevers
    So you will probably be more successful in explicitly granting share and ntfs permissions if you browse to that location, right click the whatever folder and choose properties and then use the sharing and security tab to set permissions as you wish making sure that you understand the caveats mentioned above regarding group membership and aggregate share and ntfs permissions.
     
  7. webking

    webking New Member

    Joined:
    Jun 5, 2011
    Messages:
    8
    Likes Received:
    0
    well, i triple-checked all settings.. all folders are set to full access
    i guess i just leave it like that and use dropbox for sharing files from these folders...
    thanks for the help!
     
  8. sirloyne

    sirloyne Banned

    Joined:
    Aug 31, 2010
    Messages:
    303
    Likes Received:
    8
    I was in the same boat you are now. In the end I decided all the wow effects of 7 wasn't worth it and went back to good ole easy to use and working XP. I'm guessing here... when you set up your network, you choose "Home"? While that would make the most sense, I remember reading somewhere online (after I removed 7) that "Work" network allows total file sharing. It sounds completely backwards and very anti-security to me, but give that a try.
     

Share This Page

Loading...