Can't connect to public networks

I am running an hp g4 notebook with windows 7 64 bit. I can connect to my home network just fine, but I am unable to connect to any public network. The networks show that the connections are available, but when I try to connect I either get a cannot connect error or connected but with no internet error. I have updated the driver for my wireless adapter (Broadcom 4313GN 802.11b/g/n 1x1 wi-fi) and tried resetting the winsock, dv4 and dv6 in ipconfig. No luck with either.

The networks show as open.


Excellent Member
Microsoft Community Contributor
If you open the Network and Sharing Center, then go to Advanced Sharing, at the bottom of the page are the Public sharing options. It is a little hard to see since you have to click the arrow to expand the choices. Have you checked there for anything you could change?

When you left click the wireless icon, then right click the network you are trying to connect to, does it show a properties option?

Everything in advanced sharing is checked. All I see for the network is the option to connect, there is not a properties option. There was one for a while at one of the sites, but it disappeared the next time I tried it.

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.