Can't copy and replace files


New Member
I am trying to replace one file with another and it tells me that I need permission from admin which is me, I am using the admin account, and I have also turned off user account manager and it still tells me I need the right permission. I never had this issue on vista or xp (vista did do the same thing untill i turned UAC off then it worked) can someone tell me how to fix this. The files I am trying to replace or game .exe with no cd .exe Yes I do own ALL originals I just like to keep my cd/dvd hidden as I have got 7 little kids that like to use them as frisbees. So any help on this issue will be great.


New Member
Try and take ownership of the file first.

1. Locate the file or folder on which you want to take ownership in windows explorer
2. Right click on file or folder and select “Propertiesâ€Â￾ from Context Menu
3. Click on Security tab
4. Click on “Advanceâ€Â￾
5. Now click on Owner tab in Advance Security Settings for User windows
6. Click on Edit Button
8. Now select your User/group and click apply and ok. (Check “Replace owner on subcontainers and objectsâ€Â￾ if you have files and folder within selected folder)
9. Click ok when Windows Security Prompt is displayed
10. Now click Ok to exist from Properties windows
Once you have taken the Ownership of file or folder next part comes is Granting Permissions to that file/folder or object.

How to Grant Permissions in Windows 7

1. Locate the file or folder on which you want to take ownership in windows explorer
2. Right click on file or folder and select “Propertiesâ€Â￾ from Context Menu
3. Click on Edit button in Properties windows Click ok to confirm UAC elevation request.
4. Select user/group from permission windows or click add to add other user or group.
5. Now under Permission section check the rights which you want to grant i.e check “Full Controlâ€Â￾ under the “Allowâ€Â￾ column to assign full access rights control permissions to Administrators group.
6. Click Ok for changes to take effect and click ok final ok to exit from Properties window.

Or you can download the txt file I have attached and rename the .txt to .reg and run it. It will add take ownership to the rightclick button on your mouse.


New Member
Thanks I followed your instructions I even used the txt and changed it to reg and ran it and I still get the same error if i change permissions from me its says I need permission from admin and if i change admin it says i need permission from me and even if i grant permissions on all accounts it says the same thing I have even granted the right permission to all users and its the same thing everytime i need permission to move it :(
Last edited:


New Member
Try running this command in the command promt first

net user administrator activate:yes

I take it you cannot just delete the old .exe first? You could also try booting to safe mode and follow the steps on the whole folder the .exe is in.


New Member
No It was also stopping me from removing the original .exe, however it did move under safe mode but then would not let me play the game saying it was blocked. My anti virus was causing the problem it seems which is weird as I have used the same no cd crack for three years and 2 other operating systems AVG caused the problem it didn't detect it or warn me about it being a virus (it wasn't a virus but a false positive I scanned it manually and got that result scans on three other avs mcaffe and nod32 gave no errors neither did avast.) Anyway thanks for all your help after all that its a shame it was something so simple. Thanks a lot for your help.

Off Subject....
Anyone who reads this and has a codec issue there is one called KMplayer its a really nice little codec and worth a try works on all files from mpeg to mkv to bluray and hddvd.


Well-Known Member
I am just tagging onto this thread because I am stumped.
Short story version: I have corrupte files that CHKDSK and SCANNOW will "see" but not fix.

One file is


I make two dynamic backups to other drives, meaning I have a source for the file.

But when I try to copy paste, it says "You need permission to perform this action"

Of course, MS has made it a root canal to figure it out.

I tried the methods above--no help.



Essential Member
Microsoft Community Contributor
Check out an app called "Take Ownership", it has worked well for my when things like this happen.

It adds the take ownership command to your right click drop down.

Add Take Ownership Option Shortcut in Right Click Menu of Windows 7

If that fails try...

How to Enable the Administrator Account

Open the command prompt with elevated privileges by clicking the Start orb, All Programs, Accessories, right-click Command Prompt and then select Run as administrator.


net user administrator /active:yes

and then press Enter.

When you are done undue the process by doing the same thing and pasting in ….

net user administrator /active:no
Last edited: