Can't install Firefox because I don't have "necessary permissions"

#1
When I try to install Firefox, I get an error that says "You may not have the necessary permissions to use all the features of the program you are about to run. You may run this program as a different user or continue to run the program as the current user."

Then it gives me an option of running as the current user, which does nothing, at all except close the program, or running as "Administrator" which gives an error because there's no password for Administrator. It's very frustrating; is there any way to get around this?
 


reghakr

Essential Member
#2
Go to Control Panel > User Accounts, click the Change user account control settings and set the slider to never Notify.

You can leave it at this setting as long as you have a good Anti-virus , spyware detector and personal firewall.
 


#3
Ah, thanks, that worked.
 


reghakr

Essential Member
#4
Great,

Thanks for posting back too as that can help other posters with that problem.
 


#5
I had this same problem except for one thing. I already had mine set to never notify and firefox wouldnt install. I actually had to set mine back up to the default setting to get firefox to install.
 


#6
I had this same problem except for one thing. I already had mine set to never notify and firefox wouldnt install. I actually had to set mine back up to the default setting to get firefox to install.
Exact same experience for me when I tried to install my girlfriend's Firefox program. Very strange.
 


#7
hello,

I just joined this forums to let you know how I managed to install FF 3.5.5.

As a new user of Windows 7 the first thing I did was to set the UAC on never notify. I've tried to install Firefox and had the same problems as you did, but UAC was already on "never notifiy". After reading this topic I switched back to default settings for the UAC and it worked like a charm.

Don't know what the deal is because I just installed 7 today, but I guess some programs are loving the UAC. :D
 


#8
Hello everyone

Thanks for the thread - Its so frustrating how simple things in XP are now creating forum missions to resolve.

I had the same problem ie had the setting set for "never notify" and so I nocked it back one selection and now I can install any of the Firefox versions.

I'm using a brand new PC with Windows 7 Pre-installed - total hours use now 3. Total hours of frustration trying to get it to fun like XP pro 2.5!!!
 


#9
if your trying to download firefox and it tells you for a password for administrator put your pc on SAFETY MODE and try again that works! :thumbs_up:
 


#10
Go to Firefox Control Panel > User Accounts, click the Change user account control settings and set the slider to never Notify.

You can leave it at this setting as long as you have a good Anti-virus , spyware detector and personal firewall.
Thank for your sharing
 


Last edited:

Pauli

Extraordinary Member
Premium Supporter
#11
Thank for your sharing
Yeah well, we have the main word, Sharing. Not like knowing or anything. Or being certain.

To share sounds like an extended big heart. Go for it.
 


#12
It will also help if you right-click on the Mozilla installer and choose "run as administrator." I was having this exact same issue and it worked for me.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.