Can't Install or Uninstall ANYTHING

Discussion in 'Windows 7 Help and Support' started by azarathian210, Jul 8, 2010.

  1. azarathian210

    azarathian210 New Member

    Jul 8, 2010
    Likes Received:
    For some reason, when I was trying to uninstall a game I don't play anymore, it told me I didn't have sufficient priveledges to do so, and to contact the system administrator. Needless to say, I'm worried as I am the only user on this computer. I tried to install one of my force uninstall programs only to find that I can't INSTALL anything, as when I do, it asks me what program I wish to open it with. I don't know what's happened, all I know is that I didn't get a system disc shipped with my computer, and I'd like to get this all fixed with as little tears, cost, and bloodshed as possible.
  2. TorrentG

    TorrentG Banned

    May 31, 2010
    Likes Received:
  3. zvit

    zvit Honorable Member

    Nov 3, 2009
    Likes Received:
    Problems with insufficient privileges at uninstall is a very annoying problem in Windows 7. I have tried different scripts and codes to "regain" permissions on registry keys, but most of the time I end up having to do it manually. You can try using programs such as Ashampoo UnInstaller 4 or Cleanse Uninstaller Pro and there are others, but more times then not, I still had to do some manual work.

    If it is a game, it is likely that it won't be that much work. If it's a heavy program like Adobe or Microsoft Office, make sure you have enough milk for coffee in your fridge.

    WARNING: The following tip involves moderating your registry files. You should make a backup of your registry before proceeding!

    In the warning message you should see what Key is the problem. It should look something like this: {435899C9-44AB-11D1-AF00-080036234103}.
    You will need to find this key in the registry by typing regedit in the "run" command. (I personally use Regisrty Workshop because it gives you multiple search results at once).
    Once you find this key, click on it and you should see some sub keys that are colored red. These are the keys that are protected and is preventing the game\software from uninstalling itself.

    Right click on the parent key (folder) of the red ones and choose "permissions...".
    Make sure you are in the list of users. If not, Add yourself and give yourself Full control.
    Click on your name and click "Advanced".
    In the list of Permission entries, I sometimes just remove all and add myself but it works without that many times.
    Click on "Owner" tab.
    Make sure you are in the list, if not, add yourself.
    Click on your name and check "Replace owner on subcontainers and objects" and clikc OK and again OK to exit the permissions dialog.

    The red folders should change to default orange color.

    Try to uninstall again.

    You may have to do this a few times like I said, depending and the complexity of the software your trying to uninstall. Each time will be a different key\folder you will have to do this to.

    Good luck. Don't forget to backup your registry first and even create a restore point first in case you mess things up.

Share This Page