Can't manage my disk

Charlie210

Well-Known Member
#1
When I right click on Computer and select Manage I get the following error message:
C:windows\system 32\mmcbase.DLL is not designed to run on windows or contains an error.

Any ideas as to what the problem is and how to fix it?

Running Windows 7 Home Premium x64
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#2
I am not sure what is wrong, but it seems I remember seeing the same type of message in a different situation. I will have to think about that to see if I can remember.

If you try to run mmc.exe does it do the same thing?

Is there some utility you want access to, like Disk Management (diskmgmt.msc) or Device Manager (devmgmt.msc)?

I do not know if this is involved in your situation, but some utilities will not run on some versions of Windows, such as the .msc versions above.

You might open an Administrative command prompt window and type SFC /scannow and let it check your system files. If it reports any errors, let us know.

Compmgmt.msc should also start the utility if you use the Winkey+R and type it in the run command. It might not work either, but would tell us if there was something wrong with the Computer right click options.
 


Charlie210

Well-Known Member
#3
Thanks for taking the time to reply Saltgrass.

I tried to run mmc.exe and diskmgmt.msc and received the same error message. I ran sfc as administrator and received a report saying there were corrupt files but unable to fix them and instructed me to look at the CBS log. The log file would not grant me access to read it using notepad. I ran notepad as administrator and the CBS log file doesn't even show up in the list.

One other bit of information. I recently installed a new SSD drive on my system as the boot drive. Everything else seems to be working fine.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#4
You can enter the command below in an Administrative Command window by copy and paste, or typing yourself. It will place a text file on your desktop you can check. The list of files not repaired is normally stated near the end of the file, but if you want to attach the file, use the paperclip on the advanced replies and we can check it.

findstr /c:"[SR]" %windir%\Logs\CBS\CBS.log >"%userprofile%\Desktop\sfcdetails.txt"

The way you added the SSD to your system might be relevant. If you cloned a drive, sometimes that confuses the system... Hopefully you did a clean install to the SSD, or created an image of the old install and then restored that image to the SSD. But let us know. If you have the old drive still installed and it contained the prior OS, you might try to disconnect it for testing.
 


Charlie210

Well-Known Member
#5
Thanks again for the help Saltgrass. I ran the administrative command and I will attempt to attach the file created.

My SSD was installed by cloning the original OS using my backup software Acronis. I have the original HD and I will boot to it and confirm if this issue occurred before or after the SSD install.
 


Attachments

Saltgrass

Excellent Member
Microsoft Community Contributor
#6
The list of problem files is below. You can see the mmcbase.dll is included in the list. The fact it is showing doesn't always mean it won't run, but it is quite a coincidence.

rgb9rast.dll
HelpPaneProxy.dll
C_20949.NLS
mmcbase.dll
mmcbase.dll.mui
sdiageng.dll
Solitaire.exe
McxDriv.dll
You might start by running a chkdsk to see if it will repair any corruption. If that doesn't help, you might be able to replace some of the files using the link as a guide. I have never needed to replace any files, so I won't be of much help with that. I don't know of another way to repair the situation, but if you find something that mentions some package the files are included with, that is listed in the SFCdetails.txt. Such an entry would look like the one following.

[SR] Cannot repair member file [l:22{11}]"mmcbase.dll" of Microsoft-Windows-Microsoft-Management-Console, Version = 6.1.7600.16385, pA = PROCESSOR_ARCHITECTURE_AMD64 (9), Culture neutral, VersionScope = 1 nonSxS, PublicKeyToken = {l:8 b:31bf3856ad364e35}, Type neutral, TypeName neutral, PublicKey neutral in the store, hash mismatch

[SR] This component was referenced by [l:202{101}]"Microsoft-Windows-Foundation-Package~31bf3856ad364e35~amd64~~6.1.7601.17514.WindowsFoundationDelivery"

[SR] Could not reproject corrupted file [ml:520{260},l:46{23}]"\??\C:\Windows\System32"\[l:22{11}]"mmcbase.dll"; source file in store is also corrupted
If you had any idea what might have caused the problems to develop, you might want to deal with that.

Use the System File Checker tool to troubleshoot missing or corrupted system files on Windows Vista or on Windows 7
 


Charlie210

Well-Known Member
#7
Thanks again for your help. I did a backup/restore (instead of a clone) to the SSD and the problem was resolved. Now my new problem is that the restore (using Acronis True Image 2013) resized the Windows 7 System Partition from 100MB to 48MB. I have posted this issue on the Acronis Forum.
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#8
Hope you get it worked out. I haven't used Acronis in quite a while so not much info from me. But perhaps it was adjusting the size of the partitions to fit on the SSD. I don't suppose there are settings to set certain partitions to maintain their current size?

Anyway, good luck. I suppose I will eventually have to go to a third party imaging software since Microsoft, in their infinite wisdom, has decided to take the Windows Backup and Restore utility out of Windows 8. That is all I have used for the last 4 years...
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.