Can't open a shared file on a Windows 7 machine if it is already open on an XP machine in same netwo

Discussion in 'Windows 7 Networking' started by nencoin, Jan 23, 2012.

  1. nencoin

    nencoin New Member

    Joined:
    Jan 23, 2012
    Messages:
    16
    Likes Received:
    0
    I have a small network of six computers. Five of them run XP and I just added a Windows 7 machine. I've got a Microsoft Access 2003 database that all of the computers share that is hosted on one of the XP machines. The Windows 7 machine can access the Access database through the network just fine, as long as no one else is accessing it. However, if someone else on an XP machine on the network is using the file, it won't open on the Windows 7 machine. Doubling clicking the file on Windows 7 gives me the circling blue icon for a second or two, then nothing happens. If the XP user exits the database, then I can open it fine.


    Permissions on the XP that is hosting the database is set to allow everyone. And all the XP machines can access it at the same time.

    Any ideas what is happening?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hello and welcome to the forum.
    Many questions come to mind regarding your issue. Primarily, are all machines running the same version of MS Access? And is the database broken down into a front end .mdb which resides on the local machine that may contain access forms and are accessing a back end .mdb containing the tables and queries on the XP host machine. Usually such problems will produce a msg box reporting some type of lock file issue regarding the container on the host where the .ldb is created when the database is opened.
    However, what you are describing where clicking on the shortcut results in apparent brief activity and then a failure to open the database with no prompts or error messages might suggest that you need to add the path to the local MSACCESS.exe executable into the shortcut target line. Something like
    "c:\program files\microsoft office\office11\msaccess.exe" "X:\Directory Name\Acess Database Name.mdb" (or .mde as the case may be)
    You can usually test this hypothesis by (when the problem is present, the .mdb is opened on one of the XP machines) opening Microsoft Access on the Windows 7 machine and then from the menu using the File->Open to browse to and open the problem database. If it opens without issue then you need to add the path to the msaccess.exe executable into the target path of the shortcut as above.
    Good luck and keep us posted
    Regards
    Randy
     
  3. nencoin

    nencoin New Member

    Joined:
    Jan 23, 2012
    Messages:
    16
    Likes Received:
    0
    Thank you for the reply, Randy! All machines are running the same version of Access. The database does not have a front end on the local machines. I will try adding a path to the local Access to the shortcut line. I'll keep you posted. Chris
     
  4. nencoin

    nencoin New Member

    Joined:
    Jan 23, 2012
    Messages:
    16
    Likes Received:
    0
    Randy, that did it! I modified the shortcut just like you said and it worked! Thanks SO much.
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hey Chris:
    Glad to hear that you have managed to resolve your problem. Thanks for posting back and updating your thread with the solution that worked for you. Wrestling with Microsoft Access databases across a network can sometimes be a bit of a pain and often if you're lucky enough to actually get a message box indicating some type of error, they are not easily deciphered and in cases where nothing happens you're kinda left scratching your head.
    Thanks for joining our community and we hope to continue to see you around.
    Best.
    Randy
     
  6. 23carnies

    23carnies New Member

    Joined:
    Apr 12, 2012
    Messages:
    8
    Likes Received:
    0
    Hello! So I have this same problem and I don't understand the answer you've given. We have 5 computers networked with one of them as the Server. 4 are running XP and we just added one with Windows 7. We are running Office 2010 with Access 2007. There is only one database I am having problems with and it is not split.

    I have upgraded it to Windows 7 Professional so i could change Network List Manager Policies regarding Unidentified Networks. I have done this but am still unable to open Access from the network if a XP terminal is already in the database. Windows 7 still shows my network as "Unidentified" but it is now listed as "work" instead of "public."

    If none of the XP terminals are in the problem database, the windows 7 terminal will open the database but before it does, there is a "Open File-Security Warning" which asks if i want to open this file from an "Unknown Publisher." It shows "From: \\Server\folder\database.mdb" This warning does not appear when i attempt to open any other database. The problem database is the only one that multiple people work in at the same time. I am able to open Access first and then open the problem database.

    i am at a complete loss here. I have tried a million things and none have worked. I am hoping your solution will be it, but i don't understand where the shortcut target is. Any help is greatly appreciated. I'm pulling my hair out.
     
  7. nencoin

    nencoin New Member

    Joined:
    Jan 23, 2012
    Messages:
    16
    Likes Received:
    0
    Hi. I will try to help you out, but if I can't, I'm sure Randy will be able to if he sees this post. On the XP machines, I assume you have a shortcut on the desktop that points to the Access database on the server. If you right click on the shortcut and select properties, you will see the target box. It likely shows something like you'll see in the screenshot.
    shot1.

    What you need to do in the target box is add the path to where Access resides on the local machine BEFORE the path to the actual database on the server. If you're running XP, it quite possibly is something like this: "c:\program files\microsoft office\office11\msaccess.exe"

    To see if that is indeed the actual path, try copying and pasting the line above (including the quotation marks) in the target box. Again, paste this before the path that is already in there. Once that is done, hit OK and then try opening up the database. That should do the trick. If not, then you quite possibly have a different issue than the one I experienced. Again, I'm sure Randy or one of the other experienced users will be able to help you.
     
  8. 23carnies

    23carnies New Member

    Joined:
    Apr 12, 2012
    Messages:
    8
    Likes Received:
    0
    Thanks for the reply! that makes sense.

    I think the problem i am having, though, is that the shortcut to the server is a folder with several databases. Most of the databases are fine, only one has the problem but it is in the folder on the server. I just tried to put this into the target and got "Problem with Shortcut---The name 'c:\Program' specified in the Target box is not valid. Make sure the path and file name are correct." Sometimes it only says c:\program and sometimes it spells out the whole thing. I have also tried making a shortcut directly to the problem database and putting this in there, but with the same result.
    Also, I looked at exactly where the msaccess.exe file was in the windows 7 machine and the path here is c:\Program Files(x86)\microsoft office\office 14\msaccess.exe.manifest
    i have tried this path as well but i always get the problem with shortcut when i hit enter/ok.

    Any other ideas are appreciated
     
  9. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    That would indicate that either your macro security level is set too high within Access or that more likely you need to include the location and .mdb within the Trust Center. Since you don't have that issue with other MDBs then it's not likely the macro security setting.
    The fact that you can open the database without issue from within Access, suggests that you indeed need to add the path in the text box labeled Target: in the properties of the shortcut that you double click to open the database.
    So right click on the shortcut and choose properties, in the text box labeled target enter
    "C:\Program Files\Microsoft Office\Office14\msaccess.exe" \\ServerName\SharedFolderName\YourDatabaseName.mdb
    The target syntax must include quotation marks whenever spaces are present in the path. There needs to be a space separating the path to Microsoft Access (the program) and the path to the MDB and if the path to the MDB also includes spaces it must also include its' own set of quotes separate from the other set. Which is just bad naming convention as network paths and database names should not have spaces in their names.
    That is because you haven't properly included quotes in your path syntax.
    If as you have stated you are using Access 2007, then that is not likely the correct path but more like the path to your Office 2010 files and in any case should not include a dot manifest (.manifest) at the end.
    If you are using Access 32 bit on a 64 bit machine then the path is likely
    C:\Program Files (x86)\Microsoft Office\Office14\msaccess.exe (if you are using the 32 bit version of access 2010)
    or
    C:\Program Files (x86)\Microsoft Office\Office12\msaccess.exe (if you are using the 32 bit version of access 2007 as you've stated.
    Otherwise if you are using the 64 bit version of Microsoft Access on a 64 bit machine or the 32 bit version of Microsoft Access on a 32 bit machine the path will be the same just without the (x86) notation.

    And if you are getting an error something to the effect that another user has the file opened and it is locked, then perhaps your actual problem is something else entirely and more likely related to the security on the folder where access is creating the lock file .ldb.
     
    #9 Trouble, Apr 12, 2012
    Last edited: Apr 12, 2012
  10. 23carnies

    23carnies New Member

    Joined:
    Apr 12, 2012
    Messages:
    8
    Likes Received:
    0
    hey, everyone!
    I really appreciate your help with this. I'm really close, I think.
    I'm still getting the "open file security warning" if the 7 computer is the first to enter the problem database. This network is not on the internet so I changed the macro settings to "enable all" and still get the same error. I have added the Server location, the folder that holds all my databases and the problem database all to the Trusted Locations list. Still the same problem.

    I was able to make another shortcut directly to the problem database (instead of the folder) and put "C:\Program Files (x86)\Microsoft Office\Office14\msaccess.exe" into the target and that now works. I really need it to work inside the folder, though. I am still unable to figure this part out.

    I tried going to Properties of the problem database inside the shortcut folder but see no way to change the target here. I can see the Folder Path under the Details tab but am unable to affect it.

    The thing that confuses me the most is why this one database? This is the only database we regularly work in on multiple terminals at the same time, but I tried putting someone else in another database and the 7 machine was able to open it from the folder on the server with no problems or security warnings.

    Thanks again for all the help!
     
  11. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I don't understand this statement.
    Normally, you would always want your database shortcut to point to the database. So why or what is going on with "I really need it to work inside the folder" what does that mean exactly.
    If you can open the database from within MSACCESS.EXE and you can open the database after adding the path to the MSACCESS.EXE executable to the target path syntax, what am I missing as to what is left to do.
     
  12. jimmight

    jimmight New Member

    Joined:
    Apr 20, 2012
    Messages:
    2
    Likes Received:
    0
    I have one I'll never use. Zero emotional attachment, just would like to free up some space.
     
  13. 23carnies

    23carnies New Member

    Joined:
    Apr 12, 2012
    Messages:
    8
    Likes Received:
    0
    OK. So this is my office network and we have several databases that we use. We all need to be able to access all of them so we keep a folder with all the databases on the network. There is a shortcut to this folder on each of the terminal desktops. Inside this folder are several databases along with other items we need to access from every computer. One of these databases is the problem. It is also the one database we all use simultaneously every day. Adding the msaccess.exe to the path works if i make a separate shortcut only for this database. This, however, is very confusing for my employees, especially during training. What I am trying to figure out now is how to make the database work when accessing it through the shortcut folder that is linked to the server. Does that make more sense?
     

Share This Page

Loading...