Can't open regedit

Discussion in 'Windows 7 Help and Support' started by Tsign, Jun 16, 2010.

  1. Tsign

    Tsign New Member

    Joined:
    Jun 15, 2010
    Messages:
    6
    Likes Received:
    0
    When I try to open regedit by command in Windows 7 I see the the message that this file can't be found.

    Can somebody help me with this?
     
  2. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    Not sure what you mean by "command" Command prompt?
    But either there or in the start, it should open. Look in Windows and see if the file exists. (Windows\Regedit.exe) If it does, see if it runs from there.
     
  3. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Make sure to log in as admin.


    1. Start->Run->gpedit.msc->User Configuration->Administrative Templates->System->Prevent Access to Registry Editing Tools->Set this to Enabled

    or (if you don't have gpedit.msc) Start->Run->REG add HKCU\Software\Microsoft\Windows\CurrentVersion\Policies\System /v DisableRegistryTools /t REG_DWORD /d 0 /f

    Reboot

    2. If you're still getting this error, cmd->sfc /scannow.
     
  4. Tsign

    Tsign New Member

    Joined:
    Jun 15, 2010
    Messages:
    6
    Likes Received:
    0
    Thanks for posting but this doesn't help.

    I executed gpedit.msc and changed the registry editing tools to Enabled. After rebooting I still get the same error message: can't find file.

    I see the same error message when I execute your second command.
     
  5. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Try the repair function with the Windows 7 dvd.
     
  6. nima

    nima New Member

    Joined:
    Jun 25, 2013
    Messages:
    2
    Likes Received:
    0
    hi I had this problem, do this it may work:
    go to C:windows
    then search (Regedit.exe) press right click (click" run as administrator")
    now you will see the regedit
    then go to this address :HKEY_CLASSES_ROOT
    go : exefile\shell\open\command ok now open the Default and
    change the Value data to "%1"%*

    then go to: runas\command and do the last way( change to "%1"%*)
    Now it's finished, and you done ;)
    Cheers
    Nima
     
  7. MikeHawthorne

    MikeHawthorne Essential Member
    Microsoft Community Contributor

    Joined:
    May 25, 2009
    Messages:
    6,048
    Likes Received:
    300
    Hi

    You don't have to run Regedit from the command prompt.
    Just type Regedit in the run windows and it should open.

    But it should start from the command prompt as well.

    On my computer regedit.exe is located in C:\Windows\regedit.exe

    If you have trouble with it opening from there, try using Take Ownership on it and see if that helps.

    Mike
     

Share This Page

Loading...