Can't remove read only attribute

#1
This is not my first rodeo for sure. Well with win7 I guess it is. Anyway, I can't seem to get rid of the the read only attrib on a directory. I remove it and apply and close the window but when I look at the properties again, the box is colored again. (not a check mark) Meaning something in the strucure is still read only. And yes, I told it to propogate to the entire dir structure..... I have delt with this years ago but can't remember how I fixed it......any ideas??
 


#2
Hold your shift key and right click on the parent folder and go to command prompt then type and enter

attrib folder name -h

If aren't in the parent folder you'll have to provide the full path

type and enter attrib folder name and it should show there is no h


If that doesn't work and you are trying to change a system folder, let me know which one... you may have to take ownership and use icacls to put it in the administrative group.

You are showing hidden files in your Folder Options / View menu .. right?
 


#3
I guess I should have mentioned it but I did try it through a cmd prompt with admin rights. I am showing hidden files in my folder options. It is not a system folder. It is the expandedsetup folder that has my downloaded install files for win7
I did take ownership of it as well. this is driving me crazy..........
 


pbcopter

Honorable Member
#4
If you are talking about the filled-in read only box on the folder, it does not mean the folder is read only. Folders are not read only and that box only applys to files within the folder.
 


#5
I guess I should have mentioned it but I did try it through a cmd prompt with admin rights. I am showing hidden files in my folder options. It is not a system folder. It is the expandedsetup folder that has my downloaded install files for win7
I did take ownership of it as well. this is driving me crazy..........

I have the same folder and there is nothing hidden about it ... or any of the files in it or subfolders.

Maybe you are just "thinking" it's readonly but the box isn't actually checked .. at least not here. I can check it and make it read only.
 


RJB

New Member
#6
I have the same problem as detailed before -
All my folders on drive D are cheked as 'read only', the read only box doesn't have a tick though it has a blue 'blob' (for want of a better word) in it. if I cancel it and 'apply' the next time I open properties it is back.
I have tried the command prompt 'attrib' method to try and get rid of the read only but am coming up with errors such as 'parameter format not correct'

Some of the files in the folders I am able to overwrite but I opened an excel file today and it wouldn't let me save into the folder as it was write only and I had to make another folder to put it in. When I looked at the propertied for the new folder I had the same blue blob in read only.
 


#7
I am having this problem right now with my photos I can't even crop or edit them in anyway. I changed the attriubtes and click ok it changes it right back again.....
 


Elmer

Extraordinary Member
#8
Double post!! ???
 


Elmer

Extraordinary Member
#9
I am having this problem right now with my photos I can't even crop or edit them in anyway. I changed the attributes and click ok it changes it right back again.....
This might help, it may not!

Years ago I was having the same sort of issue so I downloaded a trial of Attribute Manager and liked it so much I bought a licence. I only mention the licence bit as I can't remember the trial limitations.
May be worth a look-see.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top