Can't sleep, restart, shutdown; Explorer won't refresh

Discussion in 'Windows 7 Help and Support' started by tonightslastsong, Jun 26, 2009.

  1. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    SOLVED: Can't sleep, restart, shutdown; Explorer won't refresh

    (Solution on last post, but the short version is that I had to use the Device Manager to "Uninstall the hardware" for my built-in SD card reader, so that Windows just forgets that the hardware exists. I can't use it anymore, but that's cool with me. I'll trade my card reader for my sanity any day of the week.)


    I've seen several posts here about similar issues, which I suspect to be connected:

    I've got the RC on my laptop, and things are great. At some point, though, explorer.exe gets weird and refuses to refresh things. Copy and paste a file, and it won't show up. Push F5-- ah, there it is. Same if you delete a file, or create a new one.

    Also, when I open a new explorer window, it's a 1 in 10 chance that it'll work. When it doesn't work, it acts like it's trying to find drives, folders, etc. Virtually nothing shows up in the tree at the left, or in the main panel on the right. (See attached image.) Typing addresses directly into the address bar, or using a command prompt to go to locations works perfectly well, still. Programs that are currently running have no trouble accessing specific folders, but usually hang when trying to view My Computer.

    When trying to shut down, restart, hibernate or sleep, the computer will get stuck on the "Shutting down..." screen, or on a black one if trying to sleep. Nothing ever happens after that. I've let it sit overnight, just to be sure, and it never completed the task.

    I created a Restore Point after I reformatted and was convinced that all was well-- I disabled updates after that, didn't install any new drivers, software, or hardware. Yet suddenly the issue resumed one day. I restore to said Restore Point, and the problem does NOT go away.

    I have stopped every conceivable service, killed every process possible, and dug deep into clearing caches and carefully tweaking registry spots where it seemed possibly relevant.

    This has nothing to do with some of the common suggestions made in other posts, including ISO mounting utils (these mostly no longer cause problems in the RC anyway), and all of my drivers are up to date. If you suggest anything of the sort, you will have proven to me that you did not read past my initial description of the issue.

    Basic computer specs:
    HP TouchSmart tx2
    Windows 7 RC x64
    Computer is a tablet, with Multitouch, built-in fingerprint reader, and IR sensor for a media remote.

    Please-- I'm pleading with anybody to reveal their helpful info, if they have any. I'd kill babies just to know what the culprit element is. If there simply is no solution, I'll accept that, but I NEED to know what's causing it. My technical experience is high, yet I cannot get to bottom of it.
     
    #1 tonightslastsong, Jun 26, 2009
    Last edited: Jul 13, 2009
  2. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Ps...

    PS:

    System event logs report nada. It's like Windows doesn't even know there's an issue. I've also done profiling with the tools built into the OS, and I find nothing that really seems abnormal.
     
  3. bmclachlan

    bmclachlan Senior Member

    Joined:
    Jul 3, 2009
    Messages:
    6
    Likes Received:
    0
    The same is happening with me.

    Bill
    Win 7 RC 7100, Toshiba Portege M700, 4 gb RAM, 320 Gb 7200 rpm Drive
     
  4. JeremyJukes

    JeremyJukes Senior Member

    Joined:
    May 8, 2009
    Messages:
    112
    Likes Received:
    5
    HP TouchSmart tx2 Hanging

    Some Suggestions (sorry if there is duplication since I did not read any of your other posts):

    1. Run in safe boot mode, If the problem goes away you may have a device driver/hardware problem.
    2. Disable as many hardware devices (one at a time) as possible to see if the problem goes away.
    3. Check to see if BIOS need updating.

    Good Luck!
     
  5. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Well.. here's an update.

    I seriously could not live with the behavior, so I did reformat (again... 3rd time) and reinstall. The disc I have has successfully installed on 3 other machines without troubles, so I don't think it has anything to do with that. It's official, off of MSDN, and not a cracked/leaked version.

    Safe Mode seemed to suffer from the same problem, surprisingly.

    Windows liked to constantly think some unidentified device was being inserted and removed (you'd get the removable device sound every couple of minutes), which I believe was my fingerprint reader. The driver doesn't play nice with Win7, so I just leave it uninstalled.

    So, after reformatting, as I started off saying, I immediately turned off windows updates and have not installed any drivers at all, aside from Hamachi's virtual network adapter.

    Everything seems to be doing good so far. I've sworn an oath that I'd only install one new major program a week, so that I can narrow it down.

    Currently, my software looks like this:
    -- Chrome
    -- Screen-scraper
    -- MS Office 2007 (no servicepack updates-- it's just a clean install of Word, Excel, and Onenote)
    -- Hulu desktop
    -- Netbeans
    -- Java JDK (64-bit)
    -- Python w/ various modules
    -- Utilities, including: Synergy, Skype, Cygwin, Hamachi, Katmouse, Togglehiddenfiles.exe, WinSCP, Notepad++
    -- A few games, such as Stardock's Demigod, and its accompanying Impulse manager, and the Pcxs2 PS2 emulator
    -- DirectX updates (as required by games and DirectX SDK)
    -- Homebrew'd mouse hooking program

    And that's all. Programs I have yet to pronounce 'clean':
    -- Adobe Photoshop CS4 / Soundbooth CS4
    -- My tx2 multitouch driver
    -- Fingerprint reader driver (Authentec AES1610)
    -- Video driver (ATI Radeon HD 3200)
    -- Network driver (Broadcom 802.11g)
    -- Misc drivers: Fax/Modem ("WTF?", right?), SD card reader, mouse touchpad, IR sensor for media remote
    -- Google talk
    -- MS Office updates
    -- "Important" windows updates
    -- "Recommended" windows updates
    -- "Test" windows updates
    -- Virtual Clone Drive
    -- MySQL/ webserver extensions
    -- Winamp
    -- RocketDock

    bmclachlan or others, feel free to add to the list of "okay" software/drivers. Much of what I've listed likely isn't to blame, but I'm interested in being comprehensive, since this is the only case I can seem to find of the troubles.

    Thanks so much for the replies. Hope to get to the bottom of this. I'm sure on of these weeks I'll install the culprit, and then the world will be a better place for knowing the problem.

    Tim
     
  6. Tepid

    Tepid New Member

    Joined:
    Jun 11, 2009
    Messages:
    1,344
    Likes Received:
    38
    I would start with individual drivers, as those are probably causing the issue.
    Also, I never, ever use Windows Updates for driver installs. I have always had problem with them.
    D/L the official ones and install those.

    I wish MS would either fully fix WU Driver installs, or stop using it. I have personally fixed a great number of systems by uninstalling a driver installed by WU and installing the ones from the manufacturer. Usually the very same version.

    I also want to add, that I have tested it by uninstalling the good driver and letting WU install their driver and the system breaks. This has been repeatable. So, watch for broken drivers on WU.
     
    #6 Tepid, Jul 3, 2009
    Last edited: Jul 3, 2009
  7. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    I agree with you about starting with the drivers. I'm just ready for anything as I install other things, such as Explorer shell extensions, etc, as found in shared component of Adobe products.

    For the sake of speedy reformatting (which I seem to do frequently these days), I download the real drivers from the manufacturers and keep them all in a single location on my network. WU doesn't seem to be to blame for this particular driver problem...

    In fact, I'm most likely to conclude that it's a combination of my multi-touch/fingerprint driver (not sure which) and a normal Windows Update. Updating all the way seems to do fine, and separately, installing my drivers seems to be fine. But when I do both, the computer decides to throw down some angst against me. Who knows if there's anything to blame about mixing 32- and 64-bit stuff. Fingerprint reader driver wouldn't come close to working while running their 32-bit version of the configuration software.
     
  8. Tepid

    Tepid New Member

    Joined:
    Jun 11, 2009
    Messages:
    1,344
    Likes Received:
    38
    Yes, this could be. Not all 32bit software will work properly on a 64bit system.
    This is why people need to test that all their needed software will work, or if there are updates before going headlong into straight 64bit computing. It is an unfortunate thing, to have to do all that testing, but it can save you later.

    It is also why, 32bit Win 7 should not even exist. Just make the move, make it now, make it permanent.
    People will just need to deal with it like they dealt with Vista (which is where MS should have started with 64bit only) the transition would have been much better by now, and forced all these other companies to start fully supporting 64bit software.
     
  9. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    I'm in complete agreement with you.

    This laptop is a HP-manufactured one, so I figured I'd have my best 64-bit experience with it, rather than building my own and being stranded without any professional driver makers to back me up. (Ironically, the computer that I *did* build is doing better than the laptop, at the moment, 64-bit an all.)

    Assuming my issue lies with either the multi-touch or fingerprint reader driver(s), then I'm not sure there's much I can do about it anyway. I'm traditionally an early adopter of technology, so I'm accustomed to headaches... I just prefer to at least know what contributes to the issue! Drives me insane when I can't even avoid the issue since I don't know what it is!
     
  10. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Started happening again.

    The only things I've installed recently are the multitouch driver (which I don't suspect to be the culprit, given the timing), and Microsoft Expression Blend 2 trial.

    I suspect the latter, but only by the components it seems to install. I'm pretty sure it tosses in some distributable runtime of Visual Studio or some .NET thing. When this started happening the first time, it was extraordinarily close to the time that I had installed Visual Studio 2005 and Visual Studio 2008 Express.

    I hope this helps someone, because I'm really past the point of feeling on this one... I'm furious, but I've run out of ways to express it :)

    My computer actually gave me the Blue Screen just after I began seeing the evidences of the disease. Not 2 minutes passed between the two events. I will try to uninstall the bloody MS Expression thing, but I can only hope that it truly removes the drivers. System restore did not seem to help me revert whatever change has happened.
     
  11. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Final verdict:

    The Visual Studio runtime package gave me a bluescreen for some reason, but it actually seems that my built-in SD card reader went to hell at some point. System Restore did nothing for the problem once my main problem started. I had to open up the Device Manager and go "Uninstall" the hardware (silly terminology, really, since the hardware didn't go anywhere) for the card reader.

    So, I can't use the card reader at all now, because uninstalling the hardware means that Windows will forget that it even exists. This means I never have to worry about it freaking out again due to any driver that it thinks it needs to use to operate the thing.

    Good riddance.
    Hope this helps somebody in the future. My laptop is working in top condition now that the bloody card reader has been cut off.
     
  12. danceguy

    danceguy New Member

    Joined:
    Jan 5, 2010
    Messages:
    8
    Likes Received:
    0
    same problem in 2010 - better solution yet?

    same problem here with win 7 and multi-card reader. i can uninstall the hardware, but is there another better solution yet?
     
  13. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Well, when I switched to the official version (not the beta or RC anymore), I didn't have the balls to install the driver in the first place, so to this day I haven't done it. The reader seems to work great without the driver, but I do notice that it'll bottom-out on transfer speeds sometimes. It's one of those things that I haven't summoned up the courage to test yet.

    However. I'll probably finally reinstall my OS one last time, since I seem to be cluttering it up too quickly. Before I do so, I'll absolutely try installing the driver for the reader and see what happens, and I'll post the result here.

    Until that time, though, I'd say that the best action is to never install the driver in the first place, if your concerned about the problem. After you've uninstalled the hardware through the device manager, I'm not sure how to recover the situation, as I never had to do that. (I was always reloading the OS for various reasons.)
     
  14. danceguy

    danceguy New Member

    Joined:
    Jan 5, 2010
    Messages:
    8
    Likes Received:
    0
    thanks for your post! so your reader works without that particular driver? so if i uninstall the hardware, 7 might recognize the device after the uninstall? or do i misunderstand?
    sorry you had to go down this path, but thanks for your knowledge!
     
  15. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Yes, I would expect that you could make it do that. However, Windows will probably remember that you intentionally got rid of the hardware, so it may not automatically say "Hey! I found new hardware!". You might have to explicitly check for new hardware, or explore the Device Manager to see if you can find the device again, with a '?' or a '!' on its icon.

    Please let me know how it plays out! I'm very interested to know.
     
  16. danceguy

    danceguy New Member

    Joined:
    Jan 5, 2010
    Messages:
    8
    Likes Received:
    0
    Interestingly, the fresh clean install of windows 7 solved this issue. Card reader works fine, machine starts up and shuts down without a hitch, and sleeps now. So the upgrade protocols seem to have been the culprit. Thanks for your posts!
     
  17. tonightslastsong

    tonightslastsong New Member

    Joined:
    Jun 26, 2009
    Messages:
    26
    Likes Received:
    0
    Just to be clear, did you go ahead and install the driver for the card reader, or did you leave it out (like I've been doing)?
     
  18. danceguy

    danceguy New Member

    Joined:
    Jan 5, 2010
    Messages:
    8
    Likes Received:
    0
    sorry meant to say - windows 7 has the same driver already installed, it works fine with a clean install.
    i never uninstalled the hardware either, just did a clean install of windows 7 and all worked fine.
     

Share This Page

Loading...