Can't write to writeable Samba share

Discussion in 'Windows 7 Networking' started by Stilby, Oct 8, 2009.

  1. Stilby

    Stilby New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    2
    Windows 7 Enterprise 90 day (64bit)

    A big improvement over 7 RC which would hang if I attempted any file sharing with my Ubuntu Samba share. However, now I can read my shares but can't write to a writeable share with guest access. I have added the cridetials 'guest' with no password and that maintains the mapped drives between reboots but I can't write. I can of course write to the share in Leopard, Snow Leopard, Xp and OpenSolaris but not from Windows 7. I'm half expecting someone to tell me it's a security feature which needs to be unlocked using a program which doesn't appear in any menu and has to be run from the Start Menu or perhaps in the registry but how can writing a file to another system be a security issue?

    Any pointers at all will be welcomed, even speculative ones. Let me know if you can write to your Samba shares. My smb.conf is very simple but I've written more complex ones in my time. If I can fix it at that end, that would be fine too, better in fact as I don't administer all the systems that connect to this share.

    (As an aside: As you can see I have a number of different systems available to me so please feel free to ask me to test or reproduce problems you might be having.)

    Stilby AKA Mike Freeman IRL
     
  2. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    Ok here's a speculative one. Go to:

    Get Vista and Samba to work - Blogs - Code Monkey Business - Builder AU

    The same procedure works in W7 to call it up. I'm not trying to do this now but I ran into it once with Vista. At the moment I'm not trying to use Ubuntu.

    Anyway, mine is set to "Send LM & NTLM responses". I haven't touched it. There are other options. Maybe you need one of them.
     
    #2 stueycaster, Oct 11, 2009
    Last edited: Oct 11, 2009
  3. Stilby

    Stilby New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    2
    Not a solution but a way forward!

    ____________


    This reminded me of some notes I made on setting up 2008 Server as a desktop and getting 7 to connect to OS X shares. Only they used the group policies editor gpedit.msc I guess that cascades down to local policies. It didn't help with my Samba share as I'm using the latest version of Samba which I believe now supports the default NTLMv2.

    However you helped solve a problem I hadn't discovered yet! Which was connecting to OS X Shares. As it was I couldn't. Your fix does fix the OS X shares (you also need to disable 128bit encryption).

    I will now troll through the Group Policies Editor looking at all the help tabs in hope that one of them speaks to my problem. So you have given me a way forward. Thank you.
     
  4. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    Cool. :) The setting: "Send LM and NTLM - use NTLMv2 session security if negotiated" didn't work?
     
  5. Stilby

    Stilby New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    2
    Still can't write to Samba but fixed another problem!

    Yes I did, as it is also required to access OS X shares. Bare in mind that my situation is that I can access both shares //zion/shares (ro) and //zion/swap (rw) but I can't write to swap, I can only read, even though it works for all my other OSs including, as I just discovered, Windows 7 RC. I've tried two systems with Win7Ent 90day and both can see but don't have permissions to write. So what changed from RC to the release version?

    Interestingly, my old problem of not being able to read from a Windows 7 share was a hardware problem! I tried a different NIC and the problem went away. The problem NIC was an onboard Attansic L1 Gigabit on my Asus P5KC. I just installed the Vista64 drivers from the Asus website and it works OK now.
     
  6. stueycaster

    stueycaster Millennium Celebration Award Winner
    Premium Supporter

    Joined:
    Feb 5, 2009
    Messages:
    1,519
    Likes Received:
    53
    Here's a thought. I have mapped a network drive of a folder on my wife's laptop into "Computer". If I right click it and click properties then go to the Security tab there is a way of setting permissions. It's set to allow "Everyone" and the only permission that is not allowed is "Full control".
     
  7. Stilby

    Stilby New Member

    Joined:
    Oct 8, 2009
    Messages:
    14
    Likes Received:
    2
    Thank you for all your suggestions

    It won't let me change any of those settings but thanks for making me aware of those settings. One possibility is to sit down with both RC and Ent side by side and go through all the settings in gpedit. That could take a few hours and isn't garanteed to find me the solution but it's a possibility if no one comes up with a better idea. Thanks for coming back with more ideas though. I could revert to using RC as it works. Of course I'd be screwed next year when it runs out and I have to buy the real thing knowing full well it doesn't work!!! I guess that's why I use Unix, Linux & Macs for the important stuff and Windows for playing games. Of course the most time consuming game is getting it working ;-)
     
  8. Han

    Han New Member

    Joined:
    Jan 12, 2011
    Messages:
    6
    Likes Received:
    0
    Did you ever find a solution to the problem, I am having the same problem.

    Thanks
     

Share This Page

Loading...