CCC: Host application has stopped working

#1
Hello,

I'm having a problem with catalyst control center. Whenever I boot into windows I get a message saying: CCC host application has stopped working and my CCC automatically shuts down.
I'm having this problem for a while (a few months) and I tried a few things to fix it but it didnt work. I have no idea what exactly I did before I started expiriencing this problem.

I tried uninstalling CCC and installing it again from the official AMD website. I update my windows and all of the other applications regularly.

If anybody has any advices how to fix this issue I'd be grateful.
Thank you in advance.
 


kemical

Windows Forum Admin
Staff member
Premium Supporter
Microsoft MVP
#2
Hi, you could try un-installing the driver again and then running driver sweeper: Phyxion.net - Driver Sweeper Then re-install making sure you turn off any anti-virus apps. I'd also run a malware scan with something like malwarebytes: Malwarebytes : Free anti-malware, anti-virus and spyware removal download just to make sure nothing untoward is happening..
 


#3
It worked. Driver sweeper did the trick. CCC is working normally now. Thank you for your help!
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.