CD drive not showing up....tried filters

Discussion in 'Windows 7 Hardware' started by vorbroker, Nov 30, 2009.

  1. vorbroker

    vorbroker New Member

    Joined:
    Nov 30, 2009
    Messages:
    6
    Likes Received:
    0
    My CD/DVD drive isnt showing up in my computer or in the device manager.

    My drive is an Optiarc DVD RW AD-750A

    My computer is a Lenovo ideapad-Y710 laptop

    I have had this problem for a while. I finally just backed up to an external and re installed windows.

    but still the problem exists.

    I know there isnt a problem with the drive because it works if i put in a boot CD like the windows 7 install CD or an Ubuntu 9.10 CD.

    I have tried the filter registry editing approach with no luck.

    im also getting 2 base system devices that can't find drivers automatically. I'm not sure if this is related or not but it doesn't really give me any more info than that.

    I'm not new to computers or anything. Other people think I know everything but i don't think they know how Google works haha. This is one situation where Google isn't helpful, because all of the search results come up with solutions that involve filter registry blah.

    Thanks for any help.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Did this just start when you went to Win 7? Have you checked to see if any chipset drivers are availiable for your laptop for win 7?

    Does it behave the same if you have media in the drive?
     
  3. vorbroker

    vorbroker New Member

    Joined:
    Nov 30, 2009
    Messages:
    6
    Likes Received:
    0
    No, this isn't new to windows 7....it worked on windows 7 before. What happened was I tried to dual boot Ubuntu 9.10 with windows 7 and when i finished installing them both it wouldn't work so then i just reinstalled windows 7 completely without Ubuntu and now it isn't working. When I put in a CD and close the drive it makes a noise like its going to work but it just doesn't show up.

    I downloaded the chipset driver and it didn't help.

    it does the same thing no matter what is in the drive.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Possibly the Linux install wrote something to the drive to mess it up in windows.

    Have you done a cold boot? Have you checked the Device Manager with the hidden items shown? Have you checked the Device Manager while in Safe Mode?

    If you find it, try to uninstall it and let Windows find it again. Maybe unplug it for a couple of boots and try again.
     
  5. vorbroker

    vorbroker New Member

    Joined:
    Nov 30, 2009
    Messages:
    6
    Likes Received:
    0
    I tried a cold boot...no luck

    I checked the device manager for hidden items...no CD/DVD drive category at all.

    I checked the device manager in safe mode...no CD/DVD drive category at all.

    I checked the device manager in safe mode for hidden items...no CD/DVD drive category at all.

    i opened my laptop up.....and i couldn't figure out how to unplug or remove the drive...then i checked the internet and searched and searched on Google and Bing and all the results are unrelated. they were either about a different computer completely or some other random problem....nothing for a Lenovo Ideapad Y710 CD/DVD drive
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Well, the only other thing I could think of would be the possibly the IDE controllers. Maybe you could find the one that might control the DVD and see if any settings there could be changed.

    Is there any chance the DVD could be listed as some other type of device?

    My DVD drive on this Dell, slides out if I remove a screw. It might help to try that, or it may not, if you can even get access to it.

    You mentioned something about some devices that do not have drivers. Have you tried getting them to load as a DVD?

    Since you have already reloaded Windows, I suppose it would not help, but just for the heck of it, have you tried opening an Administrative command prompt and running sfc /scannow to check your system files?
     
  7. mgomps

    mgomps New Member

    Joined:
    Dec 15, 2009
    Messages:
    2
    Likes Received:
    0
    I have the exact same problem on the exact same laptop. My issue started when I uninstalled Vista and installed windows 7. Every solution I found was about removing the upper and lower filters which werent even in my registry.
     

Share This Page

Loading...