Changed Shell32.dll to notepad by accident!

#1
I'm far from a computer expert, other than games I don't know much at all.

I was trying to get a file for a game to work so I turned to google for help, It looks like I've gone onto something I shouldn't have.

The instruction on the website was to click start and type "Shell32.dll" into the search box.
The next instruction was to open it with Notepad, which I did... The box saying something like "always open using this program" was ticked.

After spending time googling what I'd just done it seems like that was a huge mistake, I have no idea how to change it back to its original state.
So far everything seems to be fine but from what I read on another site the shell32.dll file has something to do with the start up so I haven't turned my laptop off yet.
 


#2
Hello Sean,
to Windows 7 Forums

You can do a "System Restore" to undo the change you've made.

To access "System Restore" open Control Panel, click on "System and Security" then click on "System" in the left pane under Control Panel Home click on "System Protection" which will open your "System Properties" window, then click on the button "System Restore" it should open so you can choose a Restore Point.
Make sure you have no other open programs or windows as it will restart to perform the necessary actions, so let it run it's course.

Let us know how it goes

Don
 


Saltgrass

Excellent Member
Microsoft Community Contributor
#3
You should be able to do the same thing you did the first time, but it should show as "unknown application".

If you go to the Start Menu, all Programs, Default Programs, Associate file type, you might be able to remove the notepad entry there. If not, we may have to go to the registry if Adamsappleone's suggestion does not work.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.