Changing a drive permissions?

Discussion in 'Windows 7 Help and Support' started by jon12, Aug 2, 2010.

  1. jon12

    jon12 New Member

    Joined:
    Aug 2, 2010
    Messages:
    4
    Likes Received:
    0
    Last night I started to change the permissions on my D drive, there was a lot of files though so I cancelled it halfway through to do it another time. Now I can't do anything with the drive, open it, view files, change the permissions, all I can do is see the icon in My Computer view.

    How can I sort this??
     
  2. cybercore

    cybercore New Member

    Joined:
    Jul 7, 2009
    Messages:
    15,823
    Likes Received:
    321
    Have you tried right-clicking drive D in my computer, security tab, and allowing access to this drive?
     
  3. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Try activating Vista's hidden administrator then taking ownership.

    The hidden administrator is the most powerful user, so remember to disable it after you have finished with it.

    A tutorial from the How To Geek:

    http://www.howtogeek.com/howto/win [...] ows-vista/

    *************

    When you DO change your permissions: (DONT DO THIS ON A ROOT FOLDER.)
    You need to use the security tab and take ownership of the files.
    Right click on the relevant folder, click properties->advanced->owner->* click edit. Make sure the "replace ownership on subfolders" box is selected, select your account from the provided list and click ok.
    Note it should say you may need to reopen the folder for the permissions to fully take effect, that should fix things, it's quite a common issue with new installs and files from other computers.
     
    #3 zvit, Aug 2, 2010
    Last edited: Aug 2, 2010
  4. jon12

    jon12 New Member

    Joined:
    Aug 2, 2010
    Messages:
    4
    Likes Received:
    0
    I tried the secret admin, but I still couldn't access it on my regular user account. I've solved it by copying everything to the C: in the secret admin user, then formatting the drive as the secret admin. Everything's fine now :)
     

Share This Page

Loading...