Check disk

#1
Hello
My PC has decided to do a check disk every time it boots up, can anyone please assist with finding what is causing it.
 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#2
Hi

This can be caused by a virus, so the first thing to do is run Malewarebytes.

Malwarebytes : Malwarebytes Anti-Malware PRO removes malware including viruses, spyware, worms and trojans, plus it protects your computer

If that comes up clean, try...

From run type...
From run type...Scf /scannow

Scans and restores system files.

Try starting in safe mode and see if it still does it.

Look in Device Manager and see if there is a error indicator on any of your devices.
This can be hardware or driver related.

See if you have a restore point before the problem started.
If so try going back to that.

You could try a repair install if nothing else works.

I'm pretty sure you can stop it from doing it by typing "chkntfs /x c:" at the command prompt.

But I would only do that if you absolutely can't find out why it's doing it, since it might become a bigger problem later if not addressed.

Mike
 


#3
I've now found that it's actually every few days and itquotes "a check disk was scheduled", I can't find anywhere to changethese settings.
I typed "chkntfs /x c:" (without " obviously) into the searchbox and it came up with the exe file, thinking I'd be able to look at an interfacewith this process I clicked on the file, I suspect that it has just done it asit just blinked and nothing came up.
It looks to me as if I've inadvertently done the process, justhope there will be no ramifications.

 


MikeHawthorne

Essential Member
Microsoft Community Contributor
#4
Hi

It's not in the search box that you have to type it.

Open the command prompt by going to Programs / Accessories / Command Prompt.
When you get to Command Prompt open it by right clicking on it and selecting Run as administrator.

When it opens you will see a black Window with a line that says C:\Users\Your User Name>There will be a flashing block and the end of the line.
If there isn't click in the window.

Where the flashing block is type....

chkntfs /x c:

This should turn off automatic disk checking on drive C:\

Here is a link to the Microsoft support site on the subject.

CHKNTFS.EXE: What You Can Use It For

Mike

Now I see that this may not apply to Windows 7, not sure one way or the other.
If it won't work it won't hurt to try it, it just won't do anything.
 


Last edited:

MikeHawthorne

Essential Member
Microsoft Community Contributor
#5
Hi Again

Check this out, I think this will stop your problem!

Check Disk - Reset - Windows 7 Forums

Mike

Another note, in my first post I mistakenly typed in the wrong command for scan now.
It should read....

SFC /scannow not SCF !!!
 


Last edited:
#6
Thank you for the chaps, I will see what happens in a few days (hopefully nothing).
Richard
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.