Clicking on Start Menu and Taskbar Items Doesn't Launch Program

Discussion in 'Windows 7 Help and Support' started by Chamenas, Aug 25, 2011.

  1. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    This is a recurring but inconsistent issue that I'm going through. Essentially, upon starting up my computer, from time to time, I have no yet been able to isolate what may cause this issue, I will find that I cannot launch programs from their shortcuts in the Quick Start or Taskbar menu. As of right now I have not tried to launch said programs from the original .exe file in this scenario.

    I've noticed that when I try to open these programs from the Taskbar, the icon will be surrounded by a square to indicate that it is active, but, after a period of maybe 5 seconds or so, sometimes longer, it will disappear and the program will no longer look active. Opening up the task manager, the programs usually show up in the Processes under the appropriate name. Multiple instances of a program can appear, even when, under normal circumstances, multiple instances aren't allowed (such as with Firefox). The processes will usually show a static amount of memory used, like 108k for any firefox.exe in the process list, and will simply sit there until they are ended, despite the program not actually running. When this happens I generally have to restart the computer and hope it works on the restart.

    Chkdsk has found no problems.

    I'm prepared to run a repair CD if need be, but I was curious for some opinions first. I'd like to keep wiping and reinstalling a last resort since that will take a lot of organizational effort to make sure I don't lose anything.
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I would probably run the System File checker first. Open an administrative command prompt and type SFC /scannow and allow it to finish.

    If that doesn't find any problems, perhaps an anti-virus might help, like Malwarebytes.

    I suppose it does the same thing if you hit Winkey + (number key for taskbar order), for instance, Winkey + 1 for whatever is in the first position.
     
  3. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    I forgot to mention that I've already run Malwarebytes. It did find one thing on the system (which is pretty incredible, it usually finds nothing, I'm pretty cautious). So I had it remove it and then I scanned again and it found nothing so the system is clean at least according to Malwarebytes.

    I've never tried the Winkey. Will try the System File checker first though. Thanks.
     
  4. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    No problems found with the system file scan.
     
    #4 Chamenas, Aug 26, 2011
    Last edited: Aug 26, 2011
  5. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    All I can do now is guess. If the Winkey were to work, I would suggest reinstalling your mouse driver.

    If you have several instances of a program open, have you made sure to shut them all down before trying to open a new one? Do your programs show up under applications, or just processes/services? After you restart your system, and you might try a complete shutdown, do the programs open normally at least once?

    Are you running multiple monitors? Are you running any type of utility that gives multiple screen options?

    Have you run any utilities that alter the task bar?

    If you right click the taskbar icons, and then possibly right click the application name, are you given any options, have you tried the Run as Admin one?
     
  6. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Winkey only works for Internet Explorer and File Explorer, both of which probably work with my mouse too, I just didn't click on them as programs to test when I originally had the problem.

    As mentioned previously, instances of the program isn't really the issue. The program will show up in task manager as a static memory value, and it will show up an equal number of times to the number of attempts of me trying to open it. I can clear out this "list" of the program, but it makes no difference in getting it to open.

    The only fix to the problem, currently, is restarting and hoping it works. If it doesn't, then I have to restart it again, eventually something happens and it all works fine.

    I don't run any utilities that alter the task bar. Just one monitor, no special utility.
     
  7. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    I'm throwing out solutions that helped others:

    1. Start PC in safemode. Go to Run: msconfig. Remove startup programs that you don't need. (Including Skype, messengers etc...) The one that caused issues for others, believe it or not, was an old sound card driver.
    2. From a user: Basically with my issue the problem was that in msconfig a service[LG Firmware] required by the CD/DVD drive to run was not being run at startup. Now enabling that solved my issue[not sure how it fixed other non-CD/DVD applications].
    3. Like you said, see if the problem exists when opening from the original exe and not the shortcut. If these are shortcuts that will not open, read here: Every program won't start - Windows 7 Forums
    4. Read from Microsoft and use the FixIt utility on that page: When you run an .exe file on a Windows Vista-based or Windows 7-based computer, the file may start a different program
     
  8. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Thanks. I forgot to mention that I already did some paring away in my MsConfig, was one of the first things I thought of. But maybe I didn't take out what I needed to, most anything I left seemed like it might be necessary though, so maybe I'll post up what's left or something.

    Will let you know more the next time it happens, I should have some time over the next three days to do some restarts and get it to happen.
     
  9. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    Right now all MsConfig has checked off is "Google Update", "EPSON Status Monitor 3", and "Catalyst Control Center" (ATI). I'm probably going to uncheck Google Update. I can't see anything in this list which looks like it should be important to startup, such as a possible CD/DVD program like you mentioned. Anyways, the unechecked ones are:
    OpenOffice.org 3.3
    PowerReg
    Epson all-in-one Registration
    CurseClientStartup
    Xvid
    Winamp Agent
    Creative Updreg
    Java Platform SE Auto Updater 2 0
    QuickTime
    Elements Organizer
    Logitech Camera Software
    iTunes
    Facebook Update
    EEventManager Application
    E-MU USB Audio
    DivX Update
    Elements Auto Analyzer
    Adobe CS4 Service Manager
    Adobe Reader and Acrobat Manager

    I tried clicking on the original .exe file, it doesn't launch the programs either.
     
  10. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
  11. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    I want to say that the Restore EXE association fixed it, but I'm tentative. I'll let you guys know if the issue surfaces again in the near future. Thanks.
     
  12. trunorz

    trunorz New Member

    Joined:
    Jul 6, 2012
    Messages:
    4
    Likes Received:
    0
    Hi there, I'm terribly sorry to grave bump this, but this is the only other place where I've found someone who had the same problem as me. I tried the EXE association, that worked for about a day or two, then when I shut down my computer and turned it on the next day, the problem as come back, and restoring EXE association no longer works. I've uninstalled .NET framework and I'm going to check if it works, but I'm doubtful.
     
  13. Chamenas

    Chamenas New Member

    Joined:
    Jun 24, 2010
    Messages:
    104
    Likes Received:
    0
    I haven't had any issues with this lately, and I can't remember doing anything other than the .exe association. Though it may be that I did run it a couple times before it stuck permanently (I can't remember). I hope you find a solution though, good luck to you!
     
  14. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    I've noticed the same kind of problems as you, Chamenas. I have Windows 7 Professional. Programs don't always start with one click on the Start Menu, or with a double click on a short cut - nor with a click on a taskbar icon. I never had this kind of problems with XP.

    I think it's a Windows glitch. Need to wait for a patch?
     
  15. trunorz

    trunorz New Member

    Joined:
    Jul 6, 2012
    Messages:
    4
    Likes Received:
    0
    Chamenas, I have a question. When you had this problem, did you have Google Chrome installed on the computer?
     
  16. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Well, I have Google Chrome installed, and it's the Browser I use. I also noticed another weird thing: I'm using Start Menu 7 and it occasionally leaves the "final outpost" hanging, like in http://i514.photobucket.com/albums/t350/Hamarahakki/StartMenuX.jpg, where you can see Windows Start Menu part over Google Chrome - it also "works" with other programs, and on the Desktop. It may go off, just to get back, but the only way to really kill it is to reboot.

    Not a big pain, but it never happened with XP.
     
    #16 Pauli, Jul 7, 2012
    Last edited: Jul 7, 2012

Share This Page

Loading...