COM Surrogate has stopped working

Discussion in 'Windows 7 Help and Support' started by 1Bit, May 16, 2013.

  1. 1Bit

    1Bit Well-Known Member

    Joined:
    Feb 14, 2013
    Messages:
    20
    Likes Received:
    0
    SYSTEM: Core-i5 3470 - 8Gb Crucial 1333Mhz - XFX Pro Core PSU - Gigabyte H77 board - Samsung 840 SSD

    Hi

    Ive recently been having problems on my PC which started when I ran a program called DSL Stats alongside Avast Internet Security that had replaced Norton Internet Security (uninstalled, then used removal tool, then reboot before installing Avast) - soon as I executed DSL Stats (router monitoring made by Roseway on kitz forum, previous versions were fine) the PC done lots of strange things such as logging out then in, showing only some processes in task manager, being unresponsive, causing USB Devices and PCI-E wifi to disconect then reconnect...

    since then I have had a few "lock ups" where the PC just doesnt respond from sleep (or left it running to come back and find screen off but PC still on and unresponsive) and ive had to reset it and when I do I got "boot failure" from BIOS...this happened twice! , then when logging into windows my USB JoyPad and USB Mobile Phone drivers were corrupted and they wouldnt work (error 43), I could only get them working by uninstalling, removing, reboot, inserting into different usb port, reinstalling...and even then the USB Joypad would revert back to "unable to install" at every reboot... the phone did not for a while until tonight I plugged it in to charge and it would not show up in my computer, so I did the reinstalling thing and reboot, when i went to browse the phone as soon as I went into the folder it said:

    COM SURROGATE STOPPED WORKING

    when i looked at the error it said something about rpcrt4.dll being the problem?

    can anyone help with this... Iam getting really pee'd off with it

    since removing the once permanently connected USB JoyPad from the system I have had no problems with it freezing & then failing to boot straight afterwards (although this only happened 2 or 3 times in quick succession (a few days)).

    appreciate it if anyone could help?

    here is the error from EventViewer:

    Faulting application name: DllHost.exe, version: 6.1.7600.16385, time stamp: 0x4a5bc6b7
    Faulting module name: RPCRT4.dll, version: 6.1.7601.17514, time stamp: 0x4ce7ba59
    Exception code: 0xc0020043
    Fault offset: 0x0005cd99
    Faulting process id: 0x948
    Faulting application start time: 0x01ce52941c8e0015
    Faulting application path: C:\Windows\SysWOW64\DllHost.exe
    Faulting module path: C:\Windows\syswow64\RPCRT4.dll
    Report Id: 5b6ffdd8-be87-11e2-87bb-50e549bb754c

    and right after it is this:

    Event filter with query "SELECT * FROM __InstanceModificationEvent WITHIN 60 WHERE TargetInstance ISA "Win32_Processor" AND TargetInstance.LoadPercentage > 99" could not be reactivated in namespace "//./root/CIMV2" because of error 0x80041003. Events cannot be delivered through this filter until the problem is corrected.

    thanks
     
    #1 1Bit, May 16, 2013
    Last edited: May 17, 2013
  2. Pauli

    Pauli Extraordinary Member
    Premium Supporter

    Joined:
    Mar 1, 2012
    Messages:
    2,499
    Likes Received:
    211
    Did it say anything more about the rpcrt4.dll ? Cause?
     
  3. 1Bit

    1Bit Well-Known Member

    Joined:
    Feb 14, 2013
    Messages:
    20
    Likes Received:
    0
    hi, sorry - ive edited the first post to include errors from EV

    thanks
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The error message, is fairly common on some systems. You can search for the message and get many hits. One is linked below, but another link seems to indicate a worm is involved. I can tell you I installed using the SP1 DVD and got the message. Using the fixit yourself, I got rid of that message. It is probably not related to your situation.

    Event ID 10 is logged in the Application log after you install Service Pack 1 for Windows 7 or Windows Server 2008 R2

    Can you uninstall DSL stats? I see version 3.2 is available...
     
  5. 1Bit

    1Bit Well-Known Member

    Joined:
    Feb 14, 2013
    Messages:
    20
    Likes Received:
    0
    hi, thanks for your reply


    I havent just installed any service packs, but did install some updates the day before this message popped up because I restored windows back as far as I could after the problems occured (which was 8 days previous) but still problems remain, Ive ran


    the person who wrote DSL Stats says he uses Lazarus to render a win32version of his Linux mux as he uses Linux, he does test it on WinXP but it doesnt get any extensive testing, he says theres no major changes from the previous version (called RS-W) which ran fine on my machine... all i know is I had NIS 2013 installed, removed, installed AVAST IS and next day I upgraded RS-W to DSL Stats and ran it..soon as I done that it all went funny...the very second I ran it.


    ive just ran SFC /SCANNOW and it said it found some corrupted files and repaired them...

    when I reboot it said the COM SURROGATE STOPPED WORKING again when I opened My Computer..??? and now wont show anything in there as the progress bar just keeps climbing and repeating..even if i close and reopen it

    EDIT: i reboot and my computer worked fine, i closed it and plugged in my phone by USB and again it went like below:

    [​IMG]
     
    #5 1Bit, May 17, 2013
    Last edited: May 17, 2013

Share This Page

Loading...