Windows 7 Computer crashes when loading Battle field 3

#1
Hi, when I'm loading BF3 to play online, my computer suddenly crashes to black screen. Sometimes when it crashes the cpu fan goes so loud so I checked the temperature as I load the game. The temp hits 50 Celsius and crash to black screen again. I have no clue what is going on. Please somebody help me.



My computer is..

Running on Window 7 64 bit
Inter I7-2600K
Nvida Geforce GTX 560
Asus P8Z68-V pro
12Gb of Corsair Vengence (ram)
120G of Corsair Force GT SSD

I also did the SF diag tool
 


Attachments

#2
Is this the temp on the cpu or gpu? Have you checked for any blockages on the heat-sinks for both cpu and gpu as well as the fans? Does your case have adequate air flow...is it being cooled and vented properly? Do you have the latest driver for your GPU?
 


#3
It doesn't appear to be the hardware that's at fault, but the application of that hardware to running Windows 7.

I'll bet you've done nothing to re-tune W-7 to take full advantage of your hardware and ram. Right?

Windows 7, like all MS OS's, comes to you at factory default, designed to run on a computer with a single core CPU, and minimal ram, ergo, it still runs much of itself from the hard drive. It's kind of like a new Corvette, with a governor in the engine so it will only run 45 miles per hour. It's SAFE, but definitely not what the buyer wants.

BSOD's, crashes, etc., tells me and should be telling you that there is an internal conflict.
Possibly: Two programs are trying to grab the same memory locations, or, the CPU is just getting Jammed up with too many programs, services and TSR's all demanding attention. Having 50 to 80 services running in the background on Win-7 is not unusual.
It's horrible, but it's common. I shut off about 40 un-needed services when I first set up a new PC with Windows 7 on it.

Then if you have a multi-core CPU, windows will use just one, by default, till you tell it otherwise.

You have lots of ram, but winders is NOT using it effectively.

Good Luck,
Doctor O.T.
 


#4
go to system configuration by typing that into the start orb's search field, then select boot tab, then select advanced options to have a look.


View attachment 18221
 


Last edited:
#5
Is this the temp on the cpu or gpu? Have you checked for any blockages on the heat-sinks for both cpu and gpu as well as the fans? Does your case have adequate air flow...is it being cooled and vented properly? Do you have the latest driver for your GPU?
Thanks for the reply. Its the temp of the cpu and I cooler master cpu cooler so that should be fine and gpu fan seems to run fine. I have total of 8 fans in the case with good air flow. I also checked all the drivers are up to date.
 


#6
It doesn't appear to be the hardware that's at fault, but the application of that hardware to running Windows 7.

I'll bet you've done nothing to re-tune W-7 to take full advantage of your hardware and ram. Right?

Windows 7, like all MS OS's, comes to you at factory default, designed to run on a computer with a single core CPU, and minimal ram, ergo, it still runs much of itself from the hard drive. It's kind of like a new Corvette, with a governor in the engine so it will only run 45 miles per hour. It's SAFE, but definitely not what the buyer wants.

BSOD's, crashes, etc., tells me and should be telling you that there is an internal conflict.
Possibly: Two programs are trying to grab the same memory locations, or, the CPU is just getting Jammed up with too many programs, services and TSR's all demanding attention. Having 50 to 80 services running in the background on Win-7 is not unusual.
It's horrible, but it's common. I shut off about 40 un-needed services when I first set up a new PC with Windows 7 on it.

Then if you have a multi-core CPU, windows will use just one, by default, till you tell it otherwise.

You have lots of ram, but winders is NOT using it effectively.

Good Luck,
Doctor O.T.
Thank you for the reply. I'll be sure to turn off unnecessary stuff and trying to using hardware effectively.
 


#7
go to system configuration by typing that into the start orb's search field, then select boot tab, then select advanced options to have a look.
Thanks for the reply. Thank you for the direction.

In the Boot Advanced option the number of the processor was 1 so I changed to 8.
I also changed the startup programs.
But I have no idea what to turn off on service tab.
 


Last edited:

Highwayman

Extraordinary Member
#8
50C is certainly not a temperature that would cause problems with shutdowns on any chip I know of since the dawn of PCs....same goes for GPU... however if a hard drive/mobo/ram or maybe PSU where hitting 50C then that is time for concern.
 


Highwayman

Extraordinary Member
#9
Then if you have a multi-core CPU, windows will use just one, by default, till you tell it otherwise.

Windows 7 doesn't have that issue multi-core CPUs at all... Windows 7 is the most multi-core friendly OS from microsoft and uses all cores effectively without any configuration, maybe you thinking about XP there.

Forcing a fixed value on Advanced Bootup for CPUs doesn't have any effect on windows function, that is complete urban myth, it's merely to enable a feature to use more than one cpu core during booting sequence ONLY, but once in desktop has no further role and using that often causes more problems than it ever solved.

Need proof? simply run task manager in the desktop without that "tweak" and you will see all your CPU cores happily jumping around as you launch or open things without forcing it. You can also get a gadget for the sidebar from Most Wanted Windows Gadgets - Windows Vista and Windows 7 that gives you the same multicore rendering information in a small handy gadget.
 


Last edited:

AceInfinity

Senior Member
Microsoft MVP
#10
Summary
Code:
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************
Use !analyze -v to get detailed debugging information.
BugCheck 116, {fffffa800c2242e0, fffff8800ff29ae4, ffffffffc000009a, 4}
Unable to load image \SystemRoot\system32\DRIVERS\nvlddmkm.sys, Win32 error 0n2
*** WARNING: Unable to verify timestamp for nvlddmkm.sys
*** ERROR: Module load completed but symbols could not be loaded for nvlddmkm.sys
Probably caused by : nvlddmkm.sys ( nvlddmkm+c3bae4 )
Followup: MachineOwner
---------
7: kd> !analyze -v
*******************************************************************************
*                                                                             *
*                        Bugcheck Analysis                                    *
*                                                                             *
*******************************************************************************
VIDEO_TDR_FAILURE (116)
Attempt to reset the display driver and recover from timeout failed.
Arguments:
Arg1: fffffa800c2242e0, Optional pointer to internal TDR recovery context (TDR_RECOVERY_CONTEXT).
Arg2: fffff8800ff29ae4, The pointer into responsible device driver module (e.g. owner tag).
Arg3: ffffffffc000009a, Optional error code (NTSTATUS) of the last failed operation.
Arg4: 0000000000000004, Optional internal context dependent data.
Debugging Details:
------------------

FAULTING_IP: 
nvlddmkm+c3bae4
fffff880`0ff29ae4 4883ec28        sub     rsp,28h
DEFAULT_BUCKET_ID:  GRAPHICS_DRIVER_TDR_FAULT
CUSTOMER_CRASH_COUNT:  2
BUGCHECK_STR:  0x116
PROCESS_NAME:  System
CURRENT_IRQL:  0
STACK_TEXT:  
fffff880`04014a48 fffff880`02f61000 : 00000000`00000116 fffffa80`0c2242e0 fffff880`0ff29ae4 ffffffff`c000009a : nt!KeBugCheckEx
fffff880`04014a50 fffff880`02f34867 : fffff880`0ff29ae4 fffffa80`0b532000 00000000`00000000 ffffffff`c000009a : dxgkrnl!TdrBugcheckOnTimeout+0xec
fffff880`04014a90 fffff880`02f60e0f : fffffa80`ffffd84d ffffffff`fffe7960 fffffa80`0c2242e0 fffff880`0ffa1dc0 : dxgkrnl!DXGADAPTER::Reset+0x2a3
fffff880`04014b40 fffff880`0ffa1ec1 : fffffa80`0ba6f670 00000000`00000080 00000000`00000000 fffffa80`0b524010 : dxgkrnl!TdrResetFromTimeout+0x23
fffff880`04014bc0 fffff800`0377dfee : 00000000`01318b64 fffffa80`0b527060 fffffa80`09729450 fffffa80`0b527060 : dxgmms1!VidSchiWorkerThread+0x101
fffff880`04014c00 fffff800`034d45e6 : fffff800`03658e80 fffffa80`0b527060 fffff800`03666cc0 fffff880`01242384 : nt!PspSystemThreadStartup+0x5a
fffff880`04014c40 00000000`00000000 : 00000000`00000000 00000000`00000000 00000000`00000000 00000000`00000000 : nt!KxStartSystemThread+0x16

STACK_COMMAND:  .bugcheck ; kb
FOLLOWUP_IP: 
nvlddmkm+c3bae4
fffff880`0ff29ae4 4883ec28        sub     rsp,28h
SYMBOL_NAME:  nvlddmkm+c3bae4
FOLLOWUP_NAME:  MachineOwner
MODULE_NAME: nvlddmkm
IMAGE_NAME:  nvlddmkm.sys
DEBUG_FLR_IMAGE_TIMESTAMP:  4e99233b
FAILURE_BUCKET_ID:  X64_0x116_IMAGE_nvlddmkm.sys
BUCKET_ID:  X64_0x116_IMAGE_nvlddmkm.sys
Followup: MachineOwner
---------
Bugcheck VIDEO_TDR_FAILURE 0x116
I expected something related to your graphics driver. It's an obvious assumption whenever you see a BSOD occuring from playing a game for the most part.
This one points towards nvlddmkm.sys which is your nVidia Graphics Driver.
Code:
!sysinfo cpuspeed
CPUID:        "Intel(R) Core(TM) i7-2600K CPU @ 3.40GHz"
MaxSpeed:     3400
CurrentSpeed: 3502
It doesn't look like you're overclocking anything with your i7 from the looks of it. You're clocking nearly at around 3.4GHz which is where you should be at, but if you are overclocking that extra 0.1 GHz, then I would recommend to STOP doing that.
Overheating and PSU issues are common with this particular BSOD.
The temp hits 50 Celsius and crash to black screen again
Now is this your CPU temp or your GPU temp, and have you checked both? 50C is low, but if that's only your CPU temp I would highly recommend checking the core temp on your GPU.
You can also do a GPU Stress test here: FurMark: VGA Stress Test, Graphics Card and GPU Stability Test, Burn-in Test, OpenGL Benchmark and GPU Temperature | oZone3D.Net
Check for any warnings in device manager under the display area, and also your event viewer.
If we don't find an issue here, I would suggest that you also try running System File Checker to see if there's any corrupt system files. To use it, open command prompt and type this in:
Code:
sfc /scannow
This should repair any corrupted system file entries.
Last resort would be to do a reinstall for that particular driver (nVidia Graphics Driver). Make sure you reboot after uninstall, boot the machine back up, then reinstall, and reboot once more for changes to take effect when the system starts again. A good program to use for uninstalling drivers would be a program called Driver Sweeper

I'm getting warnings on the symbols for this driver, so possibly a reinstall could be the answer, but it's always good to take a runthrough for the above steps before I mention reinstalling the driver in this post as well :)

Cheers
~Ace
 


#11
Windows 7 doesn't have that issue multi-core CPUs at all... Windows 7 is the most multi-core friendly OS from microsoft and uses all cores effectively without any configuration, maybe you thinking about XP there.

Forcing a fixed value on Advanced Bootup for CPUs doesn't have any effect on windows function, that is complete urban myth, it's merely to enable a feature to use more than one cpu core during booting sequence ONLY, but once in desktop has no further role and using that often causes more problems than it ever solved.

Need proof? simply run task manager in the desktop without that "tweak" and you will see all your CPU cores happily jumping around as you launch or open things without forcing it. You can also get a gadget for the sidebar from Most Wanted Windows Gadgets - Windows Vista and Windows 7 that gives you the same multicore rendering information in a small handy gadget.
Thats not what he was getting at. What you are seeing is many programs running and using processor power. The point he was getting at is that login.exe, explorer.exe, rundll32.dll, dwm.exe, will only use a single core to run, unless otherwise set to. This is all because it is part of the OS, not external software from the OS. Internet Explorer, Calculator, Windows Media Player, these are all external programs. Not something that is deep rooted in the OS. I guess the better way to say it would be user mode as appose to System/kernel mode. System/kernel mode is designed to run on the bare minimum, where user mode is set to use as much of the avalable resources as possable. It works, and makes it work an any system set up. Though it could be made to work even better.
 


Highwayman

Extraordinary Member
#12
Strange as mine clearly uses all the cores as it see fit for explorer when I check the CPU affinity they are all ticked, and this is also reflected in the taskmanager and system performance monitors.
 


#13
Explorer is an external application from your OS as well. Things like svchost, scrss, winlogon or dllhost are examples of OS applications that would be affected by the OS not running on all cores. Anything outside of that is run by its own set of rules regarding what cores and how many. All external applications can be changes with out the OS needing to know if you know where the configuration for that application lies.
 


#14
I also faced such kind of problems while playing games and the main reason for temperature increase in CPU or may be your system got virus infected. Also check that game source of battlefield 3 is proper or not.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top