Computer unresponsive until windows connects to network

#1
Summary:
About a month ago I started to notice my computer taking an extra 2-3 minutes to load all of my startup programs. I disabled all startup programs and Windows took just as long to become usable. I did not install any new programs or change any settings (that I can think of) that might have caused this.

Issue:
When I first see the Windows desktop, the network icon in the lower right (by the clock) has a circle over it indicating that it is connecting to a network. While this is happening, no other programs will load. I can click on programs but they do nothing until the network finally connects - then they all load at once. This circle is over the icon for almost 2 minutes.

Things I have tried:
I have tried installing new drivers for my LAN card, Chipset, Video card, Sound card, Raid drivers, and even updated my BIOS (of course one at a time, rebooted to test then tried the next). Nothing made this issue go away. I also reverte them all back two releases - still no luck.

Temporary fix that I have found:
I did find one thing that stops the issue from happening; boot the computer up while the network cable is unplugged. The computer and all programs start as normal, then I just plug in the network cable and it connects in 2 seconds.

The big question:
So why does Windows take 2 minutes to connect to a network when it is booting up, but only 2-3 seconds once it's already booted, and how do I fix the issue?

Computer specifications:
Motherboard: Intel DX58SO
CPU: Intel Core i7 920 @ 4.0Ghz (200x20)
RAM: OCZ Gold 3x2GB @1600mhz 8-8-8-24
LAN: Integrated Intel
Video Card: Sapphire ATI Radeon HD5970 2GB @ 875/1200 (725/1000 stock)
Sound Card: Creative Labs Soundblaster X-Fi
Hard Drives: 2x Western Digital Caviar Black 640Gb in RAID0

Water cooled CPU (max 61c full load)
Water cooled GPU (max 47c max load)

Thank you for all who help!
 


Trouble

Noob Whisperer
#2
Wow, first let me apologize, your first post seems to have fallen through the cracks and has been sorely neglected. Very sorry and welcome Tubesock, to the Windows 7 Forums.
The issue that you have described could be the product of a few different causes, my immediate suspicions would be a convergence of services and driver processes all wanting to grab the next available processor thread. What I might suggest for you to try just to see if we can take a couple services out of the pecking order is to turn off the DHCP Client service, as well as the DNS Client service and manually assign static values for this information within the properties of IPv4, in the properties of your network adapter. As well as turning off IPv6 while you're in there, unless of course you are using home groups. In a small home network, with few nodes, DHCP is really just unnecessary overhead. Except for the convience of supporting traveling laptops, I would even turn it off on the router. The decision of course is up to you, but I would be suprised if you didn't see some improvement with DHCP out of the mix for your desktop.
 


#3
Ok did all of that, still having the issue. Any more ideas?

Thanks!
 


Last edited:

Trouble

Noob Whisperer
#4
Sorry, it looks, from what you are saying that I may have made a stupid assumption. I was thinking that you either had your own router in place, between your ISP's provided device, or that your ISP had provided you with a modem, that included routing capability and had switch ports on it, and in both or either case you were using or at least had the potential to use private reserved addresses with network address translation on your individual home computer(s). But....
from what you have said, it looks like you are going straight from the ISP device to your computer and are receiving a live or public ip address on your network adapter, which of course is also almost certainly dynamic and subject to change everytime your computer is rebooted or turned off for a period of time.
So if you would clarify for me so I can stop guessing (badly), how are you connecting, what device(s) are in place, and what ip addressing scheme is typically present on your network adapter... command prompt, type ipconfig /all
As far as your gateway not being in the same nework as the IP Address.... I don't believe that that's possible, and you can bet that they have subnets or supernets, and PVCs in place to make it work.. but simply stated your gateway is the only means to get out of your own yard and go play in the street, if your gate was in your neighbor's yard then you would be confined to yours an unable to get outside and play with others.
 


#5
I'm sorry, Trouble. I posted that post, then edited a few moments later as I got it to work. You must have been posting when I edited the thread. At any rate I am hooked up through a router to a modem. I did get the connection to work manually through setting IP addresses in the router and the computer's adapter settings - also disabled DHCP and DNS Server services. On the other hand, I am still having that delay at the start of the computer. Interestingly enough, I can open Task Manager, and other Windows oriented programs, but no other programs load during the lag time. (i.e. I can open control panel, and resource monitor, but cannot open firefox, or any other program at that time.
 


Trouble

Noob Whisperer
#6
Thanks for the update. Can you see in task manager, processes tab, check the box to view processes for all users, then click on the column name CPU to sort which processes are making demands on the processor. That could possibly give us a clue as to what's going on.
Have you confirmed that with the changes, you've made, that your network is loading promptly and when you hover over it in the system tray / notification area that it's showing viability with internet access or is the circle still over it? Does the same trick / workaround you described earlier still work?
I know you mentioned that you had taken steps to inhibit startup programs from causing problems, maybe take a look at services
Type msconfig in the search bar and hit enter
Go to the services tab and then check the box that says "Hide all Microsoft services" near the bottom
Then click on the word status in the status column header to sort by running / stopped
Is there anything there that might give a hint to what's going on
 


#7
The workaround where I can unplug the network cable until a few seconds after boot then plug it in, still works. The cpu is a 0% during that time.
 


#8
unfortunately, it may be directly related to overclocking. for no reason at all, no changes to the system were made, overnight just like that on an overclocked system, said symptom occurs. reformat/reinstall gives the same sequence of events- first its fine and then its not.

if anyone finds a solution or a fix could you please let me know vivide@gmail.com

cheers.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top