Configuration registry corrupt

Discussion in 'Windows 7 Help and Support' started by tamn, Jan 26, 2012.

  1. tamn

    tamn New Member

    Joined:
    Jan 26, 2012
    Messages:
    6
    Likes Received:
    0
    Ok, so first things first, I am not a retard, I have been using pc's all my life, I have had very few problems ever, and never one I have never been able to solve on my own with some google help. this week I have spent many many many hours researching and trying fixes for this with no success at all.
    It seems my "Configuration Registry is corrupted" whatever that means I have no idea really. My pc boots fine, runs fine, this "problem" occured over a year ago and I managed to fix it then as it was a MBR problem.

    This must be some sort of "leftover" problem, anyways after much much googling the only fix I've found is using a repair disk or install disk to do that whole Bootrec /rebuild bcd thing. All good, this is what I would like to try. LET ME STRESS THIS NOW: I KNOW WHAT A BIOS IS, HOW IT WORKS AND THAT IT IS SET UP PROPERLY, it is set correctly, the cd drive is booting first. (95% of the googled threads are people asking if the guy has it set up right)

    Now, I put in my original windows 7 install disk OR my windows 7 repair disk (homemade), with either one, it boots straight to windows every single time. I thought maybe something was up with my repair disk or something so I remade one, same files, sizes, etc, all the same.

    I tried the install disk on another pc, works correctly. Also, I can read/write to my cd's when I have the OS booted up. everything works 100% fine.

    As I said my OS works totally fine and I've been using it for a long time now. I wanted to disable DEP, and that's when I noticed the "Configuration registry corrupt" message.

    I downloaded easyBCD and it also confirmed the "Configuration registry corrupt" message and was unable to access it.

    So....I'm totally stumped....haha help?
    Thought I'd take a shot here as I read these forums occasionally, before I wipe the damn thing and start over. :frown:

    The thing that confuses me most is I have not been able to find another thread of someone with this problem or one similar where there computer functioned perfectly fine and never had any errors or other problems.
     
    #1 tamn, Jan 26, 2012
    Last edited: Jan 26, 2012
  2. Drew

    Drew Banned

    Joined:
    Mar 25, 2006
    Messages:
    3,575
    Likes Received:
    146
    Tam,

    I understand you don't get, Hit any key to boot from CD so can't run Start-up Repair.

    Anyway, I went & read what I could about your issue.

    Mostly, I found, repair from the Win7 disc. But, also...

    1st) > cmd, Run as Admin. Type, sfc /scannow, hit Enter2nd) > cmd, Run as Admin. Type, scanreg/restore

    And this: "How to Recover from a Corrupted Registry"
    (How to recover from a corrupted registry that prevents Windows XP from starting).
    I know, I know but, even though you have 7...

    Last but, not least, Microsoft Fix it Solution Center: troubleshooting software issues

    I really could not find a whole lot on this. From experience, I'll suggest, running the OS disc Repair doesn't always fix reg issues. You may, indeed, end up having no choice but, to rebuild/re-install to fix this. Some of my research into the problem said this, as well.

    Maybe, hopefully something of this will help. Hope you'll let me know if it did or not.

    Regards,
    Drew
     
    #2 Drew, Jan 26, 2012
    Last edited: Jan 26, 2012
  3. tamn

    tamn New Member

    Joined:
    Jan 26, 2012
    Messages:
    6
    Likes Received:
    0
    Hey drew, thanks for replying. I believe I used the sfc /scannow trick before to repair what was wrong last year when something happened previously. I have run it several times now and it hasn't changed anything. I have done several memory diagnostics of varying kinds and they all say its working fine.
    *headscratch*

    I tried sticking in my Deriks nuke disk to restart, and it just ends up hanging on a black screen. 0.o

    Tried many things in my BIOS trying to get any of my repair disks to work...to no avail. I think I might put one of my other cd readers in and see if it works with that.

    Very weird problem haha
     
    #3 tamn, Jan 26, 2012
    Last edited: Jan 26, 2012
  4. Drew

    Drew Banned

    Joined:
    Mar 25, 2006
    Messages:
    3,575
    Likes Received:
    146
    I considered a bad ROM but, reckoned you had likely eliminated that, already. Does it read other discs? But, IF, that turns out to be an issue, I still have little faith in Repair. Usually, in cases like this, the route necessary is a clean install .... sorry to say but...

    Oh & don't try 3rd party so-called reg fix or repair crap.

    Cheers,
    Drew


     
    #4 Drew, Jan 26, 2012
    Last edited: Jan 26, 2012
  5. tamn

    tamn New Member

    Joined:
    Jan 26, 2012
    Messages:
    6
    Likes Received:
    0
    well, the rom reads and writes perfectly fine after the OS loads, so I never thought it could be a problem with that, I swampped roms to another pc and tried it. same result. :( I think I'm going to try and wipe the drive using a usb, and see if that works.
     
  6. helpifIcan

    helpifIcan Extraordinary Member

    Joined:
    Jun 20, 2009
    Messages:
    768
    Likes Received:
    23
  7. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    As Drew mentioned, if you are not getting the Hit a key to boot, are you using a monitor that searches for an input during boot? Do any of your other F keys work, like F8?

    BcdBoot can be run from an administrative command prompt.

    Prior to running that, you might just type BCDedit and let it print what you BCD store shows. You will probably have to extend the command window to see it all. Copy and paste or use snipping tool to take a picture and attach, if you want.

    I do not know what is meant by the corrupt configuration, but I will investigate. For now I would just think it was a device or driver problem. I don't suppose anything shows up in the Device Manager?
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    It appears the error message is referring to the registry hive files kept in the C:\Windows\system32\config folder. This is what your system reads when it boots to write the virtual registry. There is always a backup in the RegBack folder.

    The problem might be now that because the backup files are saved every 12 hours, the backups are corrupt as are the current, so you would not be able to replace them from the backup, since it has been a while since the error occurred.

    I suppose if you knew what was wrong you could correct your registry and fix the problem that way, but this seems highly unlikely. If you could find any other information from the Event Viewer or other source, it might be helpful.

    So, the Startup Repair or other recovery options can be tried and hopefully work. But if they do not, you may need to do a Repair Install, which you run from inside Windows.

    I will keep looking for another fix, but I am not hopeful if the other methods do not work.
     

Share This Page

Loading...