Confusing BSODs

#1
This problem has plagued my windows 7 installation for a very long time.... i wrote a post on these (and many other forums) before giving up on the issue a few months back and switching to a linux operating system. That's fine, i would keep using linux but i am receiving a new graphics card as a gift and i would like to try to play some pc games on my new card, and as you all know serious gaming on linux is pretty tough/near impossible.

HERE is the link to the post i made a few months back about the same problem. I'll quote it here since it's relevant:

All right so i'm usually pretty good at figuring out any problems with my pc but this ones out of my league, plus i think theres a wide range of things that it could be.

I have a somewhat old hp media center 7580n (pos, bout 3 years old) upgraded it to windows 7.

This problem appeared when i started using this computer to play video games again (only game is WoW though), but at the same time I set up winamp to play my music out of my speakers so that i could use my usb headset for speaking over ventrilo (makes sense). I started getting BSOD's with what seems to be random error messages. These messages go from "IRQL_MORE_OR_LESS_NOT_EQUAL" and "MEMORY_MANAGEMENT" to "BAD_POOL_HEADER" and many more (sometimes there isn't even an error message). These bluescreens almost always happen (i say almost always because it has happened at other times) when i'm running WoW, it seems as if there's a higher chance of it happening if I'm alt-tabbing out of full screen, but I just had it happen when i was running windows mode in a really small window (less strain on the GPU).

My first guess was that it was driver related, so I went ahead and booted into safe mode, and started reinstalling/updating as many drivers as I could think of (of course the first i did was my piece of **** nvidia card driver), but that apparently has had no effect.

My next guess was that it was my RAM sticks, i move around my desktop a decent bit (didn't move it anytime around the time this problem started though) so i thought that maybe my ram sockets had warped a bit or something from all the travel. And maybe a faulty address in memory or something could explain this, so i ran memtest and it came back with no errors. So i switched the RAM sockets of my ram sticks (there's 4 sockets so i took the 2 sticks and put them in the other sockets) all had no effect. I also tried to alternate the sticks (as in run with 1 stick only) but i only ran like that for a day (had no errors) but I got fed up with running on a gig of ram and put the other one back in.

And my last guess was that something was overheating. So i downloaded CPUID hardware monitor and started paying attention to the temperatures of various components. My CPU was up to 70 -75 degrees celsius, and my GPU was up to about the same numbers during times of high stress (aka playing wow on lowest settings possible hell yeah nvidia 7300 le). The CPU temps seemed rather high so I opened it up and took an old toothbrush to the fan and the heatsink underneath it and got it what seemed like my problem. The dust in there was pretty much compacted into a fat solid layer of **** knows what. I got out all that i could, and went ahead and dusted the rest of my computer including my nvidia card (which didn't have that much dust on it). I was almost sure that was the problem. Started running again and i noticed my CPU core temperatures went from 70-75 down to 30-40 ish, and my GPU went down about an average of 10-5 degrees celsius. But apparently that's not it, since i'm still getting bluescreens. I never bothered putting the full case back on the comp i just run it case open to keep it cooler.

So now i give up and come here. I can include some of my dump files (I have about 10 or so in the folder). I have no idea how to analyze those so i didn't even try. Does anyone have ANY idea? I'm starting to get extremely frustrated. Here are my specs, i haven't bought anything new this is all stock:

CPU: AMD Athlon 64 X2 4400+
Motherboard: ASUS A8M2N-LA (HP Name- Nodus-GL8E)
Socket AM2: Micro ATX GeForce 6150 LE
RAM: 2 GB Hynix PC2-4200 (2 X 1 GB)
Storage: Seagate 320 GB 7200RPM Serial ATA
Graphics: Asus Geforce 7300LE 128 MB PCIe
Audio: Realtek ALC 888 High Definition 8 channel compatible
PSU: Bestec 300Watt Single fan
Networking: Wired 10/100 Base T

And yes, i have tried looking at other problems similar to this one but i had no luck there.

Quick edit: Here is a screenie of BlueScreenView

http://img249.imageshack.us/img249/4347/bsodreports.jpg
I have now reinstalled a nice fresh installation of windows. 100% clean. I have set up some of my applications. just a few minutes ago i got a bluescreen that seemed all too familiar. I was doing nothing intensive, in fact i was listening to music through winamp and writing on an index card when i look up and see a BSOD.

I think the fact that i had no problems running my linux os means that the problem CANNOT be hardware related (can someone confirm?). I think it MUST be a driver. I have only installed a single driver since i re-installed windows 7, the nvidia 258.96 driver for my terrible 7300 LE graphics card, which will soon be upgraded to a 9800 GTX, hence the need to use windows again.

This is an extremely frustating problem.... i have spent so many countless hours trying to resolve it only to find no solution. i would really like to try to game with this card a bit, but if i simply can't find a solution i'm probably going to try to downgrade to windows xp, and then if that doesn't solve it, switch back to ubuntu and try to play my games through wine.

Last time i posted on these forums i got 0 replies (as you can see) so i'd really really appreciate ANY advice or ideas. I plan on disabling the nvidia driver and switching back to the one that came with windows 7 and seeing if the problem is solved, but even if that solves my problem, it may ruin my gaming ambitions, right?

Thanks for reading.

I have attached the 1 dump i have (so far....).
 


Attachments

#3
huh, i didnt mention that adapter because i thought there was no way that it would be the cause (since i never used this adapter back before i switched os). The thing is, i just installed the driver from the ZyXEL website, the usb adapter did not work as plug and play so i went to the website downloaded the driver and installed it then it worked, i think i was using the latest driver, i'll reinstall it though and see what happens. Thanks, i'm still confused though.
 


#4
100% sure it was the cause.

The driver in use at the time of the crash is the one shown. Update it again, but use the device manager to install.

Which exact model of wireless usb adapter do you have, out of curiosity?
 


#5
I just did that, if i get anther BSOD i'll post here.

I have a ZyXEL USB Wireless Adapter model number: G-220 V2 (ZyXEL Download Library)

When i went to the driver download section it was under 'legacy' since it must be rather old.

i didnt even consider that this BSOD could be unrelated to the plague I had a couple months ago.

either way thank you for the help!
 


#6
Not done yet, heh heh.

That driver is simply too old to use with Windows 7. So you'll have to purchase something new to use so the bsod do not continue.

I may be able to locate a newer driver or make you a new one. I need a little information, first.

In device manager, right click the device. Properties. Details tab. Change dropdown to hardware ids. Copy/paste the results to here.
 


#7
USB\VID_0586&PID_340F&REV_4810
USB\VID_0586&PID_340F

I can probably just switch to wired ethernet (and i probably will when i get back to my university) if there is no suitable driver for this adapter.

thank you very much for the help!

also just in case it matters, i'm french and so is my computer so i'm not 100% sure if what i just pasted is language independent, i assume it is but just in case.
 


#8
Here ya go. This should be alright.

You can only use Internet Explorer for this link:

Microsoft Update Catalog

Download and extract this one to a folder on your pc (don't worry about it saying Vista):

"Windows Vista Drivers (Other Hardware) 7/29/2008 2.2.0.27 1.0 MB 1044928"

Use device manager to install. Right click on it. Update driver software. Browse my computer. Let me pick. Have disk. Browse. Now navigate to the folder you extracted to and find the .inf file. Double click it. Hit ok. Then hit next. It will install and things will be good.

You're welcome.
 


#9
Wow yep, thank you once again.

i did all that and i have installed the new driver. thank you very much you were extremely helpful :)
 


#10
oops spoke too soon!

i got another bluescreen, and it mentioned the new driver that i just installed. so i just went ahead and plugged in my ethernet cable and took out the wireless adapter. that should completely solve it, but just in case you're still interested i've uploaded it.
 


Attachments

#11
Yep. Seems Windows 7 really just doesn't like the versions of the drivers available.

Right. There will be no further crashes of that driver with the adapter removed.

At least you know the cause though. :)
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.