Connected to router, but not Internet ("Connection...is broken")

Discussion in 'Windows 7 Networking' started by oldandslow, Aug 29, 2012.

  1. oldandslow

    oldandslow New Member

    Joined:
    Aug 28, 2012
    Messages:
    4
    Likes Received:
    0
    UPDATE! RESOLVED BY UNINSTALLING "Update for MS Windows KB2732500"

    Hardware setup:

    • Dell Studio 1558 laptop, Windows 7 Home Premium, Service Pack 1, 64-bit O/S, Intel Core i3
    • Linksys E1200 wireless router
    • Comcast cable modem (by Motorola)




    After functioning on my home WLAN for over a year, my Dell Studio laptop suddenly refused to connect to the internet:

    • Via the WLAN
    • Via an ethernet cable connected to a wired port on the Linksys router
    • Via an ethernet cable connected directly to the Comcast cable modem


    Initially the error displayed by "Troubleshoot problems" was: "DNS server not responding".


    Now, after all my troubleshooting efforts, the displayed error is: "The connection between your access point, router, or cable modem and the Internet is broken"


    All the following devices function normally on the WLAN:

    • Dell Latitude laptop, Win XP SP3
    • Toshiba Satellite, Win Vista Home Premium SP2
    • iPhone 4 (two of them)
    • iPad 2


    Other than installing Windows updates a few days before, I had not made any changes to this laptop or to my WLAN (at least none that I can think of)


    I have done the following in an attempt to troubleshoot:

    • Searched this forum (tried most of the suggestions in the "DNS server not responding?" thread)
    • Rebooted the PC, modem, and router (multiple times, in different sequences)
    • Updated to the latest drivers for the DW1501 Wirelss-N WLAN Half-Mini Card to 5.60.48.35
    • Updated to the latest drivers for the Realtek PCIe GBE Familyh Controller to 7.61.612.2012
    • Used "Device Manager" to uninstall both of the above, then re-added using "Scan for hardware changes"
    • Tried to connect on a public AT&T WiFi network
    • Installed a USB WiFi adapter
    • Turned on SSID broadcast
    • Turned off MAC filtering
    • Turned off the McAfee firewall
    • Ran "Troubleshoot problems" after most of the above changes
    • Rebooted after most of the above changes
    • Confirmed that "Internet Protocol Version 4 (TCP/IPv4) Properties" was set to:
    • - Obtain an IP address automatically
    • - Obtain DNS server address automatically
    • Tried manually setting the DNS server to 192.168.1.1


    I have NOT yet attempted to reinstall Windows or "restore to an earlier point in time" (not sure how to :( One of the threads suggests this worked, but I'll admit to being nervous about trying it!!


    An suggestions for other troubleshooting would be greatly appreciated! Thanks in advance.
    Rob
     
    #1 oldandslow, Aug 29, 2012
    Last edited: Aug 29, 2012

Share This Page

Loading...