Connected to two networks when Windows 7 is booted

#1
Hi there,

I seem to have a bit of a problem with my network at home.
Usually I'm capable of fixing these problems myself since I have worked with PC's for almost twenty years now, but I'm a bit stuck on this one.

Whenever I boot Windows 7, the internet icon at the task bar has the yellow triangle thing. When I go to my network adapters, it seems my Local Area Connection is connected to two networks somehow: it says "Bananas, unknown network" (Bananas is my own network)

So, Internet doesn't work at first, because of the two networks, but after I disable and re-enable the Local Area Connection, the problem seems to be fixed (After the re-enable it's only connected to "Bananas")

Does anyone know why PC is doing this? I know I can fix it within a few seconds, but it gets kind of annoying to have to repeat these steps every time I boot my PC.

(I do have another LAN connection, but it does the same thing on that one)

Using Windows 7 32bit
CPU Athlon FX-74
GPU: Ati HD4870
Mobo: L1N64-SLI WS

Hope you can help :)
 


zigzag3143

Honorable Member
Microsoft MVP
#2
Hi


I am assuming that you have it auto connect to bananas, and not to connect to the "other"?

Let us know


Ken J
 


#3
I'm sure I understand you.
My PC is connected to the network through an UTP Cable
Do LAN connections have the option to "Auto connect"? (I do know Wifi has this, but never heard of it for LAN)

If so, where can I find these settings?
 


Trouble

Noob Whisperer
#4
Flapperbol:
Hello and welcome to the forums.
I know recently we've seen some issues with gig cards and the autonegotiation feature causing some similar issues. I assume that since the board has two gig cards integrated that you are using one of them. The issue could be a driver issue with the card or possibly a firmware issue with the router but since everything seems to work fine after you jump through a couple hoops, just as a test try this;
Type ncpa.cpl into the search box and hit enter
select then right click the card you are using and choose properties
near the top of the properties dialog box click the button that says configure
in the resultant dialog box, in the left frame/column look for something called Speed & Duplex and select it
In the right column labeled "Value:" use the drop down arrow and select 100 half
OK your way back out of there and reboot.
See if the problem persists after applying this work around.
 


#5
@Trouble:
I did what you said, but after the reboot it was only connected to "Uknown Network" (and network/internet wasn't working)
 


Trouble

Noob Whisperer
#6
Whoa, kinda scary I suppose, but did you take some time and try to debug the unknown network issue. Run the network troubleshooter, ipconfig /all see what or if you were receiving ip information from the router, static assignment of ip values, etc.
Maybe as I noted earlier an issue with the router what's the mfg. model name, number and rev. number, is there a firmware update that might help you. Or a possible driver for the network interface card, if they worked out of the box then perhaps there is a driver offering either from ASUS or from the manufacturer that may be a bit more robust than what you are currently using.
Are you currently attempting to use both interfaces simultaneously, I suppose there could possibly be a multi-homed issue, maybe try disabling one and concentrate the efforts on a single adapter at a time.
 


#7
Okay, this is kinda weird. But I didn't actually change anything but the problem seems to have fixed itself yesterday...
Glad that it's over now, but also annoying that I have no idea what caused it
 


Trouble

Noob Whisperer
#8
Auto broke, auto fixed, automagic. You've gotta love it. Oh, well at least I'm glad that it's no longer your problem. If it happens again, please let us know and we'll take another crack at it. Thanks for the follow-up and letting us know that your issue is at least for now resolved. Hope to continue to see you around the forums.
 


#9
Well, it seemed to happen again yesterday. I reset my router and it connected to the `Unknown network´ again.
Solved it by giving my PC a static IP. (Still no idea where the unknown network came from)

It seems that I also gave my PC a static IP last time, but it seems I've forgotten to tell that part :p
 


#10
Hello,

First let me say, i know this problem well, it has plagues my win7 64bit machine for ages.
The quick workaround solution, is to disable and enable the network card, but i find it very anoying to add that to my boot up routine
Luckily, i found a solution:
open msconfig, go to services, remove the microsoft services from view, and close the rest. U can be selective on this, but i noticed i had an apple id xxxx service which i never asked for, and some others i could easily set on a stopped state. This solved my problem.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top