connection to internet exists but unable to use internet

Discussion in 'Windows 7 Networking' started by shidaw, Dec 25, 2009.

  1. shidaw

    shidaw New Member

    Joined:
    Dec 25, 2009
    Messages:
    4
    Likes Received:
    0
    Hi all,
    I recently upgraded to Windows 7 Ultimate from Vista Home Premium about a week ago. Starting yesterday 12/24 around 3:00 pm, my internet started to show "internet access" but constantly has the yellow caution sign. I have searched through at least 20 posts and threads about similar issues, ran troubleshooting, uninstalled all anti-viruses, disabled firewalls, restarted router, EVERYTHING...you name it. This is really becoming a huge problem and I would really appreciate it if ANYBODY could help me out.

    P.S. I use both a wireless and wired connection (BOTH do not work). Whenever I disable then re-enable my internet connections, they stay connected for about 5 seconds then stop working completely. The only actual lead I have is that troubleshooting reports give me the message that "Windows can't communicate with the device of resource (primary DNS server).

    I know that it is Christmas and I really would appreciate some much-needed help. THANKS!!
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Open command prompt type ipconfig /all what is it showing for DNS. If's it's pointing at your router, the router may be having problems forwarding. Try going into the properties of your Network Adapter and then the properties of IPv4, near the bottom add 8.8.8.8 and 8.8.4.4 manually and see if that helps. See attachment. Let us know
     
    #2 Trouble, Dec 25, 2009
    Last edited: Dec 25, 2009
    shidaw and (deleted member) like this.
  3. shidaw

    shidaw New Member

    Joined:
    Dec 25, 2009
    Messages:
    4
    Likes Received:
    0
    Wow!! Thank you SOOOOO much!!! I've been going crazy over this internet thing for the past day and a half. Thank you so very much. Happy Holidays (Merry Christmas if you celebrate it!!!!)

    P.S. What did adding 8.8.8.8 and 8.8.4.4 do for my internet? Is it a permanent fix? Thanks
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    You're welcome, glad we could help. Yes it's permanent however you may want to use the DNS servers from you own ISP. Those are Google's public DNS servers and they work fine for me. Some older routers have some trouble forwarding DNS queries and when you through IPv6 into the mix it can compound the issue. Anyway thanks for the Merry Christmas and yes I do celebrate, having been for two whole days now
    Regards
    Randy
     
  5. Megfault

    Megfault New Member

    Joined:
    Jan 9, 2010
    Messages:
    10
    Likes Received:
    0
    Hi, sorry to reopen the thread but I'm having a similar problem. However, after setting the DNS servers, the connection lasts a few minutes (sometimes a few seconds) and when I check the IPv4 settings again, the DNS entries are gone. Any ideas on how to prevent this from happening?
     
  6. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Megfault:
    Sorry to here, that the fix mentioned above didn't work for you. Your issue may be similar, but in reality or course, apparently different. You have no information regarding your systems specs, so please edit your profile and provide as much information as possible regarding your environment. Also in your next post, provide us with some additional information about how exactly you're connecting to the internet. I haven't seen static information being over ridden before except in domain environments where group policy objects will often take precedent over user assigned setting. So if that's your environment we need to know that. Typically in a home or home office type setup you will have the computer, attached to a switch port on a router and the router connected to your ISPs provided device. This is the type of information we need in order to provide any useful information
     
  7. reghakr

    reghakr Excellent Member

    Joined:
    Jan 26, 2009
    Messages:
    14,220
    Likes Received:
    180
    Try this,Go to Start >Run, type cmd, Now type ping Google.com.

    My average is 45ms. What's yours?

    Now type "64.233.169.104" without the quotations. Does the page load faster.

    Then type ipconfig /flushdns

    You could also type ipconfig /release, then type ipconfig /renew

    Shutdown and restart your machine.
     
  8. Megfault

    Megfault New Member

    Joined:
    Jan 9, 2010
    Messages:
    10
    Likes Received:
    0
    Hi, sorry for not having posted the system specs before. I've been accessing the internet at the local library and at the university and didn't have the laptop with me when I posted.

    You can now check the specs on my profile page. I've added all I knew. If you need to know something more specific, please tell me how to find out that info.

    The only connection that's giving me trouble is the mobile connection. The modem is a USB stick from HUAWEI, but I don't know its model name. I've searched on the carrier's website and can't find it anywhere. The box where it came also doesn't help. It's known as 'O2 Surfstick 3', but that's not the model.

    I've been using this connection since October without experiencing any problems. 3 days ago it started hanging a few minutes after the connection is established. Restarting the connection would help, but after a few tries the minutes turned to seconds, or it doesn't work at all. The connection is active all the time, but I can't access anything with it. I also get that yellow caution sign that Shidaw complained about. When running the troubleshooter, either it reports something wrong with the DNS servers, or it reports no problems at all.

    I tried adding the Google DNS servers manually (8.8.8.8 and 8.8.4.4) since it seemed to have problems w/ name resolution and the first few times all went well. Later I got exactly the same problem as before, and whenever I looked at the IPv4 settings, the DNS info was gone. I repeated the process several times, and the addresses would always vanish after a while. I seemed to be able to access websites while the info was there, but I am not sure.

    What worries me now is that about an hour ago I tried to connect with this USB stick and it worked. Actually that's the connection I'm using right now, without any DNS info set by me. When it comes to computers, nothing frightens me more than an intermittent failure :(

    I'm sorry, reghakr, but I cannot try your method now, since the connection seems to be alright. Unfortunately I forgot to ping an address instead of a name when I experienced problems. If it happens again, I'll try it and post the results.

    Do you think the application for the modem provided by my carrier is resetting the DNS address fields? If so, why just now? And why did it first take dozens of minutes to do so, and later just a few seconds, or none at all?

    Thanks for your replies! :)
     
  9. Megfault

    Megfault New Member

    Joined:
    Jan 9, 2010
    Messages:
    10
    Likes Received:
    0
    I forgot to add the following:

    After restarting the connection wouldn't make it work at all, I uninstalled the carrier software and plugged the USB stick. The autorun installed it again and the connection would work once more for a few minutes. After repeating this several more times, the result was the same as before: the download speed was always 0kbps although the connection was established and I was trying to open several pages on the browser.
     
  10. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I'm sorry, I think I understand now. Basically we're talking about problems with what would appear to be a cellular broadbands carrier's device. I think you can pretty much forget about setting anything static with one of those, because basically it regenerates the connection properties using their setting each time you use it. With one of those devices, reliability of your connections is basicly like that of a cell phone, signal strength is everything. Have you tried asking the carrier questions about the issues you've been having recently? It may take something like them resetting the device with some new firmware package or something from their end.
     
  11. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    Try and check to see if they have a newer model for your USB stick from HUAWEI . My wife was having the same problems and called and they told her to bring her Huawei back and gave her the latest model. Since then she has had no problems.
     
    Trouble and (deleted member) like this.
  12. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Good info Sonny, and thanks. I hope Megfault, sees your post and uses that solution. Thanks for posting
     
  13. Sonny

    Sonny Fantastic Member

    Joined:
    Nov 17, 2009
    Messages:
    1,258
    Likes Received:
    93
    Thank you Trouble, I don't know much but just hope that I can be of use to someone through my own experiences. You guys have been a life saver for me. Don't have IT knowledge but I am able to understand pretty much what you all are saying.
     
  14. Megfault

    Megfault New Member

    Joined:
    Jan 9, 2010
    Messages:
    10
    Likes Received:
    0
    I used the 'surfstick' a while ago on a friend's laptop and it worked fine. I connected it now to my laptop and got the following error message: "The DNS server isn't responding. Your computer is trying to use a DNS server that is incorrect or doesn't exist." After closing the troubleshooter, it started working.

    The problem can't be signal strength, because the coverage is pretty good here. I wanted to make sure that this isn't caused by the operating system or any other thing on this computer, otherwise the guys at the O2 store may say it has nothing to do with them. It worries me that my laptop is the only one with problems.

    Oh well, I think I'm going to the store tomorrow. Thanks for the feedback!
     
  15. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    To eleminate the computer and or the OS as a possible cause of your problem would require several additional diagnostic steps and I'm not sure what your options may or may not be, but if you can
    1. Test the laptop with a wired connection and or
    2. Test the laptop using it's integrated wireless device
    Perhaps you could narrow the issue down some. If those devices work without issue, then I would suspect your USB stick may need upgrading. Also I noticed in your system specs that you're still running RC 7100, don't know if that would be a factor or not. Just spent several minutes browsing some forums and it seems that there are a lot of unhappy users of that device in Germany.
     
  16. Megfault

    Megfault New Member

    Joined:
    Jan 9, 2010
    Messages:
    10
    Likes Received:
    0
    Thanks for the advice, Sonny. I hope I get a new one, too, but that's highly unlikely, since I got mine for 1€ in a special campaign. Now I know why it was so cheap... :(

    Trouble:
    1. I have no way to test that, sorry
    2. Works fine, that's how I've been accessing the internet at the university and at the library.
     
  17. tekke

    tekke New Member

    Joined:
    Jan 13, 2010
    Messages:
    2
    Likes Received:
    0
    Dear All,

    You have helped others and I hope you can help me as well. I am having a very similar problem to the first poster. I keep getting intermittent internet access. I am using a Belkin d2720a, and the Sony Vaio in my profile. I tried the original fix putting 8888 and 8844 in the wireless connections properties version 4 TCP iv4, but it has not solved my problem. This may be normal but I will mention it anyway. I set the Belkin up using the software which came with it. When I open the network and sharing center and click on change adapter settings there are two Wireless connections one named Home (the one I set up) which uses the Atheros AR9285. There is also a Wireless Network Connection 2 Using Microsoft Virtual WiFi miniport adapter. It says it is not connected, but it seems to be playing some role in my problem. Thanks so much for any help.

    Matt
     
  18. kaareen

    kaareen New Member

    Joined:
    Mar 25, 2010
    Messages:
    4
    Likes Received:
    0
    hi i just upgraded to windows 7 ultimate and my internet is not working anymore...i'm connected thru a modem (the wireless works fine) when i run the troubleshoot it says "windows can't connet to device or server (primary DNS)" i'm not an expert at this so can anyone help me PLEASE!... :(

    i dont know if my problem is similar to the ones above but i tried it and it didnt work....
     
  19. xSliex

    xSliex New Member

    Joined:
    Mar 29, 2010
    Messages:
    2
    Likes Received:
    0
    Hey all,
    I did all that Shidaw had done: the virus scan, disabled the firewall, did cmd release and renew for the ip address, retart the computer, you name it! and my internet is still not working. I have wireless and Ethernet cable connection, and am sending and receiving bytes. I am just not able to access the internet at all. When I open Google chrome, it says there is no connection. Please help! I'm in college and need the wireless internet for homework! I am using an Ethernet cable right now and receiving internet, so that's working fine, it's just the wireless that's the problem. Also, I have been using windows 7 for almost 5 months and the wireless has been fine until yesterday. Thank you!
     

Share This Page

Loading...