Windows 7 Control panel in desktop toolbar

#1
I add desktop toolbar to my taskbar. and in this toollbar appear some shortcuts which I have not on my desktop ( Libraries,Control panel, homegroup and others) but the problem is that I have 2 control panels!!!!!!!!!!
Even if I delete one of them it appears again.
could anybody give some advice?
thanks in advance
 


cmn

New Member
#2
I add desktop toolbar to my taskbar. and in this toollbar appear some shortcuts which I have not on my desktop ( Libraries,Control panel, homegroup and others) but the problem is that I have 2 control panels!!!!!!!!!!
Even if I delete one of them it appears again.
could anybody give some advice?
thanks in advance
If your problems is having 2 Control panel icons appearing on your Windows 7 Desktop after you installed and configured the freeware called "Desktop Toolbar" and now you want one of the two Control Panel icons to go away leaving the other one on the Desktop (it seems like you prefer to keep the Control panel icon from "Desktop Toolbar" and jettison the Windows default Control Panel icon] :

  • Right -click on a blank spot on Windows Desktop
  • Click Personalize
  • Fom the Left Pane, click on Change desktop icons
  • From the Desktop icons check boxes , uncheck (untick)[ ] Control Panel
  • Click Apply >OK
I hope this is what you are looking for:)
Addendum:
It seems that is a Bug in Windows 7!

http://social.technet.microsoft.com.../thread/927de1ae-de3a-4d05-98a4-9077359b29a5/
 


Last edited:
#3
As you can see in attachment I don't have any of this shortcuts on my desktop - they appeared only on dasktop toolbar
:cool:
thanks for reply
 


cmn

New Member
#4
As you can see in attachment I don't have any of this shortcuts on my desktop - they appeared only on dasktop toolbar
:cool:
thanks for reply
Now I see ; a picture is worth a thousand words:)

You are now illustrating 2 Control panel icons on the Desktop's "TASKBAR" near the Notification area!
What you did not affirm or deny is whether this happened after the installation of the freeware "Desktop Toolbar" I've assumed you did before this happened.
If this happened after you installed the freeware application called "Desktop Toolbar",

Addendum:

It seems it is a Bug in Win 7 Beta: Please check this discussion: http://social.technet.microsoft.com.../thread/927de1ae-de3a-4d05-98a4-9077359b29a5/


that application must have created the duplicate entries of Control Panel on the Taskbar. If that is what has happened:
  • try to uninstall and then reinstall "Desktop Toolbar".
  • If the above does not solve the issue, you may have to do some serious Registry Editing.
  • Not sure if the freeware TweakVI can be used to avoid regedit
Am I any closer to what you are saying? :)
 


Last edited:
#5
I didn't install any additional aplications ( I mean "Desktop Toolbar")
I use windows procedure to show desktop in notification area
1. right click on taskbar
2. Toolbars
3. Desktop
:rolleyes:
 


cmn

New Member
#6
I didn't install any additional aplications ( I mean \"Desktop Toolbar\")
I use windows procedure to show desktop in notification area
1. right click on taskbar
2. Toolbars
3. Desktop
:rolleyes:
Crystal Clear now :)

For the problem I had linked this discussion on the Win Bug causing that and the Registry tweak suggested . The URL is : http://social.technet.microsoft.com/...-9077359b29a5/
 


#7
thanks alot
:D
 


cmn

New Member
#8
You are very welcome :). If the troubleshoot at the link about Deleting Control Panel from TaskBar by navigating through the folowing path works, please post back.

Please remember to make required changes in Folder Options >View to make these "hidden files and folders" to show up before starting the search and delete attempt.
Computer> Organize> Folder and Search options> View tab> Advanced settings : box

click to select O show hidden files, folders, and drives

uncheck []Hide.........
uncheck []Hide.........
uncheck []Hide.........

Apply >OK

Navigate through:-

C:\Users\<user name>\Appdata\roaming\Microsoft\Internet Explorer\Quick Launch\User Pinned\TaskBar. Remove the “Control Panelâ€Â￾ entry in it if it exists.
 


#9
thanks for advise. but in this directory there is no control panel shortcut
 


cmn

New Member
#10
thanks for advise. but in this directory there is no control panel shortcut
I am sorry I have reached the end of my knowledge about this Win 7 Beta and therfore I have to leave you at this cliff ! I know VISTA Registry and based on that the key dealing with Desktop and Taskbar for the user resides in :

HKEY_CURRENT _USER\Software\Microsoft\Windows\CurrentVersion\Policies\Explorer . I have not yet hacked Win 7 Beta Registry to know it enough to help you. Others in the Forum with much greater knowledge and expertice might be able to help you.
Since my System does not have that problem of duplicate Control Panel Icon , I can show my Registry key for you to compare , if that would help. See attached Reg Key image
 


#11
i'll try to do something tomorrow/
thanks alot
by the way
 


#12
So, I cleane my registry and made it like on your registry screenshot
Byt :frown: I still have 2 control panels
 


cmn

New Member
#13
So, I cleane my registry and made it like on your registry screenshot
Byt :frown: I still have 2 control panels
May be the entry for Takbar is in another key , try "adavanced . I will post mine later.


In the mean, I'm embarassed to ask this, as the answer is so very obvious , but let me ask it any way, at the time you tried deleting the CP icon in your previos troubleshoot, was your taskbar "locked"?
 


Last edited:
#14
The taskbar was locked and unlocked, it was autohided and alwais ontop.
:confused:
 


#15
same issue

Hey, I have been having exactly the same problem since the first beta. I just installed the rc and was hopeful that the issue would have been fixed, but iit's still happening.

Like the person who first posted, I didn't install any sort of desktop add-on or anything. Just right-clicked > add new toolbar > desktop. And then voila! Two Control Panel icons.

I'll try some of these suggestions when I get back home tonight.
 


cmn

New Member
#16
Hey, I have been having exactly the same problem since the first beta. I just installed the rc and was hopeful that the issue would have been fixed, but iit's still happening.

Like the person who first posted, I didn't install any sort of desktop add-on or anything. Just right-clicked > add new toolbar > desktop. And then voila! Two Control Panel icons.

I'll try some of these suggestions when I get back home tonight.
Did you install the RC on top of the existing Beta using Upgrade Install option although strictly speaking it is NOT an UPGRADE from an OLDER version of Windows like from Windows XP to VISTA or VISTA to Win 7 RC as the changes are only in some file updates/ Bug fixes between Builds. If you had taken Upgrade path, your new system could inherit the bad traits of old build.
 


Last edited:

reghakr

Essential Member
#17
I see from your thumbnail, you are in the HKEY_CURRENT_USER\Software\Microsoft\Windows\CurrentVersion\Explorer

Click the arrow next to that key to unexpand it and navigate to the policies key.

If it doesn't exist, you'll have to create it manually
The policies key does not always exist in the CURRENT_USER branch, but it alwaysexists in the HKEY_LOCAL_MACHINE branch
 


Last edited by a moderator:
#18
Yes, I know I wasn't supposed to, but I installed right over the beta. Don't yell at me - I know I'm an idiot. Later I'll be formatting the drive to do a full install and will respond with whatever happens.

Ok, so I have installed 7 on a clean, formatted drive. I haven't installed a single program or application yet. First, I right-click > Personalize > change desktop icons > check them all > save. Then, right-click taskbar > toolbars > desktop > BAM two control panels! I almost feel bad harping on this issue, because I really, really like Windows 7. If anyone has had any success kicking this bug, I would really appreciate it. Thank you all (including Microsoft for this spiffy new OS).
 


Last edited:
#19
I found a solution that worked for me, try it at your own risk though.
open regedit and go to
HKEY_LOCAL_MACHINE\SOFWARE\Microsoft\Windows\CurrentVersion\Explorer\Desktop\NameSpace\
In the NameSpace folder, there will be a folder (key) with the name {5399E694-6CE5-4D6C-8FCE-1D8870FDCBA0}
The value of the default item should be "ControlPanelStartupPage"
Delete the folder (key) from the registry and hit F5 or log off and then back on again. That should kill the second Control panel Icon. I haven't noticed any side effects (yet). ;)
 


#20
I had the sameproblem. What worked for me was to click the desktop-->personalize-->change desktop icons. Uncheck Control Panel then press Apply. Then re-check it and apply again.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top