Corrupt attachments

Discussion in 'Windows 7 Help and Support' started by pizzafoundry, Jun 7, 2011.

  1. pizzafoundry

    pizzafoundry New Member

    Joined:
    Jun 7, 2011
    Messages:
    6
    Likes Received:
    0
    Aboard a cargo ship: 2 Win7 machines, one at Captain, one at Chief Engineer. Systems both new HP boxes about 6 mo. old with Win7 Pro, Office 2007. Systems see each other on a wired net but Captain is the only one allowed to send email. Emails are sent via Inmarsat satellite radio connection, and served via marsatmail.com.

    Problem now is that no email can be sent with any binary attachment and have the attachment survive the trip; attaching PDFs, JPGs, any other non-text attachment always results in "invalid image" or "insufficient data for PDF" errors on the receiving end.

    Captain came down with this problem after 3-4 months of proper operation; subsequently, he swapped out his machine with Ch. Eng. machine which then once again allowed him proper operation sending email with attachments. However, after only a few weeks, this machine again reverted to the same failure, i.e. all binary attachments end up corrupted.

    I was called onboard to fix what owner perceived as a virus problem. However, after many hours of scanning with MWB, MSE, AVG, Combo Fix, in Safe Mode, clean boots, brand new user account, as well as installing Thunderbird to test with rather than Outlook, results are always same... all binary attachments are corrupt.

    They use a couple of flash drives to move files around aboard ship, however, scans on those drives produced no results of virus infections.

    In short, there was not ever a single indication of any virus being active; no suspicious popup screens, no unusual entries in any of the Runs, no virus scan hits *at all*. So, I left after many hours, thinking the problem must be elsewhere, perhaps at the server end. I advised owner to create a new mailbox account and then re-test but now we find that too produces the same result. Also, we're unable to find any other users at marsatmail.com with the same problem.

    The systems use a compression program, MVS Fly Carrier, to interface with the transmission system. I'm wondering now about this software being the culprit; unfortunately I didn't attempt uninstall/reinstall of it while aboard, as I was convinced the problem was elsewhere. I have submitted a request to that company as well.

    Truly flummoxing. Any clues?
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Truly don't have a good idea of what is going on and you don't mention which email client you are using but since you have Office 2k7 installed I'll assume you may be using Outlook so,....
    Check for add-ins, certain third party plug-ins from vendors like Norton/Symantec, Adobe, etc., have been known to cause issues with various office products including Outlook.
    Try launching Outlook in safemode (usually hold down control key when clicking on shortcut) see if that produces any different results.
    Finally if you have WinZip or 7zip installed try right clicking and choosing zip and email or compress and email and see if there is still an issue with files with .zip extensions just as a test.
    Ultimately since both systems worked fine until they didn't it sounds to me like an automatic update from Microsoft or from the software vendor or both has caused the problem. Does the software have any virtual device drivers associated with it that may have gotten updated and has produced a problem with Win7. If so you may have some luck rolling back to an earlier version.
     
  3. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Do they have the capability to send e-mails point to point onboard? You might be able to eliminate one possibility..

    Did Captain install anything or change any settings?

    What is the difference between the two machines in normal operation. Did you have to install the Sat utility to send the e-mail? Does the MVS Fly Carrier utility have a queue that might be cleaned out?

    Could it be something mechanical..what type of connection does it have to the transmission system?

    Edit: I suppose running a System File Check would not hurt if you did not do that. Did you see any errors or warnings in the Event Viewer?
     
    #3 Saltgrass, Jun 7, 2011
    Last edited: Jun 7, 2011
  4. pizzafoundry

    pizzafoundry New Member

    Joined:
    Jun 7, 2011
    Messages:
    6
    Likes Received:
    0
    MVS software replied:

    thanks for your message - we can help you to solve the problem with corrupted attachments sent using FlyCarrier. This problem can appear if regional settings on the PC where FC is installed is not EN USA/UK (for example, Greek or Bulgarian).
    To solve such incompatibility, we suggest to make one change in FlyCarrier ini file, located in the folder:
    C:/Program Files/Fly Carrier Client/FlyMail.ini :


    They include a picture of the screen but apparently this doesn't come through on this board.
    Basically you edit FlyMail.ini, find HD_Pack=True and set it to False. They say this fixes the corrupted attachment problem. I'm waiting to hear if that's true but it looks good to me so I'm posting it here to help future warriors.

    eno
     
  5. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Well that's excellent news and I certainly hope that the solution works for you, but it doesn't sound like that would explain why it worked for quite a while on both machines and then stopped working. Unless an upgrade / update to the .ini file reset the HD_Pack condition to true and it had been set to false previously, thus allowing it to work correctly.
    Still fingers crossed, good luck, and if you have any additional follow-up, like their fix actually worked, let us know.
    Regards
    Randy
     
  6. pizzafoundry

    pizzafoundry New Member

    Joined:
    Jun 7, 2011
    Messages:
    6
    Likes Received:
    0
    The reply came back today that in fact the HD_Pack edit solved the problem. I too was skeptical on how this could have worked "for a while" and then stopped but evidently that's how it went, essentially three times; on both the machines initially, and then again on Captain's machine after they fully reinstalled. It must have to do with some other parameter changing at some point and then effecting the failure.

    MVS Software did indicate that the failure is related to changing a Regional setting away from US/UK to 'anything else'... so perhaps they were not making that final change until quite a ways down the road... that's unknown to me but nonetheless it is fixed now.

    Thanks,

    eno
     

Share This Page

Loading...