Corrupt Registry

Discussion in 'Windows 7 Help and Support' started by Cornfused, Oct 6, 2012.

  1. Cornfused

    Cornfused New Member

    Joined:
    Oct 6, 2012
    Messages:
    4
    Likes Received:
    0
    Asus windows 7 x64

    So I got the corrupt registry (Yay me!:razz:) error and can't get into anything like normal, safe mode, etc. I can get into the command prompt. I can't run system restore as there are no restore points and startup repair doesn't fix it. I also replaced the the registry files in system32\config with the backups in regback, but to no avail. So here I am, hat in hand, in need of assistance. I have several questions.

    1-I have seen you mention a registry cleaner on your site in the FAQ I think it was. Can I put this on a thumb drive and run it to fix the registry?

    2-In the X: drive, there appears to be a system default version of the registry files SAM, SYSTEM, SECURITY, etc dated from 3 years ago. Can I put those in C: to fix the problem?

    3-I would rather not have to do a OS re-install. But if I must, I don't have a recovery CD. Instead, Asus put all the recovery info on a separate drive E:. Is there a way to do a system install by accessing the files on E: via the command prompt?

    I would be grateful for any other suggestions (if they work that is:tongue:)

    Edit: I forgot to mention that I can access the registry editor. Is there a way to tell which items are corrupt and possibly fix them from the editor?
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    The way you normally replace a bad registry is by using the "Last Known Good" option. It uses the backup registry files that were used the last time the system booted correctly, which are the ones to which you refer.

    If you knew exactly what was wrong, you can edit some of the hives from offline, but it appears that is really not an option.

    Running a Chkdsk is recommended to try to repair corrupt files.

    Is this the first indication that something might have been wrong with your system?

    How your system recovery works should be in your owner's manual. Different manufacturers use different procedures, but they are usually started by some type of key during boot or a bootable media.

    I seem to remember something about the Registry Corruption, that I can't recall right now. Maybe I will think of it later.
     
  3. Cornfused

    Cornfused New Member

    Joined:
    Oct 6, 2012
    Messages:
    4
    Likes Received:
    0
    Hey, thanks for the reply! I did finally get it fixed. I just wanted to add some info for future reference.

    As for the "Last Known Good" option, I tried that but it didn't work. From looking at the dates and times on some of the files in regback (which I assume it would pull the files from), they were written over by one of the many system repair boots.

    I tried src /scannow, but that wont work if you try it via the command line accessed via system repair as it tells you it is waiting for a system repair session to end.

    I also xcopy-ed the regback files from X: to c:\windows\system32\config. To make a long story short, don't do it!

    Finally, I booted from a repair disk and ran system repair a few times. One time it said it couldn't be fixed. Next time it said it fixed it. The last time it said there wasn't anything to fix, but I still couldn't get into windows. So I xcopy-ed all the files in \regback to the \config folder. (this is the command to run from command prompt: xcopy /y c:\windows\system32\config\regack c:\windows\system32\config) Note: the times on the regback files was the same as when I first looked at them mentioned earlier and roughly around when all the trouble started.

    I can't say for sure if the if the boot disc alone fixed it, but it's working now.

    As far as if this is the first problem I have had, the answer is no. Lately, I have had a fit with the hiberfil.sys file being corrupt and the computer not loading from hibernation. I suspect that it may be possible that when the system crashes trying to load from hibernation, some of the files may become corrupt. But I'm no expert.

    Thanks again.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    1 person likes this.

Share This Page

Loading...