Could not load file or assembly sorttbls.nlp or one of its dependencies.


New Member
I keep getting the above error message pop-up when I reboot the computer and also occasionally when in general use.

Any ideas :question:

I'm running Windows 7 64-bit Pro...


Noob Whisperer
Hello and welcome to the forum.
We will need to have some idea of what the "error message / pop-up" is actually saying.
If possible, use the built-in windows snipping tool to take a snapshot of the error and attach it to your next post.
Alternately perhaps you could type the content (text) as well as the information in the title bar of the error message into your next post.
Keep us posted


Essential Member
Premium Supporter
Open the Control panel (icon view) and select Programs and features
Select Net framework.
Select "Change" and the repair option.
If this is not sufficient, you may need to totally unistall net frame work. For this you sometimes need to run a specially designed Microsoft uninstaller.


Noob Whisperer
Recently found this tool which helped me overcome a Dot Net corruption issue which was preventing a proper install of the DotNet4 security update which seemed to be in an install loop and never successfully installed. Your specific issue seems to be linked to DotNetFrameWork2 but I can't say for sure. But if you would like to use it I have attached it here for your convenience. I used it myself and it worked for me. After I cleaned up DotNet4 and rebooted, I used Windows Update to reinstall DotNet4 and then the update installed properly after that with no further issue. I hope it helps you as well.

If you find that you do need to remove a particular version of the DotNet Framework (unable to repair it) then this link will help you obtain the version you need to reinstall.

Last edited:


New Member
Hi and thanks for the info.

This is the error message I get:

Erro message sortkey.PNG

I am having this exact same problem. I have repaired the .Net framework and run sfc /scannow with no luck. Would be interested in any insights.

hy...i have exactly the same problem...and i tried to solve it just like u described...but unfortunatley it didn't help...i tried all of those solutions but it's still there...dunno what to do anymore...i even tried to uninstall dotnet but when i open control panel and uninstall program it's not on the was kinda weird because it should be i looked in the program files drectory it was there but there werern't all files that should be there...i have quite exp with PC and i just dunno what to do...i tried literally everything...but nothing...i even tried to delete the dotnet directory and reinstall it but impossible...hope some of u know how to resolve it...

This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.