Could not perform this operation because default mail client .....

MajorDan

New Member
Updated 2-1-09

Here is the situation:

I go to a website that has contact information. I click on the "e-mail me name" and instead of there e-mail address poping up I get the following error message: Could not perform this operation because the default mail client is not properly installed."

I have installed both the MSN messanger and Mail programs. Here is the link to site I'm having trouble with. Any idea's?

Link Removed due to 404 Error

MajorDan
 


Last edited:

BlackWolf

New Member
eeeh ... that's simply because windows 7 does not come with a mail client. you have to install windows live mail from the windows live essentials, that's it (or any other mail client, for that matter).

a mailto:-link will always launch your default mail client. by default, windows 7 does not have ANY mailclient and therefore no default mail client.
it has nothing to do with the websites "software" (whatever that's supposed to mean) ;-)
 


MajorDan

New Member
Hi BlackWolf,

I updated my orginal post to include information that should have been there in the first place. I do have the mail client installed so I'm still searching for a solution to this error message. Take care.
 


BlackWolf

New Member
works fine for me with windows live mail installed. are you sure you defined it as your default mail client?
I have the german version of windows, so the following is just roughly translated, but I hope you'll get what I mean. go to:
control panel -> programs -> default programs -> Assign file extension or protocol to program -> scroll down all the way -> look for "MAILTO" -> make sure it is set to "windows live mail"

I guess these translations are pretty wrong, but I hope you'll find it :D
 


FooSchnickens

New Member
I'm having the same sort of issue with Thunderbird. It's odd because I can go to set up the file/protocol association and it shows mailto to be linked with Thunderbird, and it also shows up when I look at the program access and defaults section. BUT if I go to EDIT the association via the method as listed by blackwolf it doesn't show up in the list at all and I am unable to add it from that dialog.

Any thoughts? I'm running 32bit and have tried uninstalling and reinstalling thunderbird bulitple times to solve the issue.
 


jauburn

New Member
Hi BlackWolf,

I updated my orginal post to include information that should have been there in the first place. I do have the mail client installed so I'm still searching for a solution to this error message. Take care.
I'm having the same problem and I have Outlook 2003 installed. Should work.

I see no mailto entry in the usual place in the registry.
 


jauburn

New Member
works fine for me with windows live mail installed. are you sure you defined it as your default mail client?
I have the german version of windows, so the following is just roughly translated, but I hope you'll get what I mean. go to:
control panel -> programs -> default programs -> Assign file extension or protocol to program -> scroll down all the way -> look for "MAILTO" -> make sure it is set to "windows live mail"

I guess these translations are pretty wrong, but I hope you'll find it :D
Having the same problem, and in this section for me there is not MAILTO entry. See attached.
 


FooSchnickens

New Member
Fixed my issue finally. Instead of going through the normal steps of assigning program permissions/associations I took a bit of a back door approach.

Go to Control Panel> Default Programs. Instead of clicking "Set Your Default Programs", click "Set Program Access and Computer Defaults." This will bring up a dialog box that works differently than the normal Win7 program defaults. Scroll down to the custom area and define the programs you wish to use for internet/e-mail/digital media.

As soon as I did that mailto links worked perfectly.
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top