ctrl key stuck

Discussion in 'Windows 7 Help and Support' started by danh63, Nov 14, 2010.

  1. danh63

    danh63 New Member

    Joined:
    Nov 14, 2010
    Messages:
    2
    Likes Received:
    0
    My computer thinks that I am holding the ctrl key. I did the updates and it still hasn't fixed. ALso did a complete restore and tried and brand new keyboard. Any ideas? Dell was no help at all and I have been searching and still can't seem to get it fixed
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Control Panel\All Control Panel Items\Ease of Access Center\Set up Sticky Keys, uncheck "Turn on Sticky Keys"
    Other suggestions;
    Make sure you have the most current drivers available for your keyboard and mouse.
    Make sure that you have no unusual mouse button assignments that would correspond to a key on your keyboard.
    Also include as much detail as possible about your PC and the hardware causing the issue. Manufacturer, model name, model number, etc. Often times members will have specific information based on experience with similar hardware.
    And welcome to the forums.
     
  3. zvit

    zvit Honorable Member

    Joined:
    Nov 3, 2009
    Messages:
    2,455
    Likes Received:
    84
    Do you have a keyboard macro program installed like Autohotkey?

    You say you changed the keyboard but just to be sure, try the keyboard on another computer. If the problem persists, it's the keyboard's problem.
     
    #3 zvit, Nov 20, 2010
    Last edited: Nov 20, 2010
  4. teekgeek212

    teekgeek212 New Member

    Joined:
    Nov 21, 2010
    Messages:
    28
    Likes Received:
    0
    Well try these two things:
    1. search the keybourds manfacters website for updates on driver for OS
    2. see if the keybourd works anything computer, if so
    3. Make sure, if you have ever aten by keybords. See if you take the key off to see if there is any food or something like that. If you don't want to do that, try a can of compressed air used for cleaning out fans and computer boxs. Even just sack it out.
    4. Contact custermer support from your keybord com.
     
  5. amov

    amov New Member

    Joined:
    Nov 25, 2011
    Messages:
    4
    Likes Received:
    0
    I have been having this issue for the last few months. I've talked to tech support, Costcos support service and a computer repair shop in Boise all to no avail. I started having the problem after getting some malware on my computer (XP) and taking it in to a shop to get it removed. When I got it back this cropped up -- their response was, not our problem. I thought if I installed Windows 7 it would take care of the issue -- no such luck. I did a complete deletion of the hard drive -- nothing was left.
    Anyway the problem was conflicting keyboard drivers. The computer originally had a PS/2 keyboard but the system installed 2 HID (USB) drivers. I bought a new wireless keyboard which installed another HID driver and this didn't solve the issue either. Finally I deleted the two generic HID drivers and the problem seems to be have been resolved. The keyboard was locking up after only 20 minutes or so before I deleted the drivers and it's been close to 12 hours now without a problem. Cross my fingers anyway.
     
  6. amov

    amov New Member

    Joined:
    Nov 25, 2011
    Messages:
    4
    Likes Received:
    0
    The solution I previously wrote only half fixed the problem, the drivers reloaded when I rebooted the computer. I could disable the ones for the mouse but not for the keyboard. I previously had a PS/2 keyboard and replaced it with a Logitech wireless keyboard hoping that would fix the problem when Windows 7 didn't.

    Anyway, I found a fix on How To Disable Automatic Driver Installation In Windows 7 / Vista. The fix involves editing the Group Policies to Prevent Automatic Device Installation. I'm including the steps below.

    The method below willl disable automatic driver installation.
    • Go to Start-->Run-->Type in gpedit.msc-->Enter
    • (They did a search for the file but I thought the Start-->Run option was easier)
    • In Computer Configuration-->Administrative Templates-->System-->Device Installation.
    • Click the subfolder Device Installation on the left and on the right pane you will see the possible options.
    • Right Click on Prevent Installation of Devices not described by other policy settings and Edit this option, set it to ENABLED.
    • Reboot and Windows will no longer be able to auto-load its standard drivers.
    If you are using a standard USB keyboard I don't think this will help but if you can spring for a third party keyboard or if the keyboard has it's own driver it should help. I think it will work with PS/2 keyboards as well although I haven't tried it there.
     

Share This Page

Loading...