custom RDP port?

#1
I tried to change the default remote desktop port from 3389 to some other 4 digit number.

I did this via regedit


  1. HKEY_LOCAL_MACHINE
  2. SYSTEM
  3. CurrentControlSet
  4. Control
  5. Terminal Server
  6. WinStations
  7. RDP-Tcp

I setup that port correctly as a port forwarder in my router. The original 3389 was working fine. However, the new 4 digit one is not strange enough (port forwarder is 'ok' according to one of those port forwarder checking sites). I tried to RDP from one network to my IP (confirmed correct) like this:

myipaddress:1234

1234 = being the actual port number I set up.

Of course, I do already have RDP enabled on both W7 laptops.

What could be the cause of the invalid connection? It was working fine on 3389 by for extra security measures, I changed it to something else.

I did restart the laptop as well.

I tried a handful of different port numbers, for some strange reason they all show as 'closed'

Using this tool to check:
Open Port Check Tool - Test Port Forwarding on Your Router

I have a D-Link DIR-655
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top