DCS Service cannot start

Discussion in 'Windows 7 Help and Support' started by Theunis, Apr 18, 2012.

  1. Theunis

    Theunis New Member

    Joined:
    Apr 18, 2012
    Messages:
    6
    Likes Received:
    0
    Hi, when I start Windows 7 on my Gigabyte Laptop (I1520M) I get a message just after the welcome screen that says: DCS Service can not start! The message is in a small window labelled: McaMaster.
    Can you tell me what is wrong?
    I have tried to find out what this DCS Service is but to no avail.
    Regards.
    TheunisView attachment DCS Service problem - Win 7.pdf
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    Do you show a DCS service or Mcamaster service in Task Manager, or the Services control panel? If you show such a service, you can right click and check the dependencies tab to see what might have to be running for it to run and check those services.

    Do you show anything installed at the following location:

    %PROGRAMFILES%\Configuration Center\bin\McaMaster.exe

    If you do, try right clicking some of the files to see if it says whose file it is?

    Doing a search for such a thing would be of greater value to you than someone that does not have your setup.
     
  3. Theunis

    Theunis New Member

    Joined:
    Apr 18, 2012
    Messages:
    6
    Likes Received:
    0
    Thanks, I found the files running in Task Manager and found the McaMaster but can still not figure out a way to fix it.
    Someone suggested that it might be a damaged DLL file that a repair kit of tool might be able to fix.
    Do you think the RegistryBooster promoted on this site might help?

    I am also starting to think that this might cause the sudden and ad hoc restarts I get while being online (when I am not online it does not happen at all),
    Windows7 just goes blank then the computer restarts.... weird.
     
    #3 Theunis, Apr 19, 2012
    Last edited: Apr 19, 2012
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    So you have decided the file is associated with a program you want to run?

    Do you know what program it is?

    You might check to see if there is an option to repair an application's install, and sometimes that might be in the Programs and Features Panel in the Control Panel. If it is a driver, you might be able to reinstall it to repair. The next step would be to uninstall the device and then let Windows find it again. You may see an option to remove all drivers for that device, which I would do just so some corrupt file will be removed and replaced.

    Did you check what the service depends on and if those services are running?

    Since this seems to be a third party application, possibly a video driver or some part of one, running a System file check may not help, but it would not hurt. Open an Administrative command prompt and type SFC /scannow and let us know if it shows any unrepairable files.

    An Administrative command prompt can be opened by using the Winkey then type CMD and hit CTRL+Shift+Enter
     
  5. Theunis

    Theunis New Member

    Joined:
    Apr 18, 2012
    Messages:
    6
    Likes Received:
    0
    Thanks for all the advice ... I have not been able to find out with which program it is associated - it seems to be a communication device of sorts, hence the ad hoc restarts when online, although it has not happened in the last three days again... weird.
    I will try the system file scan and report back.
    Its actually my wife's computer giving the hassles. When everything is working, all is well but when it restarts or gives error messages, my help is called in :)
    I use Ubuntu 11.10 myself and it is quite stable although I have had my fair share of issues to resolve.
     

Share This Page

Loading...