Windows 10 Definition Update for Windows Defender - KB2267602 (Definition 1.231.560.0) - Error 0x80070643


New Member
Oct 27, 2016
I've tried for a few days now and can't get rid of this in my updates. I'm doing a Fresh install on an HP 8000 Elite SFF and the programs i'm loading are Malwarebytes, VLC, Google Chrome, Libre Office, Adobe Reader, and Roxio. That's it.

I'm starting to go down these rabbit holes with no fixes in sight. Any help or ideas would greatly be appreciated. Going on my 3rd or 4th day now playing with this thing, the days are blurring together...
0x0643 is a generic "fatal error" message.
  • Open a powershell prompt and type Get-WindowsUpdateLog -LogPath "$($env:USERPROFILE)\Desktop\WindowsUpdate.txt"
  • Upload the log here for review
It can take a few minutes for it to finish, once it's back at the prompt the log should be ready on your desktop to upload.
Thanks for your help and quick response time, I really appreciate all the help and effort.

Sorry, here it is. in all it's glory.


  • WindowsUPdate.txt
    2.3 MB · Views: 946
Looks like your Windows log is mostly corrupt. Which leads me to believe you probably have other system corruption. I would try and run the following. You will need to open an elevated command prompt. Click the Start button, type cmd, right click "Command Prompt" and select "Run As Administrator"
  • sfc /scannow
  • dism /Online /Cleanup-Image /RestoreHealth
It's still doing it's thing but that's crazy. Before I even installed, I ran a Diagnostic/Geek Squad disc and everything passed, no hardware failed. Fresh install, i always do updates first and this happened to all 3 HPs, same models.

I really wonder what is the problem. It's at 65%
Error 87 on the DISM usually means that the command doesn't have sufficient permission to run. Are you sure you have an Elevated Administrator CMD windows open? If not, rerun and see if it completes or you get the same result.

If you get the same result, you could have a hardware failure (RAM stick(s) or Hard Drive) and you will need to do Hardware testing after backing up all your personal data to external media if you haven't done so already. Then you can apply more aggressive software solutions. Instructions for both the Hardware testing and the advanced Software Solutions are here in my Troubleshooting Guide link: Windows 10 - Unclickable Task Bar

This should solve the problem about 90% of the time.:up:

Best of luck,:encouragement:
87 can also means DISM doesn't understand the command. From reply #13 you typed Dism /onlinedism /online... this is an invalid command. The command syntax is DISM /Online /Cleanup-image /RestoreHealth feel free to copy the bold text and paste it into your command prompt.
Thanks Neemobeer, i'll retry that clerical error correction.

Since yesterday, i ran a killdisk and before the install, all hardware passed diagnostic.

Interestingly enough though. I was suspicious about the Windows 10 version i was using. I went back to an older install disc and guess what?
Problem solved, no more Windows defender error.

I will be trying the new commands here shortly and will repost the results. I'll re install one with the NEW Win10 and one with the Older Win10 and
see what happens, thanks team!
So it seems that the ERROR was on Microsofts end... been a few days and nothing happening. Everything is fine. Such a head ache though.
Top Bottom