desktop.ini on the desktop

Discussion in 'Windows 7 Tutorials' started by nkoss, May 8, 2010.

  1. nkoss

    nkoss New Member

    Joined:
    Nov 15, 2009
    Messages:
    30
    Likes Received:
    0
    When I see the icons on my desktop, I have 2 'desktop.ini' files. I see that one is from my main user and another from the 'public' user. Is there anyway to tell Win7 NOT to show the desktop.ini files at all on the actual desktop? I see that it is a 'hidden' file, but that doesn't seem to make any difference. Any ideas? Thanks
     
  2. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    If you have "show hidden files and folders and drives" checked in Control Panel>Folder Options>View Win 7 will display the desktop.ini files because these are normally hidden files.

    This behavior is "normal" for Win 7.
    In previous versions of Windows (at least Win 2000 and XP) setting this folder option resulted in all hidden folders and files in any explorer window to be visible.
    The .ini files are normally hidden system files.
    These files are basically instruction files to set the view and behavior of the folder they are in.
    The Windows desktop is in reality a special folder that is open in explorer.
    The actual location of this folder is C:\Users\<your user name>\Desktop.
    The .ini files you see on the Win 7 desktop if "show files and folders..." in Folder Options is selected are the same .ini files in the actual Desktop folder.

    In earlier versions of Windows (at least Win 2000 and XP for sure) setting the option to show hidden files did show the .ini files present in the Desktop folder but didn't show them on the Desktop.

    Win 7 either by design or a because of a bug shows all hidden files or folders when "show files or folders..." is selected even those on the desktop.

    The solution is to change the selection to "do not show hidden files or folders..." in Folder Options.

    I personally like all hidden files or folders visible on my machine so this behavior in Win 7 is annoying.

    My solution is to not show hidden files etc. unless a situation requires it.
    I would then temporarily change the Folder Option setting to allow these files etc. be visible.

    I prefer the older way (in XP and Win 2000).
     
  3. nkoss

    nkoss New Member

    Joined:
    Nov 15, 2009
    Messages:
    30
    Likes Received:
    0
    Thanks for clearing this up. I knew most of what you said in your very thorough explanation. I was hoping there was a way to just be able to turn them off in the visible desktop. Your explanation told me that this behavior is different from prior versions and that's what got me.

    Thanks again
     
  4. RAK

    RAK Extraordinary Member

    Joined:
    Jul 6, 2009
    Messages:
    2,502
    Likes Received:
    126
    It was recognised as a bug, nkoss, way back in the Vista days, For some reason,Microsoft have not responded. .ini files are being created and recreated continuously, but, unti Vista, were kept off the desktop.
    The only way, which is normal operation is, as Figold said, hide them. None of the resulting "hidden" files are user useful anyway.
    I do not recommend it, as I have heard it can sometimes have side effects, but I deleted mine (on the desktop) I now do it as a default action, on a reinstallation. I have not experienced any problems.
     
  5. Jarhead57

    Jarhead57 New Member
    Premium Supporter

    Joined:
    Jan 15, 2009
    Messages:
    134
    Likes Received:
    3
    I also have always deleted mine from the desktop and have never had it cause any problems.
     
  6. nkoss

    nkoss New Member

    Joined:
    Nov 15, 2009
    Messages:
    30
    Likes Received:
    0
    That's interesting. So you are saying that Win7 doesn't even need those 'ini' files?
     
  7. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    The only time I need to see the hidden files etc. is when I manually backup my Fat 32 storage partition and my NTFS program partition (this is where most of my programs actually reside and where my C:\User special folders like My documents, My Pictures etc. are).
    I've chosen to hide many of the things on my NTFS program partition.

    If I don't see the hidden files and folders they don't get backed up to my 1 TB external HDD.

    The rest of the time my hidden files etc. are hidden.
     
  8. Jarhead57

    Jarhead57 New Member
    Premium Supporter

    Joined:
    Jan 15, 2009
    Messages:
    134
    Likes Received:
    3
    Well, I can only speak for myself. I have never seen anything change. I did find this on a support site:


    The desktop.ini file is a hidden file used to customize and adjust settings for the Windows folders that contain the file.


    Can it be deleted?


    This file can be safely deleted from any directory. However, because this file may have settings associated with the folder that it contains and deleting this file will change these settings back to default. For example, if the folder containing this file has a different icon and you delete this file the default folder icon will be re-enabled.
     
  9. Joe S

    Joe S Excellent Member

    Joined:
    Jan 12, 2009
    Messages:
    3,785
    Likes Received:
    113
    I think you need to check hide protected operating system files to get rid of it not show hidden files. They are different.
    Joe
     
  10. Athlonite

    Athlonite New Member

    Joined:
    Mar 25, 2009
    Messages:
    792
    Likes Received:
    10
    meh i just delete mine aswell never had anything go poo and toes up because of it besides the desktop isn't a folder
     
  11. fjgold

    fjgold New Member

    Joined:
    Jan 11, 2009
    Messages:
    1,111
    Likes Received:
    60
    #11 fjgold, May 17, 2010
    Last edited: May 17, 2010
  12. Athlonite

    Athlonite New Member

    Joined:
    Mar 25, 2009
    Messages:
    792
    Likes Received:
    10
    perhaps i should have worded my post a wee bit better but still deleting the 2 desktop.ini files from off of my desktop has not caused any noticeably harmful side effects
     

Share This Page

Loading...