Device and Printers doesn't open (and other strange things)

Discussion in 'Windows 7 Help and Support' started by 4stringer711, Sep 5, 2012.

  1. 4stringer711

    4stringer711 New Member

    Joined:
    Sep 5, 2012
    Messages:
    4
    Likes Received:
    0
    I was recently changing a network printer but the PC seemed slow when adding a new printer. I removed the unused devices and restarted the computer. Now when I try to open devices and printers I just get the green bar at the top and nothing shows up.

    On a side note (I assume it is related) at the same time the printer issue showed up I noticed that I can't get Word to open at all and when I go to page layout in Excel, Excel locks up.

    I have tried a clean boot and everything behaves the same. I have tried using Fix it for printer problems and the program seems to get stuck when checking for spooler errors.

    I have also done a search and found the posts about restarting the Blutooth services. That didn't help either.

    I don't know where to go from here.
    Here is my system information:

    Windows 7 Home Premium
    Version: 6.1.7601 SP1 Build 7601
    HP Pavillion g6 Notebook
    64 bit system
    Bios: HP F.44 11/14/2001

    Thanks.
     
  2. Adamsappleone

    Adamsappleone U.S.Navy D.A.V.

    Joined:
    Aug 2, 2009
    Messages:
    1,662
    Likes Received:
    122
    Hello 4stringer711, [​IMG] to Windows 7 Forums,

    Have you tried doing a "System Restore" to a point before the issue?
    When changing hardware devices, such as printers, monitors etc:, completely remove the device first, including all related software and drivers to avoid any potential conflicts/issues when installing the new device.

    Hope this helps & keep us updated

    Don
     
  3. 4stringer711

    4stringer711 New Member

    Joined:
    Sep 5, 2012
    Messages:
    4
    Likes Received:
    0
    Thanks Don. I have never done a system restore. But here is where I am at now:
    Performed system restore to the most recent point (about a week ago)
    I opened Word with no issue
    I opened Devices and Printers with no issue. I tried to add a printer, received an error, but didn't write it down.
    I went back and tried to open Word again, but it didn't open.
    Restarted the computer.
    Tried to open Devices and Printers, but only got the green bar while it was searching.


    I undid the system restore and everything behaved like it did before my first post.


    I performed another system restore (to about a week ago)


    This time I went right to Devices and Printers. It opened and when I tried to add a printer I received error 0x000006ba about the local printer spooler service not running. After a couple of searches I followed the steps on print-spooler.org, including stopping the print spooler service (it showed it was started).


    After another restart, I opened Devices and Printers with no issue, but it showed no devices. I was surprised because I wasn't able to successfully remove the old printers before. When I tried to add a printer I received error0x000006be.


    Another search seemed to indicate there was an issue with the printer name or connectivity. I checked the printer and everything seemed to be OK.


    It seemed like everything would work as long as the print spooler service was stopped,but I couldn't add a priter. I took a lunch break and worked a post that summarized what I had done so far. I tried to open Word and nothing happened.


    I restarted again. Opened printers and devices. The old printer was still there. When I checked properties I received a pop-up that offered to run the printer troubleshooter.


    I had done this in the past, but the program couldn't get past checking for spooler errors.


    This time the troubleshooter suggested a fix to isolate the printer drivers. I applied the fix and everything seems to be working.


    I don't fully understand the problem or solution, but I guess I got everything straightened out. Thanks.






    On a side note when are some other times I should consider a system restore? I have never done that before.

    -David
     
  4. Adamsappleone

    Adamsappleone U.S.Navy D.A.V.

    Joined:
    Aug 2, 2009
    Messages:
    1,662
    Likes Received:
    122
    Hello David,

    Usually when software or a device is installed and it will either not work or wreak havoc on your system.
    System Restore has been used to rid malware infections, but in most cases it does not work. It's best to consult someone who knows malware issues and knows how to clean your system properly.

    Don
     

Share This Page

Loading...