Difficulty connecting to other PC's on network including host OS on this PC

Discussion in 'Windows 8 Networking' started by Medico, Sep 23, 2011.

  1. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65
    When I set up virtualization on my Win 7 Ultimate using Virtual Box in order to install the Win 8 Dev Preview, I had to choose Nat in settings, networking to allow connection to the internet. I have not been able to see my other PC's using this setting. When I change the network settings to Bridged Adapter, I can see the other PC's (haven't been able to actual connect yet) but then cannot connect to the internet. My adapter is an Intel WiFi 5100 AGN which is an Intel Pro/1000 type wireless adapter. I would love to set this up to do both. Anyone have any suggestions
     
  2. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    Hey Ted;
    First make sure that your Win8 machine is in the same workgroup as the other machines on the network (host machine as well as others).
    Set the network adapter setting from within the settings menu in VirtualBox to "Bridge Adapter" make sure that the proper adapter is selected below that (should be auto populated, but check to make sure in case you have more than one).
    Determine in advance the IP addressing schema that your existing network is using... I will assume that you are using the private reserved class C, network of 192.168.1.0 through 192.168.1.255 with a subnet mask of 255.255.255.0 and a default gateway address of 192.168.1.1 You will need to have this information available when configuring the virtual adapter within the VM and you can acquire it by inspecting the properties of IPv4 in the properties of you host machines adapter that you are bridging.
    Now boot your Win8 VM and hold the windows key and tap the R key to evoke the Run dialog box and type
    ncpa.cpl
    select the adapter and right click and choose properties
    uncheck IPv6
    select IPv4 and click the properties button
    choose "Use the following IP address: and enter
    IP address: 192.168.1.222 (the last octet in this case .222, must be unique to the network and unused by anyother network node)
    Subnet Mask: 255.255.255.0
    Default Gateway 192.168.1.1 (the address of the inside edge of your router)
    choose "Use the following DNS server addressess: and enter
    Preferred DNS server: 192.168.1.1 (the inside address of your router, usually will forward DNS queries without issue, however if not use the DNS server addresses of your ISP.
    Alternate DNS server: 8.8.8.8 (Google public DNS servers 8.8.8.8 and 8.8.4.4)
    These setting while a pain in the butt, will support both network / computer browsing as well as continued web surfing on the guest and host operating system. And necessary because by default the VM adapter uses a private reserved addressing scheme from the 10 network with a class C subnet mask which is a completely separate subnet / collision domain.
    If the problem persists post back and we'll work through it
    Regards
    Randy
     
    2 people like this.
  3. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65
    The first question that springs to mind is in the settings menu should I check wired connection? The VM does not seem to see my adapter if it is unchecked.

    I have set up the settings the way you suggest above with no luck at all. IVp6 unchecked, added the DNS settings etc (Yes you are correct in my type of adapter. I type 192.168.1.1 then my password to get into my router settings. I have a Linksys 4200e dual band router.) I have had no luck at all with these settings I can not connect to my wireless router, network or internet. I seem to have lost everything.

    I am just unsure if the time spent going forward is worth the effort to get this set up.
     
  4. Trouble

    Trouble Noob Whisperer

    Joined:
    Nov 30, 2009
    Messages:
    13,845
    Likes Received:
    833
    I have to admit that I'm temporarily at a loss, as I'm not sure I understand the question marked with emphasis above?
    I have included screen shots of my own configuration in the hope that they may help with your issue. I disabled by two physical wired adapters on my host machine leaving only the physical wireless adapter enabled so Vbox had no other option but to use my wireless adapter (just to see if the connection behaved any differently on a wireless card bridge from the host to the VM) the host machine is still configured to use DHCP on the wireless card, except for the default gateway which I have manually assigned, then the guest machine's adapter (Intel PRO/1000 MT Desktop Adapter) is configured with static IP addressing assignments as described above and shown in my screenshots (unique to my own home network).
    Hope this helps
    Randy
     

    Attached Files:

  5. Medico

    Medico Senior Member

    Joined:
    Sep 20, 2011
    Messages:
    1,158
    Likes Received:
    65
    Worked for several hours on this and finally gave up. I set up a dual boot system with Win 7 Ultimate (default) 64 Bit and Win 8 DP 64 Bit. Will be Imaging the setup tomorrow (too late tonight). VD. This works to install in the Win 7 partition, but not to install in the unallocated space. As soon as I burned disk, worked like a charm. Thanks for all your time spent on this. Some day perhaps I will work on the Virtual Box again, who knows. I tried to summarize my installations in this thread.
     

Share This Page

Loading...