DigitalPersona Personal Says Fingerprint Scanner Not Connected but it is..

Discussion in 'Windows 7 Help and Support' started by bDawk20, May 22, 2011.

  1. bDawk20

    bDawk20 New Member

    Joined:
    May 22, 2011
    Messages:
    8
    Likes Received:
    0
    I have read many other forums and message boards, contacted Dell, and other ways to remedy this and all have been unhelpful. If anyone can please help me with this I'd appreciate it. Biometrics works and I can log into Windows with my fingerprint, but DigitalPersona won't work, which means I can't use my fingerprint to log into websites. Not a big deal, but if I paid for the service I'd like to actually use it. If it helps I have a Dell Studio 17 that came with Windows Vista, but I upgraded to Windows 7 (DigitalPersona still worked after this). I believe it is a 64 bit operating system (at least that's what it claims under My Computer properties). The problem began when a Dell Technician did a Dell Connect and played around with drivers while trying to fix a problem I was having with my webcam. The problem turned out to be a hardware issue so they sent someone over to replace it and it worked fine. But after testing to see if it was something with the driver, the DigitalPersona stopped working (at least that is around the time it seemed to stop working). He may have deleted certain items in the Device Manager (without telling me what he was doing or why, which annoyed me seeing how the DigitalPersona started to not work after).

    I have tried the following:

    -Uninstalled DigitalPersona completely and reinstalled it
    -Used the Repair option
    -Tried to Run as Administrator
    -Reinstalled the driver for Biometrics according to Dell Support website

    If anyone can help I'd really appreciate it again. Thanks in advance,

    Anthony
     
  2. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    You did the right thing in reinstalling drivers for the items involved in your problem. I suppose the Webcam or Digital Persona situation might be at issue.

    Have you tried disabling the Webcam to see if Persona would work again. I suppose there is a possiblity they have some resource or protocol in common that might exclude one or the other.

    Did you update your Digital Persona drivers and utilities from the website?

    If you want to know what the operating system is for sure, hit Winkey + Pause or open the System in Control Panel.
     
  3. bDawk20

    bDawk20 New Member

    Joined:
    May 22, 2011
    Messages:
    8
    Likes Received:
    0
    Thanks for the reply. The webcam and fingerprint software never had a problem working together before, but I suppose something could be connected between them. I think it's more likely when the Dell technician disconnected the USB drivers and played around with the other devices in the Device Manager he deleted something that is causing it to no longer work. What is so odd is that the fingerprint is connected and works with the Dell software to sign into the computer, yet the DigitalPersona software says the reader is not connected.
     
  4. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    I suppose you have checked the Device Manager to see if any problems are showing. Do you know if Digital Persona shows up as some type of device there?

    It would seem on the surface that the Digital Persona software or drivers are not working correctly. Did you have to do any special procedures to register the device with that software?
     
  5. bDawk20

    bDawk20 New Member

    Joined:
    May 22, 2011
    Messages:
    8
    Likes Received:
    0
    There are no problems showing. I do not seeing DigitalPersona, but I do see Biometric Devices and under that I see Authen Tec Inc. AES2810.
     
  6. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    All I can do as far as drivers is guess. I will assume you purchased the device from Dell and are downloading drivers from there. The table located on this Authen Tec site gives information about Vendors and Software. Maybe you can use the information to make sure you have the correct drivers.

    The reason it may have worked after the Upgrade from Vista might be something was brought forward with that upgrade and now has been changed.

    I don't really have any other ideas, so I will be doing some research and perhaps someone else will come along who knows about your problem.

    Edit:
    I found this thread if the link back works.
    http://windows7forums.com/windows-7-support/5732-digitalpersona-dont-work.html

    The last entry seems to have a solution you might try.
     
    #6 Saltgrass, May 24, 2011
    Last edited: May 24, 2011
  7. bDawk20

    bDawk20 New Member

    Joined:
    May 22, 2011
    Messages:
    8
    Likes Received:
    0
    That is one of the threads I had read.. the one solution won't work because it's only for 32-bit OS and mine is 64-bit. The last solution suggested on the thread I also tried, but it did not work (unless I did something wrong)
     

Share This Page

Loading...