Disk Boot Failure

madhouse

New Member
Yesterday I finally managed to upgrade from XP to Vista Ultimate after a few problems I encountered along the way. Today I decided to uninstall some programs that I no longer needed. So I first started uninstalling Corel Paint Shop Pro X. Halfway through the uninstallation process I got the BSOD and the system promptly rebooted itself. Except the system didn't boot up because I got the error message "DISK BOOT FAILURE, INSERT SYSTEM DISK AND PRESS ENTER". So I loaded my Vista DVD into the drive and pressed enter but the same error message came back. What can I do to resolve this?
 


Mike

Windows Forum Admin
Staff member
Premium Supporter
It could be due to problems dealing with your hardware configuration or some drivers you don't have that you may not know you need. If you have an Intel chipset visit their website to see if they have Windows Vista drivers for your machine -- some RAID configurations or Intel chipsets require these drivers. Please post your system specs and there will be more information to try and help you.

Did you try doing an OS repair when booting with the Vista disc?
 


thomasiain

New Member
boot drive failure

my Vista boot drive, a Maxtor 6L200M0, also failed unexpectedly. i installed the RC1 version on a 35Gb primary partition, leaving about 160Gb for my XP partition.
everything ran smoothly for about 2 months until when trying to install a MIDI keyboard it didn't appear to support. upon my attempt at booting Vista the next time at the OS selection screen it gave the error message 'BIOS does not be installed'.
i have tried to boot Vista but each time it searches for a boot drive and does not find one. from what i can see, booting from the partition is disabled as i can still access the data from my XP OS.
is there any way of 'enabling' the booting ability of the partition?

i have a limited knowledge of the advanced workings of hard drives and any help on this issue would be greatly appreciated! thanks
 


g6672D

New Member
I got a Boot Failure after running System Restore to move it forward in time (I went back one step too far before that). But it corrected itself somehow or other. My PC is ancient stuff anyway...

By the way, System Restore is GREAT!
 


U

Unregistered

Guest
I've had the same problem. However, the PC seems to boot when the Vista disk is in the DVD drive and set to boot before the HDD. As long as it asks me to 'Press a key to boot from CD or DVD', it'll then go on to boot. Tried various boot record repairs, none seemed to work.
 


S

Strange Stew

Guest
I've had the same problem. However, the PC seems to boot when the Vista disk is in the DVD drive and set to boot before the HDD. As long as it asks me to 'Press a key to boot from CD or DVD', it'll then go on to boot. Tried various boot record repairs, none seemed to work.

Having the same problem too. Recently did a clean install of Vista business on a raid setup. Computer boots fine with install disk in drive, wont boot otherwise. Any help greatly appreciated
 


M

Mshell

Guest
Having the same problem too. Recently did a clean install of Vista business on a raid setup. Computer boots fine with install disk in drive, wont boot otherwise. Any help greatly appreciated
Same problem here. Used to work with the install disk in the drive. I think the problem is that Vista installs its bootloader in the mbr, which in my case is on my other hd (where I've installed WindowsXP). I've know disconnected this drive (to prevent Vista interferring with it), but now it doesn't boot at all. I'm going to spend a few more minutes on trying to find a solution for this (i.e. finding a way to have vista rewrite its loader on the mbr of the current hd), but I'm afraid I have to do a new clean install to get it all to work.
 


St@nZ

New Member
Same problem here

Hi I'm a new user here:) . Anyway, I'm aso having the same problem like you guys- can boot vista when the installation cd is in DVD-ROM. I'm using AMD athlon 64 with Asus A8N-SLI mobo. Are you guys using AMD processor or NForce4 chip mobo? I think we need to find the hardware similarity to find the solution 4 this prob. TQ
 


sKeRt

New Member
I think I figured it out

I was having the same problem of the Boot Disk Failure....(Only boot with Vista DVD). I have an IDE drive and a SATA drive. My Vista OS is in my SATA drive so I had my boot proroity set to SATA first. BUT for some reason if I change it so that the IDE boot first I wouldnt have that problem anymore.

Try it out to see if it help.
 


Gatman

New Member
Ive had the same problem, not sure if you have the same setup but I have a sata raid array and a pata disk. I saw on another website that it Vista writes some boot config files to any pata disk seeing it as 0 in your set. I reinstalled with unplugging the pata drives and have had no problems since. Or like sKert suggested use the pata as 1st in the boot config.
 


Lee

New Member
I had the same problem with Windows XP after setting my two SATA drives to use RAID and mirror each other. Using the ideas on this post I notice my boot order included "Hard Disk" as one of the boot orders, but when I went to "Hard Disks" my external USB drive was set as number 1 in the order. I moved my RAID controller to number 1 and problem solved.
 


U

Unregistered

Guest
mine does the same thing...only boots off of a cd...did u find any way to fix it....
 


ScottyPimpin

New Member
I just found a fix for this problem 5min ago. I was getting the same error and was determined to figure it out.. After re installing and getting the same error i looked in the bios. I have 2 hard drives, a 250GB SATA (Vista OS) and a 500GB SATA (Storage). I always plug my hard drives into the sata ports closest to the drive bays. Well turned out the 500GB Storage drive was in Sata port #3 and my 250GB OS hard drive was in SATA port #4. I hooked the 250gb HD into Sata port #1 re installed vista and walla. problem solved.

Kind of dumb really because XP doesn't have this issue.. but it worked for me.
 


Mekoa

Extraordinary Member
This would explain my issue as well.

Main machine has 3 SATA drives, 36gb Raptor (System, Sata port 6), 320gb WD Cav (Dump, Sata port 4), 320gb Seagate (Dump, Sata port 2). Installed Vista x86 onto the Raptor, wont boot unless CD is in.

However, I have a second machine with 2 x IDE (120/200) and a Sata 250. Installed onto Primary IDE Master and it boots fine.

Gonna move my drives around when I get home tonight and test. Hoping this is the fix!

And yeah Scotty, XP doesnt have this issue. Bit of a pain :<
 


D

Darunada

Guest
Fixed it!

I have two hard drives in SATA, and one on secondary IDE slave.

Vista is installed on SATA 1, but setting it to boot the IDE drive first fixed it, for some strange reason.

Thanks for the fix!
 


U

Unregistered

Guest
Had the same problem and the guidance here pointed me in the correct direction.

My system had been working correctly for a month (Vista Home) and i tried an upgrade to ultimate. This failed and was rolled back.

Then a few days later my system would only boot as per the above - with cd in the drive.

Swapping the boot order on the two hard disks resolved the problem. From the postings and information that I have found this is only a problem for multiple disk machines.

Though I'm not sure how the boot record is moving!
 


U

Unregistered

Guest
Thanks for the fix guys. Like alot of other people here, switching IDE to first boot worked. Awsome job guys. Thanks again.
 


U

Unregistered

Guest
I have the same problem, however this is a new build, with an intel extreme 6850 cpu,asus striker extreme mobo, using windows vista 64 ultimate.
Everything loaded in nicely, I was in windows beginning to load the mobo drivers, gpu drivers, etc. It asked for a system restart, so I said yes, what did not realize is that windows was downloading it's updates, so before the system could reboot it had to download those , 47 of them to be exact, once it was done the system rebooted, went to a black screen with a cursor blinking in the top left corner, I figured it was still working, but half an hr went by and still nothing. SO I shut down the system and restarted it, everything seemed to be booting up nicely until it went to a black screen and said
disk boot failure, insert system disk and press enter. I installed vista disk in my cd drive, and it would not read any of the drives. Starting to think windows vista has issues.
 


U

Unregistered

Guest
I cannot seem to boot my laptop. To begin, I partitioned my hard drive and some how, accidentally made the new partitioned drive active. When I rebooted my pc, it couldn't find the operating system. So, I used g-parted live and got access to my drives. I put the newly created partition back into the main drive (c drive), flag the c drive to boot, applied all actions, exited and restarted my pc. My pc gives me two options this time:
1. To use Start-Up Repair
2. To start Windows normally

I choose the first one and all I get is the little Microsoft icon, with the green bar running on and on forever. So, yet again, I restart my pc and choose to do start up repair. It acts like it will run it, but then I just get a black screen and it stays that way. I can't access anything. If someone has some advice I would greatly appreciate it, otherwise I'm just going to have to completely wipe my pc and I would prefer not to do that.
 


fuzzylumps

New Member
Thanks Skert & Gatman. fixed IDE as 1st boot, working fine now
 


This website is not affiliated, owned, or endorsed by Microsoft Corporation. It is a member of the Microsoft Partner Program.
Top