Disk boot failure

Discussion in 'Windows 7 Installation' started by nickdrums, Jun 21, 2010.

  1. nickdrums

    nickdrums New Member

    Joined:
    Jun 21, 2010
    Messages:
    10
    Likes Received:
    0
    I am having a lot of trouble with Windows 7 booting. Here are some details:

    - single hdd machine (750GB); single partition
    - Win7 64bit home edition
    - I am getting the disk boot failure message on boot (nothing in particular changed)
    - booting from the win CD, repair seems to run ok but does not fix the problem (there are no operating systems listed when I click repair)
    - have tried running repair several times in succession, but no luck
    - I HAVE recovered from this problem twice before, using some combination of windows repair and testdisk
    - testdisk says that the partition table is invalid - have used testdisk to recreate the partition table and rewrite the MBR
    - when in win recovery, at command prompt, trying to switch to C: drive results in "the device is not ready"
    - testdisk can find the NTFS partition fine, and all my data files are visible in the testdisk file browser
    - Oddly, if I boot from a CD into linux (to use testdisk) twice, on the first time repairing the partition table, then on the second time the partition table is STILL broken.
    - It's as though booting the machine breaks the partition table - could this be a virus?

    Any help greatly appreciated!

    Nick.
     
  2. nickdrums

    nickdrums New Member

    Joined:
    Jun 21, 2010
    Messages:
    10
    Likes Received:
    0
    Further info: when I run testdisk, the first message encountered reads "partition sector doesn't have the endmark 0xAA55"
     
  3. nickdrums

    nickdrums New Member

    Joined:
    Jun 21, 2010
    Messages:
    10
    Likes Received:
    0
    A bit more info: testdisk also reports that there are hidden sectors on the disk:
    Code:
    Disk /dev/sda - 750 GB / 698 GB - ATA WDC WD7500AACS - 0
    
    Hidden sectors are present.
    
    size          1465147055 sectors
    user_max      1465147055 sectors
    dco           1465149168 sectors
    
    
    Not sure what this means? There are no bad sectors on the disk if I run hard disk health inspection
     
  4. nickdrums

    nickdrums New Member

    Joined:
    Jun 21, 2010
    Messages:
    10
    Likes Received:
    0
    Further info: a complete surface scan of the disk with SmartControl ran fine with no errors reported. The disk is physically fine, but there is a problem with the partition table which either testdisk is not resolving properly, or keeps getting corrupted at the boot stage, perhaps by a virus.

    Any comments?
     
  5. nickdrums

    nickdrums New Member

    Joined:
    Jun 21, 2010
    Messages:
    10
    Likes Received:
    0
    I seemed to make a big breakthrough on this yesterday, in that I changed the boot order in the BIOS to DVD > HDD > HDD (I think it was HDD > DVD > HDD before) and suddenly the testdisk partition table repair seemed to "stick" and windows recovery then had something to work with. All was heading in the right direction, Windows booted ok, but was behaving oddly - complaining about the absence of certain files.

    I decided to re-install Windows (upgrade rather than custom) to refresh all the OS files. This went through fine, but then on rebooting the machine it reverted to DISK BOOT FAILURE.

    I now seem to be back to square one, and even though the BIOS boot order is still correct, the partition table repair will not work as above.

    I'm even more suspicious of a virus - has anyone heard of anything like this? I have my data backed up, so would it cure the problem if I did a complete wipe of the machine and a fresh install of Windows 7?
     
  6. Veegertx

    Veegertx Honorable Member

    Joined:
    Nov 19, 2009
    Messages:
    444
    Likes Received:
    19
    fresh will definitely wipe all viruses. make sure you scan all added by you before adding them back
    make sure you delete the small partition and the large and choose full format, takes longer
    this is only a VM but you get the idea

    disk.
     
    #6 Veegertx, Jun 22, 2010
    Last edited: Jun 22, 2010
  7. Nibiru2012

    Nibiru2012 New Member

    Joined:
    Dec 16, 2009
    Messages:
    466
    Likes Received:
    18
    I have found, at least for me, that if I have more than one hard drive connected to the mobo the windows 7 install goes finicky and won't install right.

    You might try disconnecting the extra hard drive and then try your install on the primary drive you wish to install it to and see what happens. It works for me.

    If you're using a SATA hard drive, enable the AHCI feature in the BIOS and that will help too.
     
  8. Saltgrass

    Saltgrass Excellent Member
    Microsoft Community Contributor

    Joined:
    Oct 16, 2009
    Messages:
    15,157
    Likes Received:
    393
    If your install is being corrupted, I am sure we would agree something is causing the problem. Could it be a virus, yes, but it could also be several other things.

    If you were overclocking it might get corrupted. It could be a bad drive, or a controller problem. If your memory was having problems it could be corrupting data, as could a bad connection or even a power supply. Maybe your Processor is not running correctly. :( Have you checked for a bios update that might have an update to allow for larger hard drives.

    When I see someone using a utility to mess with the partition table, I get a little nervous. Is that utility completely Win 7 compatible? How many partitions do you show and what type of partitions are they?

    Perhaps you should try another utility to check your drive. So you might download Partition Wizard and use the bootable CD to check your drive from outside Windows. It also has a rewrite MBR option if you need it.
     
  9. pcs3657

    pcs3657 New Member

    Joined:
    May 6, 2010
    Messages:
    210
    Likes Received:
    13
    It looks like its your sata connector that is giving you all the trouble. i would suggest you to remove the connector from the mobo clean the socket with spirit or other cleaner fix it back.

    Fresh install Windows 7 create separate partitions for os and data, i would advise you to create a 40-60 gb partition for os
     

Share This Page

Loading...